Firefox features web page talks about the global Private Browsing mode

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ehsan, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Perhaps it's about time for us to update that piece of this page.
(Reporter)

Updated

5 years ago
Component: General → Pages & Content

Comment 1

5 years ago
Blog talking about new feature:

https://blog.mozilla.org/blog/2013/04/02/firefox-gives-you-more-control-over-your-privacy/

Should we talk about both the global and per tab feature or is that too much details for a high-level features page?

Maybe the copy could be updated talk about both global and private, but within the same amount of text that we have now.
(Reporter)

Comment 2

5 years ago
No, the global private browsing mode is removed in Firefox 20, and starting from today, we'll only support per-window private browsing.

Comment 3

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> No, the global private browsing mode is removed in Firefox 20, and starting
> from today, we'll only support per-window private browsing.

Does the current text even give private vs tab context? It seems that the image is mostly wrong now. 

Is there a new SUMO article about the per-window private browsing?

Comment 4

5 years ago
Our web site was just made out of date. I think Laura knows more about the plan for cleaning up those pages.
(Reporter)

Comment 5

5 years ago
(In reply to Chris More [:cmore] from comment #3)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> > No, the global private browsing mode is removed in Firefox 20, and starting
> > from today, we'll only support per-window private browsing.
> 
> Does the current text even give private vs tab context? It seems that the
> image is mostly wrong now. 

"You can slip in and out of private browsing mode quickly".  The image is also definitely wrong.

> Is there a new SUMO article about the per-window private browsing?

Yes: <https://support.mozilla.org/en-US/kb/private-browsing-browse-web-without-saving-info?esab=a&s=private+browsing&r=0&as=s#os=mac&browser=fx20>

Not sure what the OS and version agnostic version of the URL is.

Comment 6

5 years ago
There is a Q2 project to create a new Firefox family page and new product content that will obsolete most of this content.

Jbertsch: Is this page in the plan for Q2 to be obsoleted with something different?
(Reporter)

Comment 7

5 years ago
Can't we just fix this text in the mean time?  Q2 can mean up to 3 months from now.  :-)

Comment 8

5 years ago
Jbertsch: What do you want to do here? 

:Ehsan: Please see free to do a pull request and edit yourself:

https://github.com/mozilla/bedrock/blob/master/apps/firefox/templates/firefox/features.html
Laura - please advise.  Ping me if you want to discuss.  We can make a quick text change this week or early next if that is all that is needed.

Longer term, we are working with Laura to refresh all the "product features" Fx desktop content - probably with a final launch date timed with the Australis launch.
Flags: needinfo?(lforrest)
(Reporter)

Comment 10

5 years ago
(In reply to comment #8)
> Jbertsch: What do you want to do here? 
> 
> :Ehsan: Please see free to do a pull request and edit yourself:
> 
> https://github.com/mozilla/bedrock/blob/master/apps/firefox/templates/firefox/features.html

I wanted to argue that I'm not really the best person to write up this text, but then I realized it will take me less time to just go ahead and do it. <https://github.com/mozilla/bedrock/pull/746> :/

But I still believe this text should be updated by somebody more familiar with what to write on these kinds of pages...
Jbertsch, can you comment on the text in the pull request? You can see the old/new text here: https://github.com/mozilla/bedrock/pull/746/files
sgarrity:  I've asked Matej to take a look.  Thx!
added ozilla.org kanban card
Priority: -- → P3
The new text looks good to me, but "Open" after the colon should be capitalized. Thanks.

Comment 15

5 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/08d5624b45bccd7073a03cc077a161deaeffee76
Bug 857365 Update the private browsing description
This updates the text about the private browsing feature in order to match the new per-window PB mode.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 16

5 years ago
:ehsan - Thanks for the pull request and text. Go team work! :)
Duplicate of this bug: 858331
You need to log in before you can comment on or make changes to this bug.