If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

some about:home content is not displayed at first start-up

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: xti, Assigned: bnicholson)

Tracking

({reproducible})

Trunk
ARM
Android
reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 unaffected, firefox22+ verified, firefox23 unaffected, firefox24 unaffected, fennec22+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 732674 [details]
screenshot

Firefox for Android
Versions: 23.0a1, 22.0a2
Device: Samsung Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Open app using a clean profile

Expected result:
The home page is loaded and the following data is displayed:
* Top Sites - with 6 thumbnails
* Sync or Firefox Market banner
* Add-ons

Actual result:
Only Top Sites title is displayed (see attached screenshot). 

Note:
Gecko is loaded as expected at the first start-up.
If you can reproduce this, try to get a logcat.
I saw this as well on my Galaxy Tab 10.1 yesterday (3.1) on new profile creation after first-launch. Thanks for filing Cristian.
(Reporter)

Comment 3

5 years ago
Created attachment 733315 [details]
logcat

I hope that these logs will be useful. This bug was reproducible on the last Fennec start-up. Let me know if I can help with anything else
E/GeckoAppShell( 4492): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 2246 ("GeckoBackgroundThread")
E/GeckoAppShell( 4492): java.lang.NullPointerException
E/GeckoAppShell( 4492): 	at org.mozilla.gecko.widget.AboutHomeContent.loadTopSites(AboutHomeContent.java:134)
E/GeckoAppShell( 4492): 	at org.mozilla.gecko.widget.AboutHomeContent.access$000(AboutHomeContent.java:34)
E/GeckoAppShell( 4492): 	at org.mozilla.gecko.widget.AboutHomeContent$2.run(AboutHomeContent.java:162)
E/GeckoAppShell( 4492): 	at android.os.Handler.handleCallback(Handler.java:605)
E/GeckoAppShell( 4492): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoAppShell( 4492): 	at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell( 4492): 	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:32)

....

and D/GLSurfaceViewGroup( 2242): Skipped drawing due to suspendDrawingUntilResume() ?
Regression from bug 852312?

Looks like a Sriram bug.
Assignee: nobody → sriram

Updated

5 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → 22+
I seem to hit this on new profile creation on first launch frequently (04/08, Nightly & Aurora)

Updated

5 years ago
Blocks: 852312
Comment #4 :x
Flags: needinfo?(sriram)
The APK in bug https://dl.dropbox.com/u/35559547/fennec-abouthome-fragments.apk seems to fix this. It looks like bug 838793 will fix this.
Assignee: sriram → nobody
Flags: needinfo?(sriram)
(Assignee)

Updated

5 years ago
Depends on: 838793
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838793
Mobile triage; just going to dupe this

Updated

5 years ago
Duplicate of this bug: 861608
Although this is being treated as a dupe, I am hitting this on 22 which is now on mozilla-beta. On startup:

E/GeckoAppShell( 4294): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 269 ("GeckoBackgroundThread")
E/GeckoAppShell( 4294): java.lang.NullPointerException
E/GeckoAppShell( 4294): 	at org.mozilla.gecko.widget.AboutHomeContent.loadTopSites(AboutHomeContent.java:134)
E/GeckoAppShell( 4294): 	at org.mozilla.gecko.widget.AboutHomeContent.access$000(AboutHomeContent.java:34)
E/GeckoAppShell( 4294): 	at org.mozilla.gecko.widget.AboutHomeContent$2.run(AboutHomeContent.java:162)
E/GeckoAppShell( 4294): 	at android.os.Handler.handleCallback(Handler.java:725)
E/GeckoAppShell( 4294): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoAppShell( 4294): 	at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell( 4294): 	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:32)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

4 years ago
status-firefox23: affected → unaffected
status-firefox24: --- → unaffected
For clarification, this is only affecting 22 which doesn't have the refactoring fix in bug 838793. This needs a small fix or a judgement call on risk with uplifting bug 838793 to Beta 22 which will fix this.
Status: REOPENED → NEW
Keywords: reproducible
Over to bnicholson since he owned bug 838793. Not a blocker for our first beta, given low user impact. Is uplifting bug 838793 the right call here Brian?
Assignee: nobody → bnicholson
status-firefox21: --- → unaffected
tracking-firefox22: --- → +
Summary: about:home content is not displayed at first start-up → some about:home content is not displayed at first start-up
(Assignee)

Comment 15

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #14)
> Over to bnicholson since he owned bug 838793. Not a blocker for our first
> beta, given low user impact. Is uplifting bug 838793 the right call here
> Brian?

I'd say yes, given the facts that a) it fixes this bug, b) it can reduce memory usage by ~4MB when the user isn't on about:home, and c) there haven't been any significant regressions reported. I'll go ahead and request approval.
Bug 838793 will be fixed for FF22b2
(Assignee)

Comment 17

4 years ago
Fixed by bug 838793.
Status: NEW → RESOLVED
Last Resolved: 5 years ago4 years ago
status-firefox22: affected → fixed
Resolution: --- → FIXED
Verified fixed on:
-build: Firefox for Android 22 Beta 2
-Device: Samsung Galaxy S2
-OS: Android 4.0.3
status-firefox22: fixed → verified
You need to log in before you can comment on or make changes to this bug.