Closed Bug 857460 Opened 11 years ago Closed 11 years ago

[SMS][Contacts] Phone numbers should be mapped regardless of formatting (country code vs parentheses)

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 866135

People

(Reporter: jsantell, Unassigned)

Details

When having a contact with a phone number in this format: "(717) 555-1234", and then receiving a text from "+17175551234" (same number, different format), it does not display my contact's name, just the number. Infact, when texting the contact number, I now have two text "threads" -- one from "+17175551234" and one from "Joe Doe". I would expect any permutation of the number to be recognized as the same contact.

Unagi, B2G 1.1.0.0-prerelease, built from SHA caaa81f7dfca6
Summary: [Contacts] Phone numbers should be mapped regardless of formatting (country code vs parentheses) → [SMS][Contacts] Phone numbers should be mapped regardless of formatting (country code vs parentheses)
Note, this seems to map an incoming text message from +11234567890 to 1234567890 fine.

Also, if other Android users run into this and want to keep testing on their phone without learning everyone's phone numbers, this app formatted all of my Google contacts on my Android into +1########## format to match incoming SMS format on B2G: https://play.google.com/store/apps/details?id=org.peterbaldwin.client.android.cleanup -- Unfortunately importing doesn't overwrite previous entries (or maybe fortunately, probably intended), so you'd have to nuke your contacts if you already imported them once
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Gregor, is this related to one of the other Contacts bug we have ?
Flags: needinfo?(anygregor)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Gregor, is this related to one of the other Contacts bug we have ?

I can't reproduce this bug. It works for me in the US.
I saved in format (415)123-4567 and receiving a text showed me the correct contact.
Flags: needinfo?(anygregor)
This looks a lot like Bug 865164, and I saw this on Etienne's phone 2 days ago. So I find it strange that it's working for you Gregor :) Or maybe... you have no spaces at all in your example, could that be it ?
(In reply to Julien Wajsberg [:julienw] from comment #4)
> This looks a lot like Bug 865164, and I saw this on Etienne's phone 2 days
> ago. So I find it strange that it's working for you Gregor :) Or maybe...
> you have no spaces at all in your example, could that be it ?

Hm I don't see a space on the numbers keyboard. How do I add one?
this happens when you import from eg Google.
this bug affects me too.

for example, I have two threads on SMS app: one from 05185009800 and other from 85009800

the 8 digit number is stored on my Contacts contact, so when I send a message to it, it appears on Messages with contact's name and photo;

the incoming messages from this contact, thought, are shown on a separate thread, because they come prefixed with area code and are recognized coming from a different contact; only the number is shown


by the way, I'm also using a Unagi device, B2G 1.1.0.0-prerelease BuildID 20130426070204
Does it work in the dialer app when you receive a call?
The matching regardless of formatting should be fixed with bug 866135.
Note that bug 866135 was not in 1.1.0 before the 2nd of May, so it makes sense that your build is still buggy.
duping
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.