Undo message delete fails when offline

NEW
Unassigned

Status

defect
--
critical
6 years ago
a year ago

People

(Reporter: mitra_lists, Unassigned)

Tracking

(Depends on 1 bug, {dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR: 
1Go Online 
2Delete a message - it disappears
3Undo - it reappears
4Go Offline
5Delete a message - it disappears
6Undo - it doesn't reappear
7Go Online - it still doesn't reappear

it appears that Undo doesn't work when offline,

Note that it looks like the data gets lost completely, i.e. this is a data losing bug so I marked it major (I think that's correct, but please change if not)
Mitra, are steps 1-3 necessary?
Is this perhaps a duplicate of something in https://bugzilla.mozilla.org/buglist.cgi?f1=short_desc&list_id=6205760&short_desc=undo&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&o1=nowordssubstr&resolution=---&o2=nowordssubstr&query_format=advanced&f2=component&short_desc_type=allwordssubstr&v1=news%20compos&v2=pref%20account%20compos&product=MailNews%20Core&product=Thunderbird ?

I tried and reproduced, but what I found is the message is in trash folder. It's not visible in trash until after going back online, change folders and going back in trash. Do you agree?
Severity: major → critical
Keywords: dataloss
(In reply to Wayne Mery (:wsmwk) from comment #1)
> I tried and reproduced, but what I found is the message is in trash folder.
> It's not visible in trash until after going back online, change folders and
> going back in trash. 

I also saw Bug 719752
Summary: Unfo fails when offline → Undo fails when offline
(Reporter)

Comment 3

6 years ago
Steps #1-3 aren't necessary to cause the bug, sorry, was trying to be helpful by showing that the identical sequence works ONLINE but not OFFLINE, and giving a sequence that clearly showed a bug related to online/offline. 

Wayne - your comment #2 might be what actually happens.  I do see it in Trash now after going back Online - that really shouldn't happen - if I didn't find it (I looked in the Trash, but before going online) then I doubt most users would.
(Reporter)

Comment 4

5 years ago
Can this one be revived, its actually a data-losing bug since once you've hit Delete, or Archive then Undo no longer works to retrieve it, and contrary to what Wayne suggests it doesn't seem to come back - instead empty messages with a date in 1969 are caused. 

The same problem appears when it goes to Archive. There also seem to be weird interactions with gloda - i.e. after deleting or archiving and hitting Undo then a Search comes up with the message in the multi-line version, but there is no way to open the message.
something is rotten in denmark.
Mitra, can you check please if this also fails in version 17?
Status: UNCONFIRMED → NEW
Component: General → Backend
Ever confirmed: true
Flags: needinfo?(mitra_lists)
Product: Thunderbird → MailNews Core
(Reporter)

Comment 6

5 years ago
Version 17?   

I'm on Version 31.0 and it fails in that.
Flags: needinfo?(mitra_lists)
(Reporter)

Comment 7

5 years ago
I can confirm the bug is there on V17
related to bug 567716?
Depends on: 567716
OS: Mac OS X → All
(Reporter)

Comment 9

5 years ago
I don't understand bug #567716 so can't comment. I know that this is probably one of the two most critical TB bugs at the moment (i.e. data-losing and hit really frequently).
This still fails for me
Summary: Undo fails when offline → Undo message delete fails when offline
You need to log in before you can comment on or make changes to this bug.