[Buri][SHIRA-48052]'First start of pre-installed apps not possible while offline

RESOLVED DUPLICATE of bug 861740

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED DUPLICATE of bug 861740
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: kward)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: [apps watch list1][NPOTB])

(Reporter)

Description

5 years ago
Firefox os  v1.0.1
 Mozilla build ID: 20130327153857
 
 +++ This bug was initially created as a clone of Bug #429990 +++
 
 DEFECT DESCRIPTION:
 All pre-installed apps do not work when launched for the first time while the device is offline.
 
 REPRODUCING PROCEDURES:
 1. Start device without SIM card, do not attach device to a WIFI network
 2. Launch any pre-installed app, e.g. "distant orbit" game.
 
 Actual result:
 Device shows an error message indicating that the applicaion failed to load properly.
 
 Note: The apps do work after having been launched once while online. Afte  initial launch, the apps do also work in offline mode. However, this is not sufficient, customers expect that all pre-installed apps do work out of the box.
 
 EXPECTED BEHAVIOUR:
 App launches successfully and can be used.
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #429990 description ++++++++++
 Additional info:
  for example Wikipedia?
 this is host (right?), and why the first time launch, it's page error
 displayed?
 but if i manually do try-again, then it can refresh to display correct UI.
 #1 is just excuse.
 
 correct behavior should be:
 1. prompt to user that some info will be downloaded. if data transfer is
 required, alert of charge is mandatory.
 2. if user confirms to download, go to loading the app page cache.

Updated

5 years ago
blocking-b2g: --- → tef?
Summary: [Buri][TMO-48052]'First start of pre-installed apps not possible while offline → [Buri][SHIRA-48052]'First start of pre-installed apps not possible while offline
If these are hosted apps, there is no way nothing can be shown without connection. That is the expected behaviour, if you want to have something to be shown, it needs to be a packaged app.
blocking-b2g: tef? → ---

Comment 2

5 years ago
Comment 1 is correct.  Developers would need to make their app a packaged app to offer the ability to load an app with some assets available to the user without data access.
(Assignee)

Comment 3

5 years ago
Working with 3rd party developers of hosted game apps to get them packaged. Set a deadline with 3rd party developers to submit to Marketplace by Close of Business California time on April 10. Will work with DT team to select from games submitted by deadline. 
Reviewing options and behavior of the other hosted apps: 
Accuweather - Hosted
Facebook - Hosted
Twitter - Hosted
Youtube - Hosted
Wikipedia - Hosted
(Assignee)

Updated

5 years ago
Whiteboard: [apps watch list]
(Assignee)

Updated

5 years ago
Whiteboard: [apps watch list] → [apps watch list1]
(Assignee)

Updated

5 years ago
Depends on: 861740
tef? as changes are needed to move hosted apps to packaged
blocking-b2g: --- → tef?

Comment 5

5 years ago
(In reply to kward@mozilla.com from comment #3)
> Working with 3rd party developers of hosted game apps to get them packaged.
> Set a deadline with 3rd party developers to submit to Marketplace by Close
> of Business California time on April 10. Will work with DT team to select
> from games submitted by deadline. 
> Reviewing options and behavior of the other hosted apps: 
> Accuweather - Hosted
> Facebook - Hosted
> Twitter - Hosted
> Youtube - Hosted
> Wikipedia - Hosted

Marking as a Not Part of the Build blocker so that this doesn't fall off of our radar.
Assignee: nobody → kward
blocking-b2g: tef? → tef+
Whiteboard: [apps watch list1] → [apps watch list1][NPOTB]
(Assignee)

Comment 6

5 years ago
In Apr 10 Content Program meeting DT Poland has approved current first run user experience for
> Accuweather
> Facebook
> Twitter
> Youtube 
> Wikipedia
New Packaged apps for Games and Marketplace are included in new build associated with bug 861740.  These elements combine to resolve the reasons for this bug.

As soon as 861740 is closed this is ready for retest/closure. I've asked Joe Cheng to confirm that 861740 should be closed.
Flags: needinfo?(jcheng)
let's track bug 861740 instead
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jcheng)
Resolution: --- → DUPLICATE
Duplicate of bug: 861740
You need to log in before you can comment on or make changes to this bug.