Toolbar customizing dialog improperly displayed in some arrangements of multiple displays with mixed HiDPI support

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: sarmas.hikaru, Unassigned)

Tracking

(Blocks: 1 bug)

20 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 732866 [details]
130404-0003.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

i tried to open a toolbar customizing window(right click on a toolbar -> customize)
this problem occurs only when...
-one or more external monitors are connected to retina mac book pro.
-using a retina display as retina mode.
-primary display(where mac OS menu bar belongs) is one of external display.
-firefox is opened in retina display


Actual results:

the window shows up as nonretina mode but OSX handle it as retina mode window,namely it displays 1/4 of the whole window. the window is not closable except restarting FF or Moving FF window to non retina monitors to exit firefox's retina mode.


Expected results:

toolbar customizing window also should be retina mode.

Comment 1

6 years ago
I'm not sure where Retina bugs go.
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Does this problem also happen with current mozilla-central nightlies?  (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-23.0a1.en-US.mac.dmg)
Blocks: 785330

Comment 3

6 years ago
Created attachment 740307 [details]
Screenshot when attempting to replicate

I get a very different sort of graphics corruption when I try to bring up the dialog. It seems to be creating a larger window than it needs and not repainting it properly. Also note the missing buttons.

...but my icons are retina...

My external monitor is 1920x1080 loDPI on HDMI and is set to primary.

Comment 4

6 years ago
Nightly 23.0a1 (2013-04-18)
Testing on a Retina MBP running OS X 10.7.5 with today's mozilla-central nightly and the one from 2013-04-18, I can't reproduce either of your problems.

I arranged my (non-HiDPI) external display to the left of my MBP's build-in Retina display, and (in Displays : Arrange) dragged the titlebar to the top of my external display to make that the primary one.

Later I'll test on OS X 10.8.3.

Comment 6

6 years ago
My external is on the right. The bottoms of each desktop are flush. I updated my Nightly and can still replicate. Running the latest 10.8.3.
(Reporter)

Comment 7

6 years ago
Created attachment 740330 [details]
rendering bug in non retina display.(while this happens, toolbar customize window shows up properly in retina display
(Reporter)

Comment 8

6 years ago
(In reply to Steven Michaud from comment #2)
> Does this problem also happen with current mozilla-central nightlies? 
> (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-
> central/firefox-23.0a1.en-US.mac.dmg)

yes,the bug is still reproducable with updated nightly.
sometimes it works properly,but while it works properly in retina display, FF would get a bug if i move FF window into other monitor (attachment image of the comment7)

so with this condition
-one or more external monitors are connected to retina mac book pro.
-using a retina display as retina mode.
-primary display(where mac OS menu bar belongs) is one of external display.
I get a bugged toolbar customize window either in a retina display or external displays. and i don't know how to switch which monitor to get the bugged rendering window.
I can't reproduce this on OS X 10.8.3, either (testing with today's mozilla-central nightly).  I arranged my external monitor like Greg's.  I even tried restarting my computer after having made that change.

You guys should try testing with a clean profile.

But in any case, the (apparent) regression range for this bug is the same as that for bug 863922.  So it's possible that a fix for that bug will also fix this one.

Comment 10

6 years ago
I just factory reset Nightly and can still replicate.

Comment 11

6 years ago
I can reproduce a similar behavior. 
I have two screens, one is hidpi and one is lodpi. 
Open View=>Toolbars=>Customize.
Move the browser window from one screen to the other with opened Customize Toolbars Popup. 
Then the size of the popup is wrong, it is at half size or at double size. Also the position might be wrong. 
I guess something is wrong with chrome and a pixel scale factor is not correctly updated. 

Also you can sometimes corrupt some add-on popups, e.g. popups of Ghostery and NoScript.

I guess this bug is a duplicate of Bug 802335. 

I tested this with FF Nightly 23.0a1 (2013-04-26).
Actually, I *can* reproduce this bug (or something very close) when my external display is arranged to the right (testing with today's mozilla-central nightly on OS X 10.7.5).

> -firefox is opened in retina display

I'd forgotten about this in comment #0's STR.

For some reason I don't see the bug if my external monitor is arranged to the left.

Apparently the fix for 863922 doesn't fix this bug, since it landed on the trunk as of the 2013-04-26 mozilla-central nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: toolbar customizing window doesn't show up as retina mode when one or more external monitors are connected → Toolbar customizing dialog improperly displayed in some arrangements of multiple displays with mixed HiDPI support
Firefox 29 redid customization mode from scratch, including hidpi support, and the old code no longer exists.

For any bugs involving the new customization, please file new bugs.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.