Navigating focus between forms requires two taps

RESOLVED WORKSFORME

Status

Firefox for Metro
Input
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [forms][selection])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) tap on one of the text inputs in the test case enabling the caret monocle
2) tap on another text input

result: focus is cleared from the first and isn't set in the second. an additional tap will bring focus to second element.
(Reporter)

Comment 1

5 years ago
related - bug 851907
(Reporter)

Comment 2

5 years ago
Created attachment 732894 [details]
test case
(Reporter)

Comment 3

5 years ago
http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/helperui/SelectionHelperUI.js#697

currently by design. to fix this the selection handler needs to be reset to point to the new form input.
(Reporter)

Comment 4

5 years ago
Fixed by bug 857825.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.