Closed Bug 857674 Opened 7 years ago Closed 7 years ago

[Music] UI can sometimes gets corrupted when searching in the Playlist view

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: marcia, Assigned: dkuo)

References

Details

(Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021], retest_leorun4,[LeoVB+])

Attachments

(6 files, 1 obsolete file)

unagi, while using Commercial RIL:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/d467369d1b0c
Gaia   06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75
BuildID 20130403070204
Version 18.0

STR:
1. Load Music player
2. Perform a search for a search term you know is one of your songs
3. Observe attached screenshot
Better STR - I can confirm it happens with the Mozilla RIL as well.

1. Open Playlist mode and start playing a "most played" song
2. Pan down to get the search bar
3. Start typing in the search field
4. Entire UI moves to the left.

After that I have to close the music player and restart the app again.
blocking-b2g: --- → leo?
Summary: [Music] UI can sometimes gets corrupted when searching → [Music] UI can sometimes gets corrupted when searching in the Playlist view
Assignee: nobody → squibblyflabbetydoo
blocking-b2g: leo? → leo+
Ok, so this happens because the left edge of the screen keeps following where your cursor is in the text box (but only as you move to the right). However, I have no idea what's causing this.

Dominic, any ideas? I'm guessing there's something weird in the CSS, but I'm not very familiar with what the player does with CSS...
(In reply to Jim Porter (:squib) from comment #2)
> Dominic, any ideas? I'm guessing there's something weird in the CSS, but I'm
> not very familiar with what the player does with CSS...

I took a quick test and found this issue only happens after the album content page(SubListView) or the player page(PlayerView) loads, but actually what we did is just remove the hidden class of the two views, I am not sure there are any weird CSS in it, I will also investigate this.
update: I have tried to test on b2g desktop client, firefox nightly and unagi, and this issue is only reproduciable on device.
Assignee: squibblyflabbetydoo → dkuo
Whiteboard: mentoredbug mentor=dkuo
Dominic, are you working on this? If not, I would take it since I am familiar with the Music app.
Flags: needinfo?(dkuo)
Mihai, I have finished one 1.1 CS bug yesterday and going to fix this one, and I think for now I only have this one assigned, however if you want this, feel free to take it and I will find some other bugs to solve, thanks.
Flags: needinfo?(dkuo)
(In reply to Dominic Kuo [:dkuo] from comment #6)
> Mihai, I have finished one 1.1 CS bug yesterday and going to fix this one,
> and I think for now I only have this one assigned, however if you want this,
> feel free to take it and I will find some other bugs to solve, thanks.

Thanks Dominic, I'm still working on a few bugs right now, so you might as well work on it -- you should be more familiar with this than me.

I'll look for new bugs once I finish my current work.
Update:

Okay, by replacing gecko on my unagi with b2g18 and central, I found this issue is not reproducible on central. I am not familiar with how gecko adjust the viewport when there is an input element in an iframe, but accrdoing to my test result, it should be the different gecko cause this problem.

I tried to ask some help from gecko and Shih-Chiang told me that Robert might know what's going on here, Robert, would please comment on this bug? thanks.
Attached image Page layout of Music app (obsolete) —
The attached image is the page layout of music app. (I borrowed this from Jim's comment in https://bugzilla.mozilla.org/show_bug.cgi?id=838033#c3)

Myabe this can give everyone some ideas.
I think this one is more closer to the current implementation.
Attachment #746319 - Attachment is obsolete: true
I don't know.

In theory you could bisect along central to find a fix range. It probably wouldn't take too long.
Found steps to reproduce this issue 100% today:

1. Update device to build 20130510070207.
2. Open the music app.
3. Begin playing any song.
4. Tap on any category except for the main grid one. (Playlist, Artists, Albums, or Songs)
5. Begin entering text in the search bar at the top of the selected section.
6. Observe that as text is entered the screen is shifted to the left, eventually going almost entirely out of view.

Found on a Leo device running the following build from the moz 1.1 branch:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2aba3b5ac1c2
Gaia: fcaa90923894211c19b3544b5cb16eb0db5a6286
Build: 20130510070207
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #11)
> I don't know.
> 
> In theory you could bisect along central to find a fix range. It probably
> wouldn't take too long.

Okay, I will try to find a fix range, thanks for pointing this out.
Any luck finding the range?
Flags: needinfo?(dkuo)
Whiteboard: mentoredbug mentor=dkuo → mentoredbug mentor=dkuo, inarirun2
I haven't got a chance to find the fix range, but I am pretty sure this issue is caused by different gecko, and due to this is a leo+ bug, I will try to solve it in gaia and file a new bug for gecko to fix it.
Flags: needinfo?(dkuo)
This issue happens after users entered the album content(sublist) page or the player page, and this patch hides both of them before entering the search mode so fixes this issue, but it's not ready for review yet.
Whiteboard: mentoredbug mentor=dkuo, inarirun2 → mentoredbug mentor=dkuo, inarirun2 , [TD : 43145]
Duplicate of this bug: 882429
Angelika - can you confirm this bug for leorun3?  Thanks!
Flags: needinfo?(ahubenya)
Target Milestone: --- → 1.1 QE3 (24jun)
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD : 43145] → mentoredbug mentor=dkuo, inarirun2 , [TD:43145]
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD:43145] → mentoredbug mentor=dkuo, inarirun2 , [TD-43145]
I confirm this issue reproduces in leorun3 when searching for songs in the search bar. As I was typing, the screen was shifting to the left side. 

Leo, Build ID: 20130608000538
Gecko: /rev/
Gaia: a7b14c0ea58a34fdf7cf5257982cf9731901cd51
Platform Version: 18.0
Flags: needinfo?(ahubenya)
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145] → mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3
Priority: -- → P1
:dkuo - do you have an ETA for this landing? It'll need to land to master before 1.1, and all of that should take place before 6/24.
I had planned to do some code refactor with this issue but looks like I cannot make it before 6/24, so I will just finish the current patch(attachment 760725 [details]) before 6/21 and hopefully can be landed before 6/24.
Depends on: 886254
Comment on attachment 760725 [details]
hide sublist and player before entering to search mode

I just filed bug 886254 to record the strange behaviour of the input element, and I think we need more time to investigate/fix bug 886254, but we have to fix this issue before 6/24, so I am using a simple patch to fix and will remove/refine this patch in a followup.

And looks like Jim is away so I asked Rudy(the keyboard owner) to review this because this issue seems related to the behaviours when keyboard shows up.
Attachment #760725 - Flags: review?(rlu)
Comment on attachment 760725 [details]
hide sublist and player before entering to search mode

Looks good. r=me.
With only some nits about the comments, please refer to the pull request.
Thanks.
Attachment #760725 - Flags: review?(rlu) → review+
Thanks Rudy!

Landed on master: a24caa3b5024e3c2c7e57f9cc58504584c98d6c2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted a24caa3b5024e3c2c7e57f9cc58504584c98d6c2 to:
v1-train: 32ee116493274bd99a1ae3d3278a7e41425eb381
Issue repros on 
Leo Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1

Search field in main screen works properly however if you attempt to do any search in "Playlists", "Artists", "Albums", and "Songs" the keyboard no longer shows to allow user to type a search
1.1hd: 32ee116493274bd99a1ae3d3278a7e41425eb381
Duplicate of this bug: 886654
Have tested on 6/25 Leo build following the steps from comment 12, issue does not reproduce

 - the screen is not shifted to the left as the text is entered 
 - search field works properly in any of the tabs including "Playlists", "Artists", "Albums", and "Songs" 

Leo build info:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia   1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Build  20130625070217
Version 18.1
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3 → mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4
Hi,

This defect still exists after applying the patch .
1. Precondition : Have stored 300 mp3 on SD card.
2. Tester's Action : 
                1) Go to Music Player and switch to Artist tab
                2) Perform search for some artist and click on it to go to artist songs view
                3) Next go back and try to perform another search (continue to type from the prev search).
3. Detailed Symptom (ENG.) : When trying another search, there will be display error .
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Is the error an UI layout error? If possible can you post an image or video?

Thanks,
Mark
Screenshot of issue happening using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/01eacfdb4793
Gaia   0d5a9a7577f16b6a72a982148c6f509ee1714ea2
BuildID 20130702070214
Version 18.0

Following the STR in the next to last comment.
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4 → mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021]
Target Milestone: 1.1 QE3 (26jun) → 1.1 QE4 (15jul)
Severity: normal → blocker
Attachment 760725 [details] didn't consider the searching mode so it didn't fix this issue 100%. I will give another patch but it might be still a workaroud because of bug 886254.
Since this bug is reopened so I should revert attachment 760725 [details] from master, v1-train and v1.1hd. Before I revert it, I am attaching a WIP patch for Leo to test, see if the patch fix this issue.
Repros according to the steps in comment 30 (without the 300 songs) on Leo 1.1 commercial RIL.

Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021] → mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021], retest_leorun4
Reverted on master: 8c4291690c9bca6632317335253f6a1b8277f345
Reverted on v1-train: 4abea646d93973d1d0bfae7f82783655cd5ea393
Reverted on v1.1.ohd: e930bc7dda8e235458e6a333db828471a168b62d
Severity: blocker → normal
Severity: normal → blocker
Rudy, this is the new patch that fixes this issue, I have reverted the old one so you might need to update your branch before you test it, would you please review this? thanks.
Attachment #778343 - Flags: review?(rlu)
Comment on attachment 778343 [details]
hide sublist and player in search mode

Looks good. r+

Dominic, 
Thank you for working on this.
Attachment #778343 - Flags: review?(rlu) → review+
Thanks Rudy!

Landed on master: 2eea445c6a900c4d65fee5d8e27e5cd2be85054a
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Uplifted 2eea445c6a900c4d65fee5d8e27e5cd2be85054a to:
v1-train: ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
v1.1.0hd: 2a0b3acd3d10ca285771740c3a907b88a4c053aa
Duplicate of this bug: 895275
v1.1.0hd: ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
v1.1.0hd: 4abea646d93973d1d0bfae7f82783655cd5ea393
Whiteboard: mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021], retest_leorun4 → mentoredbug mentor=dkuo, inarirun2 , [TD-43145], leorun3, leorun4,[TD-56021], retest_leorun4,[LeoVB+]
You need to log in before you can comment on or make changes to this bug.