[B2G][Marketplace] User is able to uninstall Marketplace app

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: nkot, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

6 years ago
Description:
User can successfully uninstall Marketplace app

Repro Steps:
1) Updated to Unagi Build ID: 20130403070204
2) Launch Homescreen
3) Longress Marketplace icon to enter into edit mode

Actual:
Red "x" icon appears for the Marketplace app and user can successfully uninstall the app

Expected:
Marketplace cannot be uninstalled

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d467369d1b0c
Gaia: 06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75
Nominating and adding Fabrice based on Jason's suggestion.
blocking-b2g: --- → leo?

Updated

6 years ago
Component: Gaia → Gaia::Homescreen
I can't repro on a VARIANT=user build. Don't you have a VARIANT=eng build?
(Reporter)

Comment 3

6 years ago
(In reply to Fabrice Desré [:fabrice] from comment #2)
> I can't repro on a VARIANT=user build. Don't you have a VARIANT=eng build?

i believe we are testing on VARIANT=user build (non-eng), 

but i have something to add, after resetting device marketplace appears again and i cannot delete it anymore... 
so it looks like it deletes only the icon and it repros only until resetting?

Comment 4

6 years ago
People in MV haven't been able to repro, leo- for now
blocking-b2g: leo? → -
Keywords: qawanted
Closing as wfm.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 6

6 years ago
Issue reproduces on the following Unagi:

Environmental  Variables:
Unagi Build ID: 20130409070205
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/cfef36c0c8bc
Gaia: a80be95f553de517e5d8a159e04511cda5e38be4
RIL: Mozilla

Please see attached video: "Delete-able Marketplace Icon" at http://youtu.be/XoyUH4FXSSk
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I can't reproduce on today's build.
Using today's Commercial RIL build on unagi, I cannot reproduce this issue as well.

Can someone please try with a Commercial RIL build as well?
(Reporter)

Comment 9

6 years ago
I am not sure if that is the key, but i can repro it ONLY after reverting to Nightly

1. manually flash to the latest unagi build, Com RIL (updated to 2013-04-09-070205, Beta update channel)
2. longpress Marketplace icon => cannot delete

3. revert to Nightly
2. longpress Marketplace icon => able to delete ...
(Reporter)

Comment 10

6 years ago
have not seen this issue anymore,
the user is unable to delete Marketplace app!

test device info:
Unagi
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7
Gaia   4de4354e3a99f151a834743c7b03a041ac8db12f
Build  20130603070207
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.