Closed Bug 8578 Opened 21 years ago Closed 19 years ago

[RFE] Lightweight "-server" command line startup option

Categories

(Core Graveyard :: Cmd-line Features, enhancement, P3)

Sun
Solaris
enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 75599
Future

People

(Reporter: roland.mainz, Assigned: mcafee)

References

Details

(Keywords: helpwanted, perf)

Apprunner is IMHO too fat.
This is no bug report, but an idea to make "apprunner" to be a lightweight
startup tool which checks only arguments and loads libraries on demand instead
of loading most of them at startup.
Benefit of a "lightweight" apprunner would be easy-to-open windows using the
"-remote" option (used in Nav 4.x) - currently (under 4.x) a slower machine
needs half a minute toopen the window - and most time is spend in loading the
applocation, connect to the other navigator app, trigger there a "new window"
and exit.
Mozilla 5 should make this better...

Best would be a "-server" option , which launched Mozilla 5 in the background,
but does NOT open any window. A later call to "apprunner" will bring up the
window much faster, because init/startup has been done by the "-server"-process.

IMHO apprunner should never be bigger than 300k (sparc), the rest should ne done
by small libraries.
Assignee: don → dp
dp, what do you think?  (Just add some comments and assign back to me.)
Assignee: dp → don
I think the -server option is a good one. Also we could make it such a way that
the -server thing can happen with the login of a user in their startup script,if
the user so chooses to.
BTW: The -server option idea was stolen from CDE 1.3's "dtpad":
-- snip --
ps -ef | grep dtpad
 gisburn   544   378  0 05:08:47 pts/2    0:00 /bin/sh -c dtpad -server
-- snip --

BUT READ TTHE MANUAL PAGE OF "dtpad". There are some important comments.
This man page also describes the -standAlone option. This option is neccesary if
(for example) the editor should run under a different locale...
Component: Apprunner → XPApps
Summary: Lightweight startup (apprunner) and -server option. → [RFE] Lightweight "-server" command line startup option
Target Milestone: M14
OK, I like this.  But I gotta find somebody to write it.  Move this out to M14
with the other RFEs for now ...
QA Contact: leger → beppe
Updating QA Contact.
Move to M20.
Move to "Future" milestone.
Target Milestone: M20 → Future
*** Bug 56416 has been marked as a duplicate of this bug. ***
over to cmd-line...
Component: XP Apps → XP Apps: Cmd-line Features
QA Contact: don → sairuh
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: helpwanted, nsbeta1-
perceived startup gain, taking.
Assignee: vishy → mcafee
Keywords: perf
Blocks: 7251
No longer blocks: 7251
this is bill law's -turbo stuff, dup

*** This bug has been marked as a duplicate of 75599 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.