all tabs gone after upgrade from 19 to 20

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: glowball, Unassigned)

Tracking

20 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.2; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I started Firefox (version 19.something?), entered the set master password (to allow access to saved proxy credentials), and the previously closed session with many open tabs continued as usual. Then I was asked to upgrade to version 20, I chose to upgrade and restart.


Actual results:

Firefox upgraded, restarted, and I was shown one open tab with Google.


Expected results:

Firefox should have restored the previous session, with many tabs opened. This was what had happened at all previous upgrades (at least in the last half a year).
(Reporter)

Comment 1

6 years ago
Two additions:

(1) I am using FirefoxPortable (due to the local software installation policy), and thus cannot confirm whether the problem persists if I were using the standard Firefox. The problem does stay the same whether I use the old (originally version 15, then always online-updated to 20) or a new (FirefoxPortable version 20.0) "install".

(2) On a hunch I started the application via FirefoxPortable.exe -p (in hindsight I have no idea what that parameter is supposed to do...), and everything is fine again (session restored, all tabs there etc.). The differences seem to be in some strangely misinterpreted profile path handling. I compared the profile folders (via Help -> Troubleshooting Information -> Show (Profile) Folder), and the results differ slightly, but with big impact; both refer to the same folder, but one is using a mapped drive path, the other a "raw" \\windows\share-path:

(not working, when called directly): \\server\share\some_user_id\MyDocument\マイドキュメント\Software\FirefoxPortable\Data\profile (that's "My Document" in Japanese)

(working, when called with -p): W:\MyDocument\マイドキュメント\Software\FirefoxPortable\Data\profile

I am trying to get into touch with the FirefoxPortable-guys, to see whether it's a PortableApp-specific problem.

Comment 2

6 years ago
You need to use the command line -profile with absolute or relative path:
FirefoxPortable.exe -profile "E:\myprofile" 

https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Comment 3

5 years ago
I don't think this is Firefox problem. By now, you problem have determined that as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.