Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 857913 - XUL label truncation disregards UTF-8 character boundaries
: XUL label truncation disregards UTF-8 character boundaries
Status: RESOLVED DUPLICATE of bug 404856
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Neil Deakin
Depends on:
  Show dependency treegraph
Reported: 2013-04-03 22:47 PDT by Matthias Urlichs
Modified: 2013-04-19 13:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Selection_040.png (5.55 KB, image/png)
2013-04-03 22:47 PDT, Matthias Urlichs
no flags Details
Screenshot, Linux: Works when there is enough space (10.56 KB, image/png)
2013-04-19 12:51 PDT, Ben Bucksch (:BenB)
no flags Details

Description Matthias Urlichs 2013-04-03 22:47:00 PDT
Created attachment 733192 [details]

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0 Iceweasel/19.0
Build ID: 20130220104629

Steps to reproduce:

LWN has an article
which is named "Schrödinger's
Comment 1 jim 2013-04-04 08:18:09 PDT
It looks like the bug report was truncated at the UTF-8 character.

The problem is that, with a title with UTF-8 characters (in this case a cat), the title in the tab bar gets truncated without regards to the UTF-8 character boundries.  You can see it by visiting the linked LWN page, but that's subscriber-only for the next week, so here is a page that shows the same problem:

As the tab size shrinks, you'll see invalid UTF-8 characters at some sizes.
Comment 2 Matthias Versen [:Matti] 2013-04-04 15:34:44 PDT
confirming with Firefox20 and Firefox10ESR on windows7
Comment 3 Simon Montagu :smontagu 2013-04-06 22:30:01 PDT

*** This bug has been marked as a duplicate of bug 404856 ***
Comment 4 Ben Bucksch (:BenB) 2013-04-19 12:51:24 PDT
Created attachment 739754 [details]
Screenshot, Linux: Works when there is enough space

Works on Linux
Firefox 22, self-compiled, 64bit, Ubuntu 12.04 64bit
Comment 5 jim 2013-04-19 13:07:09 PDT
Of course it works when there's enough space -- we're talking about label truncation here, not normal display.

Note You need to log in before you can comment on or make changes to this bug.