Resized images flicker ~1 second after the page has loaded

RESOLVED DUPLICATE of bug 832400

Status

()

defect
RESOLVED DUPLICATE of bug 832400
6 years ago
6 years ago

People

(Reporter: dgutov, Assigned: joe)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130401 Firefox/21.0
Build ID: 20130401042013

Steps to reproduce:

I have two thumbnails on this page: http://company-mode.github.com/

These are .png images, resizing is done via scaling on the fly. I have the "width" attribute set on the images, and setting or leaving out the "height" doesn't change the behavior.

When the webpage is updated, to get the current problematic version, do:

git clone git@github.com:company-mode/company-mode.github.com.git
git co 39711bfd12ed3e8d7f67d3b52f20b7d5f4f92748

and open index.html locally.


Actual results:

After the page loads, both images flicker as though switching to a different scaling algorithm and back. Same thing happens when I switch to another tab and then return.



Expected results:

The images shouldn't flicker. In IE10 and Chrome Canary 28, they don't.
If you change the preference image.high_quality_downscaling.enabled to false, does the problem go away?
Reporter

Comment 2

6 years ago
Yes, it does.

And if I change it back to true and switch back to the opened tab, the images flicker again.
Assignee: nobody → joe
Assignee

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

6 years ago
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832400
You need to log in before you can comment on or make changes to this bug.