problem with Czech character encoding in email in 8859-2

RESOLVED DUPLICATE of bug 594646

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 594646
5 years ago
5 years ago

People

(Reporter: zetka, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 733253 [details]
czech_test_email.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
Build ID: 20130327153803

Steps to reproduce:

Having a message in Czech send from Microsoft Outlook Express version 6.00, the message composed in html, encoding set to 8859-2. The email source contains text and html version of the email (see the attached file)


Actual results:

When I view the message, the sender name and subject are encoded well inclusive the Czech special characters. In case of displaying the message in plain text, the body is correctly displayed in Czech. In case of viewing message in html, the czech characters are wrongly displayed. When displaying the same message in Outlook, there is no problem.


Expected results:

The czech characters /ěščřžýžáíé../ should be displayed correctly in html -View version too.
Attachment #733253 - Attachment mime type: application/octet-stream → message/rfc822
This is a duplicate of bug 594646, casused by a <meta> tag with the content= first and http-equiv="Content-Type" afterwards.

A workaround (not very pretty but better than nothing) consists of using "View → Message Body As → Simple HTML" on problematic messages. The error also disappears when replying to the message.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594646
You need to log in before you can comment on or make changes to this bug.