"Downloads" in Tools menu bring a different effect between normal mode and private mode

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: suishouen, Unassigned)

Tracking

20 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557



Actual results:

- In normal mode
"Downloads" in Tools opens Downloads in a new Library window same as "Show All History" in History menu opens a new Library window.

- In private mode
"Downloads" in Tools opens in a new tab named Downloads.


Expected results:

That's confusing.
"Downloads" in Tools menu should bring a same effect.
Eiichi, I think the idea here is that, if you download something in Private tab or window, you don't want it to show up in your Library (ie your browsing history.)  Once you close that Private window or tab, the private browsing download manager won't show what you were downloading before.

Is your point that you'd like the interfaces to look similar?
Flags: needinfo?(suishouen)
Whiteboard: worksforme?
Component: Untriaged → Private Browsing
(Reporter)

Comment 2

6 years ago
(In reply to Liz Henry :lizzard from comment #1)
> Is your point that you'd like the interfaces to look similar?

When using an old download manager, "Downloads" in Tools opens download manager window and "Show All History" in History menu opens a new Library window.
Here's no confusing User Interface.

Now that Firefox uses a download panel instead of an download manager, "Downloads" in Tools should open not "about:downloads" but a download panel, I think.
Flags: needinfo?(suishouen)
We originally made it open the panel, and it was confusing, mostly for accessibility (the Library is a better target for screen readers).
Thus we decided to open the Library by design, exactly because the panel wouldn't be accessible enough for blind users.
The fact in PB mode we open a tab instead of the Library is again a design choice for privacy reasons, in future the Library will move to a tab making it more coherent.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: worksforme?
(Reporter)

Comment 4

6 years ago
Marco,
The following is just for reference;
I think at least when in normal browsing mode "Downloads" in Tools menu should open about:downloads in a new tab, because "Show All History" in History menu also opens Library.
Now two menu commands ("Downloads" in Tools & "Show All History" in History) work similarly.
Also Show all Bookmarks opens the Library, the Library is a media collection, we consider bookmarks, tags history and downloads as the media.
(Reporter)

Comment 6

6 years ago
Clicking "Show All Downloads" in the download panel opens the Libray.
So "Show All Downloads" in History menu may be right position, not "Downloads" in Tools menu.
Why in Tools menu?
Opening download manager was a function of Tools, I think.

Updated

2 years ago
Duplicate of this bug: 1282802
You need to log in before you can comment on or make changes to this bug.