Closed Bug 85806 Opened 20 years ago Closed 20 years ago

crash in nsHttpConnection::OnTransactionComplete

Categories

(Core :: Networking: HTTP, defect, P1)

defect

Tracking

()

VERIFIED DUPLICATE of bug 85822
mozilla0.9.2

People

(Reporter: darin.moz, Assigned: darin.moz)

Details

(Keywords: crash)

from bug 83960:

------- Additional Comments From Chris Hiner 2001-06-13 17:22 -------

The fix for this bug seems to have caused a problem for me on linux.  Now when I
am loading a page, and hit stop (or click a link) while the page is loading, I
get a segfault.
I backed out the 5 files that Darin checked in on 6/13/2001 15:44, and it no
longer crashes when I do that.
If this is unrelated, let me know and I'll file a new bug.
Here's a backtrace:
#0  0x4051eec5 in main_arena () from /lib/libc.so.6
#1  0x407f021b in nsHttpConnection::OnTransactionComplete ()
   from mozilla/dist/bin/components/libnecko.so
#2  0x407f210b in nsHttpTransaction::Cancel ()
   from mozilla/dist/bin/components/libnecko.so
#3  0x407f62a9 in nsHttpChannel::Cancel ()
   from mozilla/dist/bin/components/libnecko.so
#4  0x40ce8d17 in imgRequest::Cancel ()
   from mozilla/dist/bin/components/libimglib2.so
#5  0x40ce8c58 in imgRequest::RemoveProxy ()
   from mozilla/dist/bin/components/libimglib2.so
#6  0x40cea12a in imgRequestProxy::Cancel ()
   from mozilla/dist/bin/components/libimglib2.so
#7  0x407cf5b9 in nsLoadGroup::Cancel ()
   from mozilla/dist/bin/components/libnecko.so
#8  0x408c0089 in nsDocLoaderImpl::Stop ()
   from mozilla/dist/bin/components/liburiloader.so
#9  0x408bf087 in nsURILoader::Stop ()
   from mozilla/dist/bin/components/liburiloader.so
#10 0x40905348 in nsDocShell::StopLoad ()
   from mozilla/dist/bin/components/libdocshell.so
#11 0x4090d9df in nsDocShell::InternalLoad ()
   from mozilla/dist/bin/components/libdocshell.so
#12 0x4091481a in nsWebShell::HandleLinkClickEvent ()
   from mozilla/dist/bin/components/libdocshell.so
#13 0x40914218 in HandlePLEvent ()
   from mozilla/dist/bin/components/libdocshell.so
#14 0x400c5a77 in PL_HandleEvent ()
   from mozilla/dist/bin/libxpcom.so
#15 0x400c5993 in PL_ProcessPendingEvents ()
   from mozilla/dist/bin/libxpcom.so
#16 0x400c6908 in nsEventQueueImpl::ProcessPendingEvents ()
   from mozilla/dist/bin/libxpcom.so
#17 0x406acd03 in event_processor_callback ()
   from mozilla/dist/bin/components/libwidget_gtk.so
#18 0x406aca7d in our_gdk_io_invoke ()
   from mozilla/dist/bin/components/libwidget_gtk.so
#19 0x40345aca in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#20 0x40347186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#21 0x40347751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#22 0x403478f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#23 0x4026b5b9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#24 0x406ad1d0 in nsAppShell::Run ()
   from mozilla/dist/bin/components/libwidget_gtk.so
#25 0x4068f8ea in nsAppShellService::Run ()
   from mozilla/dist/bin/components/libnsappshell.so
#26 0x804e6b9 in main1 ()
#27 0x804eea5 in main ()
#28 0x404489cb in __libc_start_main (main=0x804ed78 <main>, argc=1,
    argv=0xbffff934, init=0x804b120 <_init>, fini=0x8050b18 <_fini>,
    rtld_fini=0x4000aea0 <_dl_fini>, stack_end=0xbffff92c)
    at ../sysdeps/generic/libc-start.c:92
Status: NEW → ASSIGNED
Keywords: crash
Target Milestone: --- → mozilla0.9.2
Severity: normal → critical
Priority: -- → P1
these surfaced at the same time: bug 85802, bug 85823
and bug 85822
<darin> any crashes that pass through nsHttpTransaction::Cancel are dupes of 85822

*** This bug has been marked as a duplicate of 85822 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: benc → bbaetz
QA -> benc (I can't mark it as a dupe and verify it.... :)
QA Contact: bbaetz → benc
VERIFIED:
<rubber stamp>
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.