Closed Bug 858111 Opened 9 years ago Closed 9 years ago

Regression: Lost transparency on installed application launcher icons; background filled

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P2)

ARM
Android
defect

Tracking

(firefox22 verified, firefox23 verified)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 --- verified
firefox23 --- verified

People

(Reporter: aaronmt, Assigned: jhugman)

References

Details

(Keywords: polish, regression, reproducible, Whiteboard: [A4A] [packagedapps])

Attachments

(2 files, 1 obsolete file)

Attached image Nightly (04/04) - Screenshot (obsolete) —
See screenshot

--
Nightly (04/04)
Aurora (04/04)
Summary: Regression: Lost transparency on installed application launcher icons; background filed → Regression: Lost transparency on installed application launcher icons; background filled
Attachment #733386 - Attachment is obsolete: true
Component: Web Apps → Theme and Visual Design
QA Contact: aaron.train
Since nothing changed in the about:apps code, I am betting a regression when saving the image.
Component: Theme and Visual Design → Web Apps
QA Contact: aaron.train
Whiteboard: [A4A?]
Assignee: nobody → jhugman
Hmm...I read this as a polish regression. P2 A4A tracking.

Anyone disagree? Set back A4A? if there's disagreement.
Keywords: polish
Priority: -- → P2
Whiteboard: [A4A?] → [A4A]
This is likely from bug 840593.
Blocks: 840593
Whiteboard: [A4A] → [A4A] [packagedapps]
Attached patch PatchSplinter Review
Simple fix. These inherit from list-item in aboutBase.css:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/themes/core/aboutBase.css#47

This overrides some styles in there that we don't (currently) want for apps.
Attachment #735296 - Flags: review?(mark.finkle)
Comment on attachment 735296 [details] [diff] [review]
Patch

Needs uplift
Attachment #735296 - Flags: review?(mark.finkle) → review+
Comment on attachment 735296 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 840593
User impact if declined: ugly gray color  on about:apps
Testing completed (on m-c, etc.): Landed on mc now.
Risk to taking this patch (and alternatives if risky): Super simple. low risk.
String or IDL/UUID changes made by this patch:NOne
Attachment #735296 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8ad8e9729731
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Attachment #735296 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
-build: Firefox for Android 22 Beta 1 (2013-05-15)
-device: LG Nexus 4
-OS: Android 4.2.2
Verified fixed on:
-build: Firefox for Android 23.0a2 (2013-05-16)
-device: Samsung Galaxy Tab
-OS: Android 4.0.4
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.