imap can't handle multi-client deletion

VERIFIED DUPLICATE of bug 40701

Status

MailNews Core
Networking: IMAP
--
major
VERIFIED DUPLICATE of bug 40701
17 years ago
9 years ago

People

(Reporter: Nathan Neulinger, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.18 i686)
BuildID:    all

The imap client can't handle the situation where another imap client (accessing
the same folder on server) deletes messages. It basically gets into the 'message
set invalid' error state.

Reproducible: Always
Steps to Reproduce:
1. Set up imap
2. Access folder on server
3. Delete message in that folder from other client
4. wait till folder gets scanned again in bg

Actual Results:  Error condition, repeats constantly once it occurs. Only way to
stop is to exit and restart mozilla.

Expected Results:  If message set invalid error occurs, mozilla should
recalculate message set or re-retrieve folder contents

running against MSExchange-5.5, other client is Outlook using MAPI. Since I
browse and do some mail with mozilla, and most mail with outlook, it is pretty
critical, since once I send a piece of mail with mozilla, if I change the folder
on outlook, I have to quit out of mozilla and restart it. (In my case, usually
occurs with Sent Items.)
(Reporter)

Comment 1

17 years ago
I believe this may be equivalent to 40701, but that bug appears idle w/ no
changes since January. The bug most definitely still exists. 
(Reporter)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 40701 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.