If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use more webidl features for HTMLAudioElement

RESOLVED FIXED in mozilla23

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

Trunk
mozilla23
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 733507 [details] [diff] [review]
Patch v1
Attachment #733507 - Flags: review?(bzbarsky)
Comment on attachment 733507 [details] [diff] [review]
Patch v1

r=me
Attachment #733507 - Flags: review?(bzbarsky) → review+
Comment on attachment 733507 [details] [diff] [review]
Patch v1

>+++ b/content/html/content/public/HTMLAudioElement.h
>+  uint32_t MozWriteAudio(const Float32Array& aData, ErrorResult& aRv);
>+  uint32_t MozWriteAudio(const Sequence<float>& aData, ErrorResult& aRv);

Why not inline those two?
(Assignee)

Comment 3

5 years ago
(In reply to Boris Zbarsky (:bz) from comment #2)
> Comment on attachment 733507 [details] [diff] [review]
> Patch v1
> 
> >+++ b/content/html/content/public/HTMLAudioElement.h
> >+  uint32_t MozWriteAudio(const Float32Array& aData, ErrorResult& aRv);
> >+  uint32_t MozWriteAudio(const Sequence<float>& aData, ErrorResult& aRv);
> 
> Why not inline those two?

No particular reason, I'd just been working in the cpp.
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/e22145c3b33e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla23

Comment 5

5 years ago
Hi :Ms2ger,

This patch seems to cuase a regression on b2g project. The keytone from dialer app can't work anymore. (gaia/app/communication/dialer/js/keypad.js)

  1. I tired the changset 7ebd1eece7f0 and it is work but e22145c3b33e.
  2. The JS code is stopped at calling mozWriteAudioData().

Could you help on this regression? Thanks.
Marco, is there a exception thrown?  If so, which one?  Is there a bug tracking the problem?
(Assignee)

Comment 7

5 years ago
And where does this code live?

Comment 8

5 years ago
> Marco, is there a exception thrown?  If so, which one?  Is there a bug tracking the problem?
I didn't see any warning or error message from adb logcat or console. And I didn't fire a bug yet but will and update here.

> And where does this code live?
The regression is not happened on b2g18 because it didn't be uplifted yet.
It happened when I want to commit a patch related to HTMLAudioElement and test it on m-c tree.

Comment 9

5 years ago
Fire a new bug for this. 
Bug 862409 - [Audio] Audio_Data API is broken When dialer app tried to send a keytone
> And where does this code live?

http://mxr.mozilla.org/gaia/source/apps/communications/dialer/js/keypad.js fwiw.
Depends on: 862409
You need to log in before you can comment on or make changes to this bug.