Firefox 20.0 on Solaris x86 crashes when gmail's login bar starts

RESOLVED FIXED in mozilla20

Status

--
critical
RESOLVED FIXED
6 years ago
7 months ago

People

(Reporter: ijdt.editor, Assigned: ginnchen+exoracle)

Tracking

({hang})

20 Branch
mozilla20
x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; SunOS i86pc; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130308163327

Steps to reproduce:

I tried to read my e-mail from my Gmail account but I failed.


Actual results:

When I entered my login-password, the connection progress bar appeared and almost
immediately firefox freezes.


Expected results:

Firefox should normally start GMail.
You'll need to report this to the port maintainers for Solaris. AFAIK they are not active on bugzilla.mozilla.org

Comment 2

6 years ago
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
If so, can you provide a stack trace with a debugging tool?
Severity: normal → critical
Keywords: hang

Updated

6 years ago
Flags: needinfo?(ijdt.editor)
Keywords: stackwanted
(Reporter)

Comment 3

6 years ago
Created attachment 733808 [details]
stack trace of firefox 20.0 on Solaris x86
Flags: needinfo?(ijdt.editor)
(Reporter)

Comment 4

6 years ago
Created attachment 733810 [details]
Stack trace of firefox 20.0 in safe mode under Solaris x86

Updated

6 years ago
Keywords: stackwanted

Comment 5

6 years ago
I have had a similar issue with 21.0b1 on a WordPress blog. A bug with 18.0 (829725) was assigned to Ginn Chen from Oracle. opensolaris.org has been shut down. I found a new list at http://java.net/projects/solaris-desktop/lists  desktop-discuss [at] solaris-desktop.java.net

Comment 6

6 years ago
Same problem on OpenIndiana 151a with Firefox 20.  The progress bar gets close to the end while loading GMail, and then I get a segfault with or without safe mode.  No such issue with Firefox 19 on the same system.
(Assignee)

Comment 7

6 years ago
Respin builds posted.
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/20.0/contrib/solaris_respin/

It is caused by a compiler issue.

Fixed in Firefox 20.0 respin, Firefox 21.0 b2.

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Assignee: nobody → ginn.chen
Component: Untriaged → Build Config
Product: Firefox → Core
Target Milestone: --- → mozilla20

Updated

6 years ago
Duplicate of this bug: 867493

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.