Java plugin do not use or is unable to accept cookies

VERIFIED DUPLICATE of bug 79851

Status

()

--
blocker
VERIFIED DUPLICATE of bug 79851
18 years ago
18 years ago

People

(Reporter: co, Assigned: edburns)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
First reported in Bugzilla Bug 82335

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050521

Full explanation available at problem URL. Summary:

Unlike NS 4.x or MSIE, Mozilla's JVM does not appear to make requests for
resources (.class, .gif, .au, etc) with the cookies appropriate to that website.
http://javabug.transpect.net gives an example of how this behaviour breaks all
websites that depend on cookies for content access authentication.

Reproducible: Always
Steps to Reproduce:
1.Visit the problem demo website (http://javabug.transpect.net)
2.Read the background
3.Follow the links

Actual Results:  Java applets in cookie-secured environment fail due to
inability to download essential resources (.class files, etc)

Expected Results:  Mozilla's JVM should operate the way NS 4.x and MSIE do, and
make resource requests with appropriate cookies.

In my opinion, this behaviour is broken and needs fixing. A number of sites
which require cookie authentication would be broken if this is an 'unfixable'
problem.

----
I personally have logs to expose the problem 


06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> GET
/mapserver/servlet/com.korem.servlets.MapServlet/KoremMap/GetMapInstanceKey?workspaceKey=SimpleWorld
HTTP/1.1
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> User-Agent: Java1.3.1-beta
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> Host: 127.0.0.1:8101
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> Accept: text/html,
image/gif, image/jpeg, *; q=.2, */*; q=.2
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> Connection: keep-alive
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 --> 06/13 12:01:53 info
(JRun) HTTP Sniffer: Header 525 <-- HTTP/1.0 200 OK
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Server: JRun Web Server/3.0
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Date: Wed, 13 Jun 2001
16:01:53 GMT
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Set-Cookie:
jsessionid=69361992448113917;path=/
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Pragma: no-cache
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Expires: Thu, 01 Dec
1994 16:00:00 GMT
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Connection: Keep-alive
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Cache-Control: no-cache
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Cache-Control:
no-cache="set-cookie,set-cookie2"
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Content-Type: text/plain
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- Content-Length: 23
06/13 12:01:53 info (JRun) HTTP Sniffer: Header 525 <-- 
06/13 12:01:53 info (JRun) HTTP Sniffer: Content 525 <-- 00000000 31 38 0D 0A 36
39 33 36 31 39 39 32 34 34 38 31   18..693619924481
06/13 12:01:53 info (JRun) HTTP Sniffer: Content 525 <-- 00000016 31 33 39 31 37
0D 0A                              13917..
06/13 12:01:54 info (JRun) HTTP Sniffer: Accepted request 527
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> POST
/mapserver/servlet/com.korem.servlets.MapServlet/KoremMap/Capabilities?mapInstanceKey=18&jsessionid=255279992447827953
HTTP/1.1
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> Content-Type: 
text/plain;charset=UTF8
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> User-Agent: Java1.3.1-beta
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> Host: 127.0.0.1:8101
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> Accept: text/html,
image/gif, image/jpeg, *; q=.2, */*; q=.2
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> Connection: keep-alive
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> Content-length: 145
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 --> 06/13 12:01:54 info
(JRun) HTTP Sniffer: Content 527 --> 00000000 76 65 72 73 69
6F 6E 20 3D 20 31 2E 30 2E 30 0D   version = 1.0.0.
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000016 0A 6D 61 70 49
6E 73 74 61 6E 63 65 4B 65 79 20   .mapInstanceKey 
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000032 3D 20 31 38 0D
0A 72 65 71 75 65 73 74 20 3D 20   = 18..request = 
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000048 63 61 70 61 62
69 6C 69 74 69 65 73 0D 0A 6D 61   capabilities..ma
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000064 70 44 65 66 69
6E 69 74 69 6F 6E 20 3D 20 30 2E   pDefinition = 0.
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000080 30 3B 30 2E 30
3B 30 2E 30 3B 30 2E 30 3B 35 39   0;0.0;0.0;0.0;59
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000096 39 3B 33 30 37
3B 30 2E 30 3B 30 2E 30 3B 31 2E   9;307;0.0;0.0;1.
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000112 30 3B 66 61 6C
73 65 0D 0A 76 65 72 69 66 79 4B   0;false..verifyK
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000128 6F 72 65 6D 54
65 73 74 20 3D 20 74 72 75 65 0D   oremTest = true.
06/13 12:01:54 info (JRun) HTTP Sniffer: Content 527 --> 00000144 0A           
                                    .
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- HTTP/1.0 200 OK
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Server: JRun Web Server/3.0
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Date: Wed, 13 Jun 2001
16:01:53 GMT
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Set-Cookie:
jsessionid=114803992448114758;path=/
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Pragma: no-cache
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Expires: Thu, 01 Dec
1994 16:00:00 GMT
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Connection: close
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Cache-Control: no-cache
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Cache-Control:
no-cache="set-cookie,set-cookie2"
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <-- Content-Type:
text/plain;charset=UTF8
06/13 12:01:54 info (JRun) HTTP Sniffer: Header 527 <--

Comment 1

18 years ago
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
(Reporter)

Comment 2

18 years ago
Seems to have been with bug 83625.
This bug is a spin off from bug 83625; morse@netscape.com said there:

"Sounds more like a networking issue to me.  From the description, it sounds 
like the following is happening: when the network access is made on behalf of an 
applet, the network is not calling the cookie-module listener to generate the 
request headers."

On that basis, over to Networking.

I get grey boxes and applet init messages in Mozilla, but a proper clock in NS 
4.x. So something is wrong here.

Gerv
Status: UNCONFIRMED → NEW
Component: OJI → Networking
Ever confirmed: true
*** Bug 87806 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Mozilla Build: 2001062504

This also occurs on Windows NT and Windows 2000.
(Assignee)

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 79851 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.