pressing back on a github commit doesn't do the right thing anymore.

RESOLVED INVALID

Status

()

Core
History: Global
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
- go to https://github.com/thorfdbg/libjpeg/commits/master
- click on a commit
- hit the back button
- notice that no going back happens

I'm not sure if this is our bug or githubs.
(Reporter)

Comment 1

5 years ago
This seems to be a regression. I don't see the problem in an earlier 21 build.
(Reporter)

Updated

5 years ago
Keywords: regression, regressionwindow-wanted
I don't think this is our bug. I can reproduce with a 12 build. However, I could not reproduce with a recent Safari.

When you test please make sure to test in a new tab always, because after the last step in the STR above, if you

- go forward (to the commit, the page content won't change but the url in the address bar changes)
- go back

it suddenly works and the commit list is shown.
Keywords: regression, regressionwindow-wanted
OS: Mac OS X → All
Hardware: x86 → All
One of akamai's scripts on github is the cause. If you use NoScript and block the akamai, it works.

Invalid, but still annoying!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.