./mozilla -remote should test for UID

VERIFIED DUPLICATE of bug 80051

Status

()

Core
X-remote
VERIFIED DUPLICATE of bug 80051
17 years ago
17 years ago

People

(Reporter: Roland Mainz, Assigned: blizzard)

Tracking

({helpwanted})

Trunk
All
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla -remote command does not test for the user's UID when sending commands.
This causes problems when the user is logged into multiple accounts but uses one
$DISPLAY for all applications.

The expected behavior would be that -remote option should send commands only to
that browser running with the same UID as the current process's UID.

Comment 1

17 years ago
you knew someone would file this bug w/ proper wording eventually, feel free 
to dupe against your wontfix.  Roland: I suggest you implement this and attach 
a patch.
Assignee: asa → blizzard
Component: Browser-General → XP Apps: Cmd-line Features
Keywords: helpwanted
QA Contact: doronr → sairuh
(Assignee)

Comment 2

17 years ago
Can't do UID tests across an X connection without changing the protocol and I'm
not willing to do that at this point.

The correct thing to do is support the window argument so you can target a
specific XID.

*** This bug has been marked as a duplicate of 80051 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Component: XP Apps: Cmd-line Features → X-remote
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.