Need to enable focusmanager.testmode for tests run against B2G desktop builds

RESOLVED FIXED in Firefox 23

Status

Testing
Marionette
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: davehunt, Assigned: davehunt)

Tracking

unspecified
mozilla23
Points:
---

Firefox Tracking Flags

(firefox23 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Interacting with the keyboard or select options in the B2G desktop client requires focus on the application unless focusmanager.testmode is enabled in the preferences.

I see a couple of options:

1. Add required preferences to the profile when launching the binary specified in the MarionetteTestRunner. We already set a few preferences here, but we'd be adding focusmanager.testmode and setting these even if a profile is specified. See http://hg.mozilla.org/mozilla-central/file/c232bec6974d/testing/marionette/client/marionette/geckoinstance.py#l20

2. Add a B2GDesktopProfile to mozprofile that specifies this and any other required preferences for the B2G desktop client. This would also likely involve adding a B2GDesktopRunner in mozrunner, and adding a way to determine the binary specified on the command line of MarionetteTestRunner. Perhaps by an --application option, similar to Mozmill.
GeckoInstance was designed for desktop Firefox; I wonder how many differences we'll eventually want for B2G desktop builds?  It might make sense to create a B2GDesktopInstance subclass of this which has its own set of prefs that get used even when you specify a profile.

I like that approach better than adding classes to mozprofile/mozrunner, since it's a lot lighter-weight.
(Assignee)

Comment 2

5 years ago
Sounds good to me. How would you suggest we determine the class to use? Should we inspect the binary specified or just have an --application option?
(Assignee)

Comment 3

5 years ago
Created attachment 733840 [details] [diff] [review]
Set focusmanager.testmode for B2G desktop. v1.0
Assignee: nobody → dave.hunt
Attachment #733840 - Flags: review?(jgriffin)
Comment on attachment 733840 [details] [diff] [review]
Set focusmanager.testmode for B2G desktop. v1.0

Review of attachment 733840 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, thanks.
Attachment #733840 - Flags: review?(jgriffin) → review+
(Assignee)

Comment 5

5 years ago
Landed on inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2f719ebae709
https://hg.mozilla.org/mozilla-central/rev/2f719ebae709
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
(Assignee)

Comment 7

5 years ago
Thanks, can we get this uplifted to b2g18?
tracking-b2g18: --- → ?
this looks to be an a=testonly since it's a patch to marionette - anything i'm missing here?
tracking-b2g18: ? → ---
(Assignee)

Comment 9

5 years ago
Landed as:
https://hg.mozilla.org/releases/mozilla-b2g18/rev/fbbf1d226f45
status-b2g18: --- → fixed
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/1198ae654986
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → fixed
status-firefox23: --- → fixed
You need to log in before you can comment on or make changes to this bug.