Closed Bug 858303 Opened 7 years ago Closed 2 years ago

Personas theme image on toolbar does not appears sometimes

Categories

(Core :: Layout, defect, trivial)

20 Branch
x86_64
Windows 7
defect
Not set
trivial

Tracking

()

RESOLVED WONTFIX

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/c90d44bfa96c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 ID:20130326150557

The problem occurs in Nightly23.0a1 as well.

Steps to Reproduce:
1. Install Personas themes
   Ex. https://addons.mozilla.org/en-US/firefox/addon/i-love-music/
2. Enable Default Theme in about:addons
3. Restart browser

4. Enable the Personas theme in about:addons
   To reproduce the problem easily, you may use Tab key and Enter key to enable the theme.
   OR, click Enable buttun and don't move mouse.

Actual Results:
  No image appears on the toolbar.
  Only background color is applied.

Expected Results:
  Image appears on the toolbar.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c6970a82a686
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210104701
Bad:
http://hg.mozilla.org/mozilla-central/rev/00e26dece6ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210105701
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c6970a82a686&tochange=00e26dece6ea


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/31b16bc75897
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210013551
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3ba90f85653a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121209 Firefox/20.0 ID:20121210024851
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=31b16bc75897&tochange=3ba90f85653a

Suspected: Bug 805343
Duplicate of this bug: 858353
(In reply to Alice0775 White from comment #0)
> Suspected: Bug 805343
I don't think so because it was backed out a few days later when m-c was still in 20.0.
Regression Window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c6970a82a686
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210104701
Bad:
http://hg.mozilla.org/mozilla-central/rev/50d8f411d305
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121214 Firefox/20.0 ID:20121214072922
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c6970a82a686&tochange=50d8f411d305


Regression Window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/31b16bc75897
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210013551
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1c5601022840
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121213 Firefox/20.0 ID:20121213145727
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=31b16bc75897&tochange=1c5601022840
No longer blocks: 805343
I suspect bug 820246 or bug 821477.
Note that the migration from getpersonas.com to addons.mozilla.org (bug 741826) was happening last week so keep in mind that there's a possibility that this is caused by server issues and that could be the cause of the intermittent bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.