Closed Bug 858309 Opened 9 years ago Closed 9 years ago

Deleting table rows by clicking on "X" button on the row does not delete row.

Categories

(SeaMonkey :: Composer, defect)

SeaMonkey 2.17 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 857487

People

(Reporter: ms31643, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130404093817

Steps to reproduce:

1. Press CTL+SHIFT+N to open new composer window.

2. Click "Table" button on toolbar.

3. At "Insert Table" dialog box, use the defaults and click OK.

4. Click on first cell on any row and then click on "X" at left edge of cell. Row is not removed.

5. Repeating step 4 on any cell does not delete row.


Actual results:

Table row is not removed. Confirmed this bug in both win32 executable from Mozilla and compile from source versions of SeaMonkey 2.17:

User agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
    Built from ports (source) 4/3/2013 on FreeBSD 8.3 amd64

User agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
    Build identifier: 20130331213155
    Windows XP up-to-date as of 4/3/2013


Expected results:

Row should be removed once "X" at left edge of cell is clicked.
OS: FreeBSD → All
Hardware: x86_64 → All
Confirming problem present on
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
Build identifier: 20130331213155
But absent on
User agent: Mozilla/5.0 (Windows NT 5.2; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19a2
Build identifier: 20130404013001
User agent: Mozilla/5.0 (Windows NT 5.2; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20a1
Build identifier: 20130404003001
so it is already fixed in current trunk and aurora versions, and maybe even in upcoming 2.18 Beta 1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [closeme 2013-06-20]
Duplicate of this bug: 858453
RE:
 User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
 Build identifier: 20130331213155
I am having the same problem since upgrading last week.
Not only does clicking the "x" not remove a row, neither does selecting "Table Delete->Row(s)" from the context menu.
I used this feature regularly, so it's a real problem.
As a (very tedious) workaround, I have discovered that I can delete a row ONE CELL AT A TIME from the context menu...
I can confirm this bug for the Mac OS X version.

Workaround until rectification:
Set the cursor in the table row to be deleted.
Click onto the <tr> label in the status bar at the bottom of the composer window.
Press the backstep key.
It looks like this is a dup of core bug 857487 https://bugzilla.mozilla.org/show_bug.cgi?id=857487 which is fixed in firefox 21.  I'm not sure what version o SeaMonkey will pick that up to verify the fix in SeaMonkey.
Check any of current 2.18 betas
Duplicate of this bug: 866531
(In reply to bgzll from comment #3)
> RE:
>  User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101
> Firefox/20.0 SeaMonkey/2.17
>  Build identifier: 20130331213155
> I am having the same problem since upgrading last week.
> Not only does clicking the "x" not remove a row, neither does selecting
> "Table Delete->Row(s)" from the context menu.
> I used this feature regularly, so it's a real problem.
> As a (very tedious) workaround, I have discovered that I can delete a row
> ONE CELL AT A TIME from the context menu...

I'm have the same problem when trying to edit a page for saving! Also I can only delete one column at a time.
Duplicate of this bug: 875140
According to mcsmurf this problem is gone in 2.18b4, so it is definitely dupe for Bug 857487
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 857487
Whiteboard: [closeme 2013-06-20]
You need to log in before you can comment on or make changes to this bug.