Migrate /projects/devpreview out of legacy

RESOLVED FIXED

Status

www.mozilla.org
Legacy PHP system
P3
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: bensternthal, Assigned: sgarrity)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1093818] )

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
http://www.mozilla.org/projects/devpreview/
redirects

http://www.mozilla.org/projects/devpreview/releasenotes/
no redirect - last updated 2010

http://www.mozilla.org/projects/devpreview/firstrun/
no redirect - last updated 2012 - might be referenced by a project

It looks like the top level directory already redirects, however sub-directories do not. If this content is no longer relevant can we blanket redirect the entire directory?

If not can we move the other 2 pages from legacy and into either the wiki or mdn, then redirect there?

David adding you as needinfo, can you advise on the above?
Flags: needinfo?(dbaron)
These were in-project links from a Firefox alpha release that we didn't have a codename or an official version number for yet.  (I think it was the one shipped as 3.7a1, but eventually became 4.0.)
Flags: needinfo?(dbaron)
(In reply to Ben (:bensternthal) from comment #0)
> http://www.mozilla.org/projects/devpreview/
> redirects
> 
> http://www.mozilla.org/projects/devpreview/releasenotes/
> no redirect - last updated 2010

I think this is historically useful and should be maintained, like I presume other release notes have been.  (I believe it's also reachable directly from within the Help menu in the download.)

> http://www.mozilla.org/projects/devpreview/firstrun/
> no redirect - last updated 2012 - might be referenced by a project

I'd be fine redirecting this to a newer first run page (preferably one that suggests updating).
Priority: -- → P3
(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #2)

> > http://www.mozilla.org/projects/devpreview/releasenotes/
> 
> I think this is historically useful and should be maintained, like I presume
> other release notes have been.  (I believe it's also reachable directly from
> within the Help menu in the download.)

Could we put this page in the archives, where it will be in good company with many other historic release notes?

http://www-archive.mozilla.org/releases/
http://www-archive.mozilla.org/projects/blackwood/webclient/release-notes/
http://www-archive.mozilla.org/projects/calendar/releases/
http://www-archive.mozilla.org/js/spidermonkey/release-notes/

etc.

Then we can redirect the original URL there. 

> > http://www.mozilla.org/projects/devpreview/firstrun/
> 
> I'd be fine redirecting this to a newer first run page (preferably one that
> suggests updating).

Would this page work?

http://www.mozilla.org/en-US/firefox/firstrun/
Flags: needinfo?(dbaron)
I spoke too soon: While the archive would seem to be ideal for this, it actually cannot be changed. We'll need to come back with a better solution.
Flags: needinfo?(dbaron)
I'm back with a better solution.

(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #2)
> > http://www.mozilla.org/projects/devpreview/releasenotes/
> > no redirect - last updated 2010
> 
> I think this is historically useful and should be maintained, like I presume
> other release notes have been.  (I believe it's also reachable directly from
> within the Help menu in the download.)

We're going to be migrating historically useful Fennec release notes to the wiki (https://bugzilla.mozilla.org/show_bug.cgi?id=675031#c6). May we do the same with devpreview notes and redirect this URL there?


> > http://www.mozilla.org/projects/devpreview/firstrun/
> 
> I'd be fine redirecting this to a newer first run page (preferably one that
> suggests updating).

May we redirect this to 
http://www.mozilla.org/en-US/firefox/firstrun/?
Flags: needinfo?(dbaron)

Updated

5 years ago
Duplicate of this bug: 684983
(In reply to Justin Crawford [:hoosteeno] from comment #5)
> I'm back with a better solution.
> 
> (In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from
> comment #2)
> > > http://www.mozilla.org/projects/devpreview/releasenotes/
> > > no redirect - last updated 2010
> > 
> > I think this is historically useful and should be maintained, like I presume
> > other release notes have been.  (I believe it's also reachable directly from
> > within the Help menu in the download.)
> 
> We're going to be migrating historically useful Fennec release notes to the
> wiki (https://bugzilla.mozilla.org/show_bug.cgi?id=675031#c6). May we do the
> same with devpreview notes and redirect this URL there?

I suppose so.  Though there's presumably some loss of fidelity involved.  I guess I'm not particularly concerned about this particular case given that archival release notes are far from the most important things around.

But in general, this sort of thing is the reason that when I write Mozilla-related documentation these days, I try to host it on non-mozilla.org sites (which generally means doing it in ways that hinder collaboration).  I think most of the documentation I've written during my time working on Mozilla has either been threatened with deletion unless I actively defended it or migrated from format to format with loss of fidelity.  I think the only exception is things I've written on wiki.mozilla.org, which is why I'm still somewhat willing to write things there.

This is also what TimBL clearly wrote about in 1998, here:  http://www.w3.org/Provider/Style/URI.html .

I've essentially given up on that fight within Mozilla, though.

> > > http://www.mozilla.org/projects/devpreview/firstrun/
> > 
> > I'd be fine redirecting this to a newer first run page (preferably one that
> > suggests updating).
> 
> May we redirect this to 
> http://www.mozilla.org/en-US/firefox/firstrun/?

Sounds reasonable.
Flags: needinfo?(dbaron)
> > We're going to be migrating historically useful Fennec release notes to the
> > wiki (https://bugzilla.mozilla.org/show_bug.cgi?id=675031#c6). May we do the
> > same with devpreview notes and redirect this URL there?
> 
> I suppose so. 

Excellent. Thanks very much.

> I think most of the documentation I've written during my
> time working on Mozilla has either been threatened with deletion unless I
> actively defended it or migrated from format to format with loss of
> fidelity.

I hear you. I'm sorry to be the agent of the latest threat to these documents. 

> > 
> > May we redirect this to 
> > http://www.mozilla.org/en-US/firefox/firstrun/?
> 
> Sounds reasonable.

Great!

Updated

5 years ago
Blocks: 879544
Thanks in part to the great comments above, we are building a new archival server (bug 892152) for content that needs to stay on the web, but can't stay on www.mozilla.org. In the process of documenting this new server I migrated the devpreview/releasenotes content there. 

I think we can close this bug by redirecting...

a) http://www.mozilla.org/projects/devpreview/releasenotes/ to http://website-archive.mozilla.org/www.mozilla.org/devpreview_releasenotes/projects/devpreview/releasenotes/index.html

b) http://www.mozilla.org/projects/devpreview/firstrun/ to 
http://www.mozilla.org/en-US/firefox/firstrun/

... and then deleting the content from SVN.
Whiteboard: [kb=1093818]
To do:  make the redirects in comment #9 https://bugzilla.mozilla.org/show_bug.cgi?id=858315 and then delete the full /projects/devpreview directory from SVN.

projects/devpreview is already redirecting to http://www.mozilla.org/en-US/firefox/channel/
(Assignee)

Comment 11

4 years ago
Redirects are in https://github.com/mozilla/bedrock/pull/1278

Will remove the files from SVN once these redirects are in place.
Assignee: nobody → steven

Comment 12

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5948a7f8f537ea236de6caa52f1c19758d3a9594
Redirects for /projects/devpreview for Bug 858315

https://github.com/mozilla/bedrock/commit/14f4397bf0e297ea8768d2eecd3652f8f2b1d400
Merge pull request #1278 from sgarrity/bug-858315-devpreview

Redirects for /projects/devpreview for Bug 858315
fixed on stage
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
fixed on production
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

4 years ago
How about the system-requirements page? It'll be the only file left in /project/devpreview/

http://www.mozilla.org/projects/devpreview/system-requirements.html
Flags: needinfo?(hoosteeno)
(Assignee)

Comment 16

4 years ago
Created attachment 812741 [details] [diff] [review]
bug-858315.diff

Another delete-only patch to remove now-redirected files from SVn.
Attachment #812741 - Flags: review?(pmac)
:sgarrity, I think we can archive that to ...

http://website-archive.mozilla.org/www.mozilla.org/devpreview_releasenotes/projects/devpreview/system-requirements.html

... then redirect, then delete from SVN, then get rid of /devpreview. Woo!

The archive steps (which will need to be slightly modified for this situation) are here:

https://github.com/mozilla/archiver_toolkit

Let me know if the specific steps for archiving this file need clarification.
Flags: needinfo?(hoosteeno)
(Assignee)

Comment 18

4 years ago
Release notes are archived here: http://website-archive.mozilla.org/www.mozilla.org/devpreview_releasenotes/projects/devpreview/system-requirements.html

Pull request for redirect here: https://github.com/mozilla/bedrock/pull/1285
Attachment #812741 - Flags: review?(pmac) → review+

Comment 19

4 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/c8147353af3c471db74c3f7d4be772823e00496e
Bug 858315: Redirect to archived devpreview release notes
Please delete these 3 files from SVN:

http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/devpreview/firstrun/index.html
http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/devpreview/releasenotes/index.html
http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/devpreview/system-requirements.html
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

3 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #20)
> Please delete these 3 files from SVN:
> 
> http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/
> devpreview/firstrun/index.html
> http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/
> devpreview/releasenotes/index.html
> http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/projects/
> devpreview/system-requirements.html

Done in r139539.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.