show_bug.cgi doesn't accept space after bug number

RESOLVED FIXED in Bugzilla 2.14

Status

()

Bugzilla
Bugzilla-General
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: Jacob Steenhagen)

Tracking

({regression})

unspecified
Bugzilla 2.14
x86
Windows NT
regression

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Bugzilla's show_bug.cgi rejects URLs that have a space after the bug number,
saying that the bug number is invalid.  I think this is a recent regression. 
This is particularly annoying because I often double-click a bug number (which
selects the space after the number), paste it into a QuickSearch form, and press
enter.  (QuickSearch not stripping the space causes problems even without
show_bug.cgi rejecting the URL, so I filed bug 85832 on QuickSearch.)
(Assignee)

Comment 1

17 years ago
Created attachment 38404 [details] [diff] [review]
allow whitespace in bug id
(Assignee)

Comment 2

17 years ago
Bumping this to 2.14 due to the fact it's a regression that was caused by a
recent code change.  Allowing the bug id to have whitespace in it should have no
ill effects as SQL statements allow for whitespace.
Assignee: tara → jake
Keywords: patch, regression, review
Target Milestone: --- → Bugzilla 2.14
I bet the regex in ValidateBugID() is checking for /^\d+$/
r= justdave

checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.