Closed Bug 858339 Opened 7 years ago Closed 7 years ago

PhoneNumberJS: Fix colombian phone numbers without the leading +

Categories

(Core :: DOM: Device Interfaces, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla23
blocking-b2g tef+
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: gwagner, Assigned: gwagner)

Details

Attachments

(1 file)

https://github.com/andreasgal/PhoneNumber.js/pull/18



Colombian mobile numbers can be called without the leading "+". Google's libphonenumber supports it but PhoneNumber.js doesn't.

The problem is that PhoneNumber.js first checks that the number is a possible national number and if it isn't then it checks if it can be an international number without the leading "+".

The check of possible national numbers more loose than the check of being an international number, so most international numbers without the leading "+" are considered national numbers.
Attached patch patchSplinter Review
Attachment #733653 - Flags: review?(gal)
We should take it if Columbia is one of the initial target markets.
blocking-b2g: --- → tef?
Comment on attachment 733653 [details] [diff] [review]
patch

Review of attachment 733653 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing, r=me.
Attachment #733653 - Flags: review?(gal) → review+
blocking-b2g: tef? → tef+
https://hg.mozilla.org/mozilla-central/rev/db1838b65293
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.