Site says: enable JavaScript...But it is already enabled.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: edburns, Assigned: joki)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [USERNAME=auto252064@hushmail.com PASSWORD=bugzilla ], URL)

(Reporter)

Description

18 years ago
Please see bug 85240 for details.

Visit the above URL using today's TRUNK on win32.  It'll say

 Enable JavaScript
<http://www.hushmail.com/images/pixel.gif>
<http://www.hushmail.com/images/pixel.gif>   
<http://www.hushmail.com/images/pixel.gif>  

You need to enable JavaScript on your browser in order for HushMail to work 
correctly.

In Netscape:

   1. Pull down the "Edit" menu
   2. Select "Preferences"
   3. On the "Preferences" screen, select "Advanced"
   4. Check the box labeled "Enable JavaScript"


Even though JS is enabled.  

If you need a userid and password,

auto25064
bugzilla

Comment 1

18 years ago
Oops: I had no luck with username="auto252064". I had to use:

                  USERNAME=auto252064@hushmail.com  
                  PASSWORD=bugzilla
Whiteboard: [USERNAME=auto252064@hushmail.com PASSWORD=bugzilla ]

Comment 2

18 years ago
I am not having this problem using nightly binaries 20010613xx 
on WinNT and Linux. I am able to login to the site just fine.
I did find the part of the HTML that makes the warning appear:


<td width="35">
<a href="http://www.hushmail.com/enable_javascript/"
onMouseOver="window.status='Type Username then Click here to login'; 
             return true;" 
onMouseOut="window.status='';" 
onClick="document.loginform.submit(); return false;">
<img src="/images/home/go.gif" width="35" height="35" border="0" alt="Login">
</a>
</td>


The URL https://login.hushmail.com/images/home/go.gif is the "Go" button.
The URL http://www.hushmail.com/enable_javascript/ is the one saying, 

  "You need to enable JavaScript on your browser in order for HushMail 
   to work correctly.  etc. etc."


So apparently we have some sort of competition between the onClick attribute
of the anchor, which wants to do "document.loginform.submit(); return false;"
and the HREF attribute, which wants to bring up the "enable JavaScript" HTML.


Reassigning to Event Handling for analysis -
Assignee: rogerl → joki
Component: Javascript Engine → Event Handling
QA Contact: pschwartau → gerardok

Comment 3

18 years ago
I would like to mark this as WORKSFORME, but since Ed is using the
same date build as I am on Windows, I'd like a third person to give 
it a try before resolving it that way - 

Comment 4

18 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 5

18 years ago
*** Bug 86336 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.