Intermittent mochitest-3 Shutdown | application timed out after 330 seconds with no output after Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))), at /build/media/mtransport/runnable_utils.h:48

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: philor, Assigned: jib)

Tracking

({assertion, intermittent-failure})

Trunk
x86
Windows 7
assertion, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc-])

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=21459718&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-3 on 2013-04-04 13:43:07 PDT for push 051cf1c1449c
slave: talos-r3-w7-066

21:32:28     INFO -  0[10de4f10]: [|WebrtcVideoSessionConduit] VideoConduit.cpp:624: mozilla::WebrtcVideoConduit::SendRTCPPacket : channel 0 , len 40
21:32:28     INFO -  0[10de4f10]: [|WebrtcVideoSessionConduit] VideoConduit.cpp:633: mozilla::WebrtcVideoConduit::SendRTCPPacket Failed
21:32:29     INFO -  0[10de4f10]: [|WebrtcVideoSessionConduit] VideoConduit.cpp:624: mozilla::WebrtcVideoConduit::SendRTCPPacket : channel 0 , len 40
21:32:29     INFO -  0[10de4f10]: [|WebrtcVideoSessionConduit] VideoConduit.cpp:633: mozilla::WebrtcVideoConduit::SendRTCPPacket Failed
21:32:29     INFO -  [Parent 1396] WARNING: NS_ENSURE_TRUE(thread) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/netwerk/base/src/nsSocketTransportService2.cpp, line 129
21:32:29     INFO -  Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))), at e:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\media\mtransport\runnable_utils.h:48
21:37:59  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with no output
Isn't this an assertion in the media component?
Summary: Intermittent mochitest-3 Shutdown | application timed out after 330 seconds with no output after Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))) → Intermittent mochitest-3 Shutdown | application timed out after 330 seconds with no output after Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))), at /build/media/mtransport/runnable_utils.h:48
> WARNING: NS_ENSURE_TRUE(thread) failed: nsSocketTransportService2.cpp, line 129
> Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))), runnable_utils.h:48

Another case of dispatch to thread-gone-home on shutdown. From the warning it looks like it is the STS thread that is gone this time.
Do we need more info, or is this something we can try to address with just this report?
Assignee: nobody → jib
Flags: needinfo?(jib)
Priority: -- → P2
Whiteboard: [WebRTC][blocking-webrtc-]
Without it being reproducible, I would certainly welcome theories from people familiar with these codepaths, on what the cause may be or on more reliable reproduce steps.

My next step will be to instrument the assertion to get a callstack from where it happens, and perhaps if possible, also a callstack from the main thread at that time, so if someone knows intuitively what that will produce, please chime in. :-)
Flags: needinfo?(jib)
Any sign of this?
Hasn't been seen in close to 2 months. Closing, but reopen if this still reproduces.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.