Closed Bug 858449 Opened 7 years ago Closed 7 years ago

[SMS] The Contact search list from SMS app is not clearing when we touch backspace quickly

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P3)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 QE1 (5may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: sasikala.paruchuri8, Assigned: leo.bugzilla.gaia)

References

()

Details

(Keywords: regression, Whiteboard: [TD-8969])

Attachments

(1 file, 5 obsolete files)

1. Title : Contact search list from SMS app is not clearing when we touch backspace quickly
2. Precondition : Some contacts should be available in contacts app.
3. Tester's Action : Messages - New Message - input field - Enter the name of the contact which is present in contacts app - touch backspace quickly
4. Detailed Symptom (ENG.): The search list is not deleting when we touch the backspace quickly.
5. Expected : The search list should not be visible when we touch the backspace quickly.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Revision: 8e7262e3d98ea9574d7f79c1e890ad80cfa40c27
blocking-b2g: --- → leo?
Attached file Pointer to pull request (obsolete) —
Attachment #735142 - Flags: review?(fbsc)
Attached file Pointer to pull request (obsolete) —
Attachment #735142 - Attachment is obsolete: true
Attachment #735142 - Flags: review?(fbsc)
Attachment #735146 - Flags: review?
Could you specify the steps to reproduce it? Thanks!
Attached file Pointer to pull request (obsolete) —
Attachment #735146 - Attachment is obsolete: true
Attachment #735146 - Flags: review?
Attachment #735155 - Flags: review?(fbsc)
Attached file Pointer to pull request (obsolete) —
Attachment #735155 - Attachment is obsolete: true
Attachment #735155 - Flags: review?(fbsc)
Attachment #735157 - Flags: review?(fbsc)
Hi Borja,

The steps for reproducing this issue is
Save some contacts in Contacs app starting with same name
1.Go to SMS app
2.Select New Message icon
3.Click on input field
4.Enter the name of the contact which is present in contacts app
5.Touch backspace quickly

The contact list is not clearing when we click on backspace fastly

Thanks,
Hi Borja,

Please review the patch and provide your comments.

Thanks
Why is this patch already marked "r=borjasalguero"?
@sasikala: I agree Rick comments. Please update your PR and squash your changes.

@Rick: Due to for getting a review, we should add at least one of the 'peers'. In this case Julien and I (you can check the info of all apps 'peers' here https://wiki.mozilla.org/Modules/FirefoxOS)
Assignee: nobody → leo.bugzilla.gaia
blocking-b2g: leo? → leo+
Keywords: regression
Attachment #735157 - Attachment is obsolete: true
Attachment #735157 - Flags: review?(fbsc)
Attachment #735754 - Flags: review?(fbsc)
Testing again. Thanks!
Tested and uploaded patch with comments and new pull request.
Please review and provide your comments.

Thanks,
Whiteboard: [TD-8969]
Target Milestone: --- → Leo QE1 (5may)
Priority: -- → P3
Needs to be rebased, then r=me
Hi Rick,

I will rebase and upload the patch again.

Thanks,
Leo
Hi Rick,

Rebase is done.Please review and provide your comments.

Thanks,
Leo
Attachment #735754 - Flags: review?(waldron.rick)
Leo, please take a look to the comment https://github.com/mozilla-b2g/gaia/pull/9089/files#r3975326 . I don't know even if this is a bug with the current code in master.
Comment on attachment 735754 [details]
Pointer to Pull Request https://github.com/mozilla-b2g/gaia/pull/9089

Please take a look to the comment in the PR. THanks!
Attachment #735754 - Flags: review?(waldron.rick)
Attachment #735754 - Flags: review?(fbsc)
Hi Borja,

I have tested this in master code.This defect is still existing even in master code.

Thanks
Hi,

Tested and Uploaded the patch with the changes as per the master code.
Please review and provide your comments.

Thanks,
Leo
Attachment #735754 - Attachment is obsolete: true
Attachment #743461 - Flags: review?(fbsc)
Please update the commit name with the right bug number and for me it's r+.
Comment on attachment 743461 [details]
Pointer to pull request https://github.com/mozilla-b2g/gaia/pull/9474

Update the commit name and we are done!
Attachment #743461 - Flags: review?(fbsc) → review+
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted 46153e2871265083bceae41f1c6bb95a116758f0 to:
v1-train: c3e2c1c8ddb9b4883a7f102276a17ba6692b2b0b
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.