Closed Bug 858455 Opened 9 years ago Closed 9 years ago

Failure to link jsapi-tests with --enable-system-ffi

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(firefox22 fixed, firefox23 fixed)

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file)

No description provided.
Comment on attachment 733814 [details] [diff] [review]
Add system ffi flags when building jsapi-tests and gdb-tests

Review of attachment 733814 [details] [diff] [review]:
-----------------------------------------------------------------

There's not much context to go on in the bug report. My only concern was whether blindly adding MOZ_FFI_LIBS was a bad idea. But, from my local builds, it appears MOZ_FFI_LIBS is empty if we're not using --enable-system-ffi, so it doesn't seem like a big deal.
Attachment #733814 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/88d8ab81db89
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Comment on attachment 733814 [details] [diff] [review]
Add system ffi flags when building jsapi-tests and gdb-tests

[Approval Request Comment]
User impact if declined: build with --enable-system-libffi fails
Testing completed (on m-c, etc.): Tested on Debian builds
Risk to taking this patch (and alternatives if risky): NPOTB
String or IDL/UUID changes made by this patch: None
Attachment #733814 - Flags: approval-mozilla-aurora?
Attachment #733814 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.