imdb.com - Internet Movie Database doesn't conform to W3C stuf

RESOLVED WORKSFORME

Status

P1
minor
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: emlyyn, Assigned: bc)

Tracking

Details

(Whiteboard: dupme, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
http://us.imdb.com/Title?0268126 is one example of this. The plot summary and
the shopping box are painted in the same spot. Lots of people view the Internet
Movie Database, so this should be fixed.

I wasn't sure whether to assign this to evangelism or not - perhaps this is
Mozilla's problem but I don't think so. I saw this effect on build 2001060712
for macintosh, for future reference if this turns out to be a layout bug after all.
(Assignee)

Comment 1

18 years ago
Reporter, what build did you use when you saw this problem? I can not reproduce
this problem in 2001-06-20-04/win2k.

The page uses Layer tags etc, but appears to do so in a cross browser fashion.
The page also has an HTLM 3.2 DOCTYPE which is not true because of the LAYER tags.

Can someone with a recent build on a Mac confirm this?
(Reporter)

Comment 2

18 years ago
As previously stated, I was using the milestone build: 2001060712. I have since
upgraded to a still later version, 2001061908, and I still see this effect. If
you don't see it on windows then this bug probably is for layout rather than
evangelism - I'll look further into it since it's likely to be already reported
elsewhere on bugzilla.
(Assignee)

Comment 3

18 years ago
my bad. sorry i missed your report of the build. been looking at too many bugs i
think. thanks for helping with this. cc'ing chrisn for another mac tester.
(Reporter)

Comment 4

18 years ago
Okay, now that I suspect this is a layout bug rather than a problem at imdb,
I've looked into it in depth a little more. They use only tables for layout, so
somehow the content of a particular cell is spilling out of its confines. But
searching through bugzilla, I can't find any macintosh-only bugs about table
cells spilling everywhere. If this isn't a duplicate, I'd better give you a
screenshot of what I'm seeing...
(Reporter)

Comment 5

18 years ago
Created attachment 39506 [details]
screenshot of one page with problems (png)

Updated

18 years ago
Hardware: Other → Macintosh

Comment 6

18 years ago
I am seeing this on 2001070708 mac os x (in classic), but I don't think this is
evang. Bc: can you poke at this and see if this is an evang issue or a layout issue?

Zach
(Assignee)

Comment 7

18 years ago
zach: I think it is a Mac only layout issue, but I could always be wrong. It
looks like it has to do with a) the align attribute on the IMDb image and b) the
interaction with the stuff following with class="ch". If you look at the css for
ch, it has a white-space: nowrap. To see if this idea is correct, save the page
to disk, along with the css file and edit the css rules for ch to remove the
whitespace: nowrap rule and see what happens.

Comment 8

17 years ago
This WORKSFORME using Mac/2001062823. Reporter or Zach, perhaps try changing
your default font. I've seen some strangeness when using particular fonts. Be
sure the font actually changes (it should; the page is displaying in my own
selected font presently).

Also, just for fun, ensure the right character coding is selected (ISO 8859-1).

Comment 9

17 years ago
It looks like we have two issues going on here. A layer issue with 
doubleclick ads that we need to evang on, and some type of issue either 
with font schumck or layout. 

Bc: for the 2xclick issue and layer, should this depend on a metabug, 
moved to bugscape, or be handled on it's own? I can whip up a letter for 
them if the latter.

One way or another, this should be confirmed for the <layer> issue, let 
them get that hard earned ad revenue!
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Updated

17 years ago
Priority: -- → P1
Summary: Internet Movie Database doesn't conform to W3C stuf → imdb.com - Internet Movie Database doesn't conform to W3C stuf
Whiteboard: dupme
(Reporter)

Comment 11

17 years ago
Okay, this has somehow been fixed (2001 10 26). Marking Worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.