Closed Bug 858483 Opened 8 years ago Closed 6 years ago

The Password Doorhanger is misplaced if the url bar is hidden when signing in

Categories

(Firefox for Android Graveyard :: General, defect, P5)

23 Branch
ARM
Android
defect

Tracking

(firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox27 unaffected, firefox28 unaffected, firefox29 affected, firefox30 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox37 affected, firefox38 affected, firefox39 affected, firefox40 affected, fennec+)

RESOLVED DUPLICATE of bug 1151505
Firefox 28
Tracking Status
firefox23 --- affected
firefox24 --- affected
firefox25 --- affected
firefox26 --- affected
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- affected
firefox30 --- affected
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox37 --- affected
firefox38 --- affected
firefox39 --- affected
firefox40 --- affected
fennec + ---

People

(Reporter: TeoVermesan, Unassigned)

References

Details

Attachments

(3 files)

Attached image Password Doorhanger
Firefox for Android 23.0a1 (2013-04-04)
Device: Acer Iconia A500
OS: Android 3.2.1

Steps to reproduce:
1. Launch Firefox 
2. Go to www.gmail.com
3. Enter email and password.
4. Press "Sign in"

Expected results:
- After step 4, the password doorhanger appears and should be correctly displayed.

Actual results:
- The password doorhanger is misplaced (Please see attached screenshot)
I'm also able to reproduce this on Samsung Galaxy Tab2 7" (Android 4.1.1) and Samsung Galaxy Tab 10 (Android 4.0.4)
(In reply to Teodora Vermesan (:TeoVermesan) from comment #2)
> Created attachment 733819 [details]
> Samsung Galaxy Nexus(Android 4.1.1)

This screenshot looks fine to me. The tablet screenshot looks wrong.
Assignee: nobody → sriram
Attached image Nightly (2013-04-02)
Did you happen to rotate and not indicate in your steps to reproduce? If so, this has been around forever and this would be a dupe of bug 739205.

Also you can take screenshots through the monitor application in the Android SDK.
This happens on first load. There is no need for rotation.
I am able to reproduce this on Firefox Mobile 23 beta 1 on the Acer Iconia Tab (Android 3.0) using the following steps:
1) load gmail.com
2) scroll the page a bit until the URL bar is hidden
3) Type in the username and password and then tap Enter

Actual results:
The doorhanger is displayed in the middle of the URL bar

This is most likely caused by the dynamic toolbar
tracking-fennec: --- → ?
(In reply to Adrian Tamas from comment #7)
> This is most likely caused by the dynamic toolbar

Can you confirm by disabling it in about:config?
Flags: needinfo?(adrian.tamas)
I am unable to reproduce the issue on Aurora 23.0a2 2013-06-25 on the Acer Iconia Tab 
(Android 3.0) if I disable the dynamic toolbar since step 2 from the STR in Comment 7 requires the URL bar to be hidden.
Flags: needinfo?(adrian.tamas)
tracking-fennec: ? → +
This is reproducible also on twitter.com and facebook.com. Changing the title to reflect the exact issue
Summary: The Password Doorhanger is misplaced on gmail.com → The Password Doorhanger is misplaced if the url bar is hidden when signing in
Unable to reproduce this issue on latest Nightly 28.0a1(2013-11-21) and latest Aurora 27.0a2(2013-11-22).
(In reply to Pop Mihai from comment #11)
> Unable to reproduce this issue on latest Nightly 28.0a1(2013-11-21) and
> latest Aurora 27.0a2(2013-11-22).

This looks a lot like bug 928800, which was fixed recently and pushed to Aurora and Beta on Nov 21th. It won't appear in a Beta build until next week, I think.

I am not going to dup this bug, but I will mark it fixed so we retest.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
I am able to reproduce this on latest Nightly 11/25 on LG Nexus 4 (Android 4.2.2) on facebook.com, but I am not able to reproduce this on wiki.mozilla.org
I am able to reproduce this on Firefox for Android 28 Beta 2 on LG Nexus 4 (Android 4.4) and Alcatel One Touch (Android 4.1) on facebook.com
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: sriram.mozilla → nobody
Status: REOPENED → NEW
I am still able to reproduce this on all branches on Samsung Galaxy Note 3 (Android 4.4.2) on facebook.com
Maybe this can be mentored?
Flags: needinfo?(margaret.leibovic)
(In reply to Aaron Train [:aaronmt] from comment #16)
> Maybe this can be mentored?

I would need to dig into this to figure out how to fix it, so I don't feel like making it a mentor bug.
Flags: needinfo?(margaret.leibovic)
filter on [mass-p5]
Priority: -- → P5
This sounds similar to bug 1151505.
Status: NEW → RESOLVED
Closed: 8 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151505
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.