[SMS] previous messages to a person are not shown anymore - (NS_ERROR_NOT_IMPLEMENTED) [nsIMobileMessageCallback.notifyNextMessageInListGot]

VERIFIED FIXED

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: whimboo, Assigned: vicamo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/68caf3b9d213
Gaia   a845be046c5d3cb077e3c78f963ca5c079e7ab3d
BuildID 20130403230205
Version 18.0

Opening a contact in the SMS app doesn't show list of old messages anymore. An error gets thrown in the console:

E/GeckoConsole( 3588): [JavaScript Error: "[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMobileMessageCallback.notifyNextMessageInListGot]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: jar:file:///system/b2g/omni.ja!/components/MobileMessageDatabaseService.js :: oncomplete :: line 1825"  data: no]" {file: "jar:file:///system/b2g/omni.ja!/components/MobileMessageDatabaseService.js" line: 1825}]

Steps:
1. Open SMS application
2. Select a contact you have been in a conversation before
3. Observe that no former messages are shown
Vicamo, Borja:  did something regress here?
Flags: needinfo?(vyang)
Flags: needinfo?(fbsc)
Looks like this only is happening for contacts which have been added before a recent API change has been made. Sending a SMS to a number and adding it the contacts doesn't show this problem.
Triage agreed this should block 1.1. Please fix and add tests to ensure it doesn't regress again.
blocking-b2g: leo? → leo+
tracking-b2g18: ? → ---
Flags: in-testsuite?
(Assignee)

Comment 4

6 years ago
Have no such problem in verifying bug 850127. Will try again.
blocking-b2g: leo+ → leo?
tracking-b2g18: --- → ?
Flags: needinfo?(vyang)
(Assignee)

Comment 5

6 years ago
Well, sorry for reverted the flags :(
tracking-b2g18: ? → ---
Vicamo, please comment this bug after testing it. Thanks!
Assignee: nobody → vyang
This is still happening for me with 1.1.0.0-prerelease as of yesterdays build. Not sure if the changes of bug 850127 made it into the nightly build.
blocking-b2g: leo? → leo+
(Assignee)

Comment 8

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #7)
> This is still happening for me with 1.1.0.0-prerelease as of yesterdays
> build. Not sure if the changes of bug 850127 made it into the nightly build.

With bug 838467, bug 849739 landed in m-c, the code piece specified in bug description is completely rewritten. Will retry again after related patches uplifted to b2g18.
(Assignee)

Comment 9

6 years ago
That's a Gecko issue.
Flags: needinfo?(fbsc)
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
(Assignee)

Updated

6 years ago
Duplicate of this bug: 860938
Regression window wanted no longer warranted - needs a retest instead per comment 8.
Keywords: regressionwindow-wanted → qawanted
Is working fine in a unagi device with bc1fd377bf73fa8b6af19a39b20866ffc203b87b gaia commit and Gecko-55cc177 from v1-train.

Is working fine too in the same unagi device with Gecko-b0123a5.Gaia-63890fe from v1.0.1 and QC RIL AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.072.
Keywords: qawanted
Works for me then per comment 12.

Thanks for the timely response Carlos.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Tested in unagi device with today´s nightly from V1.0.1 (Gecko-4229cbb.Gaia-3e7dda8) with AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.072 QC RIL and working fine too.
(In reply to Carlos Martínez Toral [:carlosmartinez] from comment #12)
> Is working fine in a unagi device with
> bc1fd377bf73fa8b6af19a39b20866ffc203b87b gaia commit and Gecko-55cc177 from
> v1-train.

There is no build out as of today. The one you are referring to is the one from yesterday? I also have that one installed and it's not working for me. Please see comment 8. The mentioned patches have not been landed on b2g18 yet. So I doubt it can work for you.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Seems like the commit comes from:

commit 4229cbbb556f7106351942628c21a64b3f77ae41
Author: Brian Smith <bsmith@mozilla.com>
Date:   Thu Apr 11 17:43:06 2013 -0700

    Bug 839141: Update NSS to NSS 3.14.3 (NSS_3_14_3_RTM), a=akeybl, r=me
    
    --HG--
    extra : source : c0cd11d99953f4c547b9387ad9b9e6d8b72a7ede

But not able to reproduce anyway.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 860724
(Assignee)

Comment 18

6 years ago
Have no longer this issue after all MMS changes uplifted.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
This does still not work for me given that I now get a crash and the system restarts when I try to open such an old contact's history.  I will further investigate and most likely file a new bug on it.
Depends on: 863156
Filed as bug 863156. Also marking this one as fixed given that backports of the before mentioned patches in comment 8 have fixed the bug.
Depends on: 838467, 849739
No longer depends on: 863156
Resolution: WORKSFORME → FIXED

Updated

6 years ago
Status: RESOLVED → VERIFIED
Why was this bug marked as Resolved? I am still seeing this issue on the latest Unagi 1.1.0.0-prerelease build (20130417070204).
What builds should this be fixed on? It's definitely not fixed for me. I see this in the logcat:

E/GeckoConsole(23281): [JavaScript Error: "[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMobileMessageCallback.notifyNextMessageInListGot]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: jar:file:///system/b2g/omni.ja!/components/MobileMessageDatabaseService.js :: oncomplete :: line 1827"  data: no]" {file: "jar:file:///system/b2g/omni.ja!/components/MobileMessageDatabaseService.js" line: 1827}]

OS version: 1.1.0.0-prerelease
Platform: 18.0
Build ID: 20130417070204
Channel: Beta
Git commit: 2013-04-17 08:35:03 3774a75
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
I just updated and now when I try to view a specific message, it crashes FirefoxOS entirely.

Same steps to reproduce as befre. Specifically:

1. start the device
2. click on messages app
3. click on a message that was causing me problems before
4. screen flickers and FirefoxOS crashes

logcat has a bunch of stuff I don't recognize, but right around here is where I start the messages app:

I/IdleService(  877): next timeout 1000 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 1000 msec from now
I/IdleService(  877): reset timer expiry to 1009 msec from now
I/IdleService(  877): Reset idle timeout: tell observer 47c0b8d0 user is back
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:3129344 fd:103
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:3743744 fd:108
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:4358144 fd:113
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a767000 size:614400 offset:3129344 fd:103
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a7fd000 size:614400 offset:3743744 fd:108
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:3129344 fd:103
I/IdleService(  877): Get idle time: time since reset 904 msec
I/IdleService(  877): Idle timer callback: current idle time 904 msec
I/IdleService(  877): next timeout 96 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 96 msec from now
I/IdleService(  877): reset timer expiry to 106 msec from now
E/GeckoConsole( 1013): [JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "app://sms.gaiamobile.org/style/common.css" line: 31}]
E/GeckoConsole( 1013): [JavaScript Warning: "Error in parsing value for 'line-height'.  Declaration dropped." {file: "app://sms.gaiamobile.org/style/sms.css" line: 507}]
I/IdleService(  877): Get idle time: time since reset 1007 msec
I/IdleService(  877): Idle timer callback: current idle time 1007 msec
I/IdleService(  877): next timeout 298992 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 298992 msec from now
I/IdleService(  877): reset timer expiry to 299002 msec from now
I/IdleService(  877): Idle timer callback: tell observer 47c0b8d0 user is idle
I/IdleService(  877): Get idle time: time since reset 1008 msec
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x4535c000 size:2383872 offset:2375680
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a5f7000 size:8192 offset:1622016 fd:133
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a6b1000 size:614400 offset:2383872 fd:148
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a68f000 size:8192 offset:2244608 fd:139
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a691000 size:122880 offset:2252800 fd:142
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a6af000 size:8192 offset:2375680 fd:145
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x4477a000 size:2244608 offset:1630208
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a5f9000 size:614400 offset:1630208 fd:136
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x45a08000 size:3006464 offset:2998272
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a747000 size:8192 offset:2998272 fd:151
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a749000 size:122880 offset:3006464 fd:159
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x45d68000 size:3129344 offset:3006464
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x44500000 size:1630208 offset:1622016
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x45678000 size:2998272 offset:2383872
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x44e00000 size:2252800 offset:2244608
D/memalloc(  937): /dev/pmem: Unmapping buffer base:0x45118000 size:2375680 offset:2252800
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:3743744 fd:85
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44400000 size:4358144 offset:3743744 fd:32
E/GeckoConsole( 1013): [JavaScript Warning: "Expected pseudo-element but found '-moz-placeholder'.  Ruleset ignored due to bad selector." {file: "app://sms.gaiamobile.org/shared/style/input_areas.css" line: 40}]
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:1228800 fd:108
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44828000 size:1843200 offset:1228800 fd:35
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:532480 offset:1843200 fd:111
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44d00000 size:2375680 offset:1843200 fd:38
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:450560 offset:2375680 fd:120
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44fac000 size:2826240 offset:2375680 fd:41
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:532480 offset:4972544 fd:123
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x45276000 size:5505024 offset:4972544 fd:44
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:450560 offset:5505024 fd:127
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x458a4000 size:5955584 offset:5505024 fd:47
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:49152 offset:2826240 fd:131
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x45e52000 size:2875392 offset:2826240 fd:50
I/ONCRPC  (  112): rpc_handle_rpc_call: for Xid: 2b0, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  112): rpc_handle_rpc_call: Find Status: 0 Xid: 2b0
I/ONCRPC  (  112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2b0
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a71d000 size:49152 offset:2826240 fd:131
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x45e52000 size:2875392 offset:2826240
E/profiler( 1038): Registering start signal
E/GeckoConsole( 1038): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
I/Gecko   ( 1038): ###################################### forms.js loaded
I/Gecko   ( 1038): ############################### browserElementPanning.js loaded
I/Gecko   ( 1038): ######################## BrowserElementChildPreload.js loaded
I/ONCRPC  (  112): rpc_handle_rpc_call: for Xid: 2b3, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  112): rpc_handle_rpc_call: Find Status: 0 Xid: 2b3
I/ONCRPC  (  112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2b3
I/IdleService(  877): next timeout 1000 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 1000 msec from now
I/IdleService(  877): reset timer expiry to 1009 msec from now
I/IdleService(  877): Reset idle timeout: tell observer 47c0b8d0 user is back
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:5955584 fd:132
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x45e52000 size:6569984 offset:5955584 fd:50
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:532480 offset:6569984 fd:136
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x46518000 size:7102464 offset:6569984 fd:53
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:245760 offset:2826240 fd:140
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x46c3d000 size:3072000 offset:2826240 fd:56
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:7102464 fd:143
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x46f3b000 size:7716864 offset:7102464 fd:59
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44d00000 size:2375680 offset:1843200
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x458a4000 size:5955584 offset:5505024
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a62d000 size:532480 offset:1843200 fd:111
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a929000 size:532480 offset:4972544 fd:123
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a9ab000 size:450560 offset:5505024 fd:127
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a6af000 size:450560 offset:2375680 fd:120
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:7716864 fd:111
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x47697000 size:8331264 offset:7716864 fd:38
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:532480 offset:1843200 fd:120
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44d00000 size:2375680 offset:1843200 fd:47
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:245760 offset:2375680 fd:123
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x457b6000 size:2621440 offset:2375680 fd:62
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:4972544 fd:127
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x47e89000 size:5586944 offset:4972544 fd:65
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x45276000 size:5505024 offset:4972544
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44fac000 size:2826240 offset:2375680
I/IdleService(  877): Get idle time: time since reset 834 msec
I/IdleService(  877): Idle timer callback: current idle time 834 msec
I/IdleService(  877): next timeout 166 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 166 msec from now
I/IdleService(  877): reset timer expiry to 176 msec from now
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:49152 offset:3072000 fd:146
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44f44000 size:3121152 offset:3072000 fd:41
I/IdleService(  877): Get idle time: time since reset 1011 msec
I/IdleService(  877): Idle timer callback: current idle time 1011 msec
I/IdleService(  877): next timeout 298988 msec from now
I/IdleService(  877): SetTimerExpiryIfBefore: next timeout 298988 msec from now
I/IdleService(  877): reset timer expiry to 298998 msec from now
I/IdleService(  877): Idle timer callback: tell observer 47c0b8d0 user is idle
I/IdleService(  877): Get idle time: time since reset 1012 msec
D/memalloc(  877):  Out of PMEM. Dumping PMEM stats for debugging
D/memalloc(  877):  ------------- PRINT PMEM STATS --------------
D/memalloc(  877):  Node 0 -> Start Address : 0 Size 19200 Free info 0
D/memalloc(  877):  Node 1 -> Start Address : 19200 Size 19200 Free info 0
D/memalloc(  877):  Node 2 -> Start Address : 38400 Size 19200 Free info 0
D/memalloc(  877):  Node 3 -> Start Address : 57600 Size 16640 Free info 0
D/memalloc(  877):  Node 4 -> Start Address : 74240 Size 7680 Free info 0
D/memalloc(  877):  Node 5 -> Start Address : 81920 Size 6400 Free info 1
D/memalloc(  877):  Node 6 -> Start Address : 88320 Size 7680 Free info 0
D/memalloc(  877):  Node 7 -> Start Address : 96000 Size 1536 Free info 0
D/memalloc(  877):  Node 8 -> Start Address : 97536 Size 256 Free info 1
D/memalloc(  877):  Node 9 -> Start Address : 97792 Size 19200 Free info 0
D/memalloc(  877):  Node 10 -> Start Address : 116992 Size 19200 Free info 0
D/memalloc(  877):  Node 11 -> Start Address : 136192 Size 19200 Free info 0
D/memalloc(  877):  Node 12 -> Start Address : 155392 Size 19200 Free info 0
D/memalloc(  877):  Node 13 -> Start Address : 174592 Size 11520 Free info 1
D/memalloc(  877):  Node 14 -> Start Address : 186112 Size 19200 Free info 0
D/memalloc(  877):  Node 15 -> Start Address : 205312 Size 16640 Free info 0
D/memalloc(  877):  Node 16 -> Start Address : 221952 Size 19200 Free info 0
D/memalloc(  877):  Node 17 -> Start Address : 241152 Size 19200 Free info 0
D/memalloc(  877):  Node 18 -> Start Address : 260352 Size 1792 Free info 1
D/memalloc(  877):  Total Allocated: Total Free: 
D/memalloc(  877): ----------------------------------------------
E/memalloc(  877): /dev/pmem: No more pmem available
W/memalloc(  877): Falling back to ashmem
D/memalloc(  877): ashmem: Allocated buffer base:0x44a25000 size:614400 fd:149
D/memalloc( 1013): ashmem: Mapped buffer base:0x42814000 size:614400 fd:44
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x47e89000 size:5586944 offset:4972544
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a929000 size:614400 offset:4972544 fd:127
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4ab31000 size:614400 offset:7102464 fd:143
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x47697000 size:8331264 offset:7716864
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44d00000 size:2375680 offset:1843200
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x46c3d000 size:3072000 offset:2826240
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x46f3b000 size:7716864 offset:7102464
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4abc7000 size:614400 offset:7716864 fd:111
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4aa19000 size:614400 offset:5955584 fd:132
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a62d000 size:532480 offset:1843200 fd:120
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4aaaf000 size:532480 offset:6569984 fd:136
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a71d000 size:245760 offset:2826240 fd:140
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a6af000 size:245760 offset:2375680 fd:123
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a759000 size:49152 offset:3072000 fd:146
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:1843200 fd:112
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x4523e000 size:2457600 offset:1843200 fd:38
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x45e52000 size:6569984 offset:5955584
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x46518000 size:7102464 offset:6569984
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x457b6000 size:2621440 offset:2375680
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44f44000 size:3121152 offset:3072000
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:2457600 fd:111
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44d00000 size:3072000 offset:2457600 fd:41
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44828000 size:1843200 offset:1228800
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a597000 size:614400 offset:1228800 fd:108
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x4523e000 size:2457600 offset:1843200
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a62d000 size:614400 offset:1843200 fd:112
D/memalloc(  877): ashmem: Freeing buffer base:0x44a25000 size:614400 fd:149
D/memalloc(  877): ashmem: Unmapping buffer base: 0x44a25000 size: 614400
D/memalloc(  877): /dev/pmem: Allocated buffer base:0x4a46b000 size:614400 offset:1228800 fd:109
E/Gecko   (  877): mozalloc_abort: Redirecting call to abort() to mozalloc_abort
D/memalloc( 1013): /dev/pmem: Mapped buffer base:0x44828000 size:1843200 offset:1228800 fd:35
D/memalloc( 1013): /dev/pmem: Unmapping buffer base:0x44400000 size:4358144 offset:3743744
D/memalloc(  877): /dev/pmem: Freeing buffer base:0x4a7fd000 size:614400 offset:3743744 fd:85
D/memalloc( 1013): ashmem: Unmapping buffer base: 0x42814000 size: 614400
E/AudioHardwareMSM76XXA( 1056): failed to open AUDIO_NORMAL_FILTER /system/etc/AudioFilter.csv: No such file or directory (2).
E/AudioHardwareMSM76XXA( 1056): failed to open AUTO_VOLUME_CONTROL /system/etc/AutoVolumeControl.txt: No such file or directory (2)
E/QualcommCamera( 1056): Qint android::get_number_of_cameras(): E
I/QualcommCameraHardware( 1056): getCameraInfo: IN
I/QualcommCameraHardware( 1056): getCameraInfo: loading libqcamera at 0xb000ee28
V/QualcommCameraHardware( 1056):  Storing the current target type as 3 
I/QualcommCameraHardware( 1056): getCameraInfo: numOfCameras = 1

I'm pretty sure at this point in the log, the device is restarting, so the rest is kind of moot.

Should I create a new bug for this?

OS version: 1.1.0.0-prerelease
Platform: 18.0
Build ID: 20130418070205
Channel: Beta
Git commit: 2013-04-05 21:17:35 a5a95f7
(In reply to Will Kahn-Greene [:willkg] from comment #23)
> I just updated and now when I try to view a specific message, it crashes
> FirefoxOS entirely.
>
> I'm pretty sure at this point in the log, the device is restarting, so the
> rest is kind of moot.
> 
> Should I create a new bug for this?

No, I already did so yesterday. It's bug 863156.
(Assignee)

Comment 25

6 years ago
Please check the build you're using, or maybe the landed changes are still not included in that build.

You can grep 'otifyNextMessageInListGot' (without prefix letter 'n' because it could be capital in C++ code) in dom/mobilemessage, and you'll find out there is only one debug line still contains that string. That method call is already removed from nsIMobileMessageCallback, and a new method, named notifyCursorResult, is added to nsIMobileMessageCursorCallback instead. So if you still get this error, it just can't be as new as current b2g18 HEAD.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
Marking as verified fixed based on the landing of the patches as mentioned in comment 8. Everything works fine now. Thanks.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
Setting status-b2g18 to fixed due to the bugs in comment 8 being uplifted to the b2g18 branch.
status-b2g18: affected → fixed
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.