If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Application permissions screen should use 'author' localization string, not 'developer'

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Bartosz Piec, Unassigned)

Tracking

({l12y})

unspecified

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In application permissions screen there is a string describing the author of the application and the 'developer' string is used there however while installing the application the 'author' string is used. We should change the string in the permissions screen.

Furthermore, the 'developer' string is used also in 'More information' setting where in Polish it must be translated differently.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: l12y
If the problem is the inconsistency of the literal (author vs. developer) I do not think we should block on this one. If there are any further problem, please provide more details and exact Steps to Reproduce. 

Adding Stas as it seems a consistency of localization issue.
blocking-b2g: tef? → ---

Updated

5 years ago
Flags: needinfo?(stas)
Daniel, the issue here is that we expose two strings and use them in three cases:

author=Author -- used to show the author of the app when installing it
developer=Developer -- used to show the author of the app in the Permission settings *as well as* in Device Information > More > Developer Settings as a button label

The desired situation is:

author=Author -- used to show the author of the app when installing it *and* to show the author of the app in the Permission settings
developer=Developer -- used in Device Information > More > Developer Settings as a button label

In order to fix this, we'd need to add the author=Author string to settings.en-US.properties.  Currently, it is present only in system.en-US.properties.  

I suggest we fix this in master and v1-train.  Taking this on v1.0.1 would break the string freeze.
blocking-b2g: --- → leo?
Flags: needinfo?(stas)
Created attachment 736712 [details] [diff] [review]
Patch
Attachment #736712 - Flags: review?(kaze)
Comment on attachment 736712 [details] [diff] [review]
Patch

Looks good to me. Staś, may I let you merge this and mark this bug as fixed?
Attachment #736712 - Flags: review?(kaze) → review+
Thanks, kazé!

Landed on master: https://github.com/mozilla-b2g/gaia/commit/6021f6773b67686369f5ca9b88f5b2b4eb1d235a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → affected
Resolution: --- → FIXED
Not a blocker, but tracking+. This patch will be approved for uplift to v1-train.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Comment on attachment 736712 [details] [diff] [review]
Patch

Bug caused by (feature/regressing bug #): n/a
User impact if declined: Confusing translations
Testing completed: Manual.
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch:  "author" added in setttings.properties
Attachment #736712 - Flags: approval-gaia-v1?

Comment 8

4 years ago
Comment on attachment 736712 [details] [diff] [review]
Patch

Approvals are now closed. Please nominate for blocking-b2g:leo? for critical issues.
Attachment #736712 - Flags: approval-gaia-v1?

Updated

4 years ago
Duplicate of this bug: 922629
You need to log in before you can comment on or make changes to this bug.