mail filter doesn't move mail correctly

VERIFIED FIXED

Status

MailNews Core
Filters
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: now michael@endbracket.net, Assigned: Navin Gupta)

Tracking

({regression})

Trunk
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (WinNT; U)
BuildID:    2001060703

BACKGROUND INFORMATION
I have 1 POP mail account and 1 NNTP news account configured in
Mozilla Mail-News.  I have 7 mail filters configured for my POP
account.  Most of my mail is filtered into a mail folder called
"work" (which exists at the same level as the "inbox"), or a
subdirectory of the "work" folder.

BUG
When receiving POP mail, each message appears to be filtered into
the appropriate folder (e.g. work->projecta): the message count in
that folder is incremented (as seen in the left-most pane (the folder pane?)), 
yet the message count in the "inbox" folder is also incremented for the same 
message.

Clicking on the "projecta" folder in the folder pane, where I would
expect to find the message, the message appears in the upper-most
pane (the thread pane?).  Clicking on the message, the message is either 
partially displayed, not displayed, or another message
(including the full headers for that other message, appearing as body text) 
is displayed in the bottom-most pane (preview pane?).  Double-clicking
the message to open it in its own window shows the same incorrect
message as the preview pane.

Looking in the "inbox" folder, the same message is also listed there
(in the thread pane), and the correct message is fully displayed in
the preview pane.  Double-clicking the message also shows the full
and correct message.

Moving the message from the folder where I would have expected the
message would have been moved to to another folder
(for instance: from work->projecta to work), the message appears in
the thread pane of the new folder.  Selecting the message sometimes
results in the same incomplete message as before, and sometimes an
"Unknown Error 80470002" occurs.  (I moved the message by clicking
and dragging the message from the thread pane and dropping it on
the appropriate folder icon in the folder pane.)

I have only noticed this since adding a newsgroup account today.

I received almost 200 mails in a short time today, which is more
than I would usually receive.

Selecting "Compact Folders" or "Empty Trash" from the "File" menu
does not seem to have any effect on this bug (i.e. selecting either
of these does not clean up or move the messages at all).

Reproducible: Sometimes
Steps to Reproduce:
Would be something like:
1. create a mail filter to move POP mail to another folder
2. receive lots of mail
3. try to view the mail in the folder it should've been moved to
(Reporter)

Comment 1

17 years ago
Closing and reopening Mozilla (browser and mailnews) does not cause the
messages to be shown differently (i.e. everything stays the same after a
restart).

The "projecta" filter has 2 "subject contains" conditions and 1 "to or cc 
contains" condition, matching at least 1 condition.

I have also observed this on another filter, which moves messages to a
different folder, and this filter has has only 1 "sender contains" condition.

Comment 2

17 years ago
The mail filter keeps turning off filters.  Today it's generally disabled two of
the filters (I'm now using 0.9.2).  On many prior days it has disabled
considerably more.  If I turn them back on, and check, they are remembered as
turned on, but if later I get mail that wasn't transferred to the apporpriate
folder, and check, then I will find that they have been turned off again.

(I think this is the same bug...but I'm not sure.)

Mozilla version {Build ID: 2001062815}

Comment 3

17 years ago
If your filters are disabling, you likely have a folder path problem - bug 41720
is the main tracking bug.  Is there or were there ever any unusual characters in
the folder name?  We also have seen problems with folder names having illegal
characters causing "unknown errors" (we have also seen unknown errors in other
scenarios).

Comment 4

17 years ago
No unusual characters.  They do usually occur within subfolders, but then almost
everything I deal with is within a subfolder.  The outer layer of folders have
names like "comp lang" and the internal layer have names like "Python
BlackAdder"  (Is a space a part of what you meant by an unusual character?)
I do have a great many folders + subfolders.  I've been wondering if I have just
overrun some maximum number of filters (I have 36 or 37), but it doesn't seem
quite like that.

One of the filters that's been turning off today is for a folder called "Erland
q" within "comp lang".  The filter name is "comp lang Erlang q".

Some of my folder names start with digits so that they will sort near the top,
e.g. "00 MTC" and "01 Mailing Lists".  But I did that on purpose, it wasn't
something done to me. 

Comment 5

17 years ago
I have a similar problem, which IIRC started showing up around 0.9.2:
Move mail filters would spontaneously disable themselves, causing my inbox to
rapidly fill up (instead of most of the mailing list traffic to be sorted into
local folders).  After much observation, I think I have narrowed down when the
problem occurs:
If new mail is detected (either by clicking "get new messages", auto-checking
the mailbox after specified time, or auto-checking the mailbox on startup), and
a message matches a move mail filter, and the destination folder is not visible
in the folder pane (because it is a subfolder of a collapsed folder), then the
filter will become disabled.  The filter will work correctly once the
destination folder is visible.  I *think* this occurs because the filter doesnt
think the destination folder really exists (probably has something to do with
the error catching listed in bug 41720).
On a related note, "Local Folders" always starts collapsed for me now (starting
somewhere between .9.1 and .9.2).  It used to remember previous state (usually
expanded), and thus this problem would not be as noticeable.

I am currently using build 2001070904 on windows 2000 professional.  My inbox is
an IMAP server, my "Local Folders" is on a different hard drive than the main
mozilla install and contains spaces and >8.3 character directory names (if
that's relavent).

-Doug

Comment 6

17 years ago
Makring NEW based on confirmation.
Keywords: regression

Comment 7

17 years ago
Marking NEW since Ksosez forgot
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
I can confirm the bug with the mail-filtering problem and collapsed folders.

I reproduced the problem with old filters imported from NS 4.7x and also with
new filters.
When they mach an incoming mail that should be moved to a collapsed folder the
filter is disabled and the mail is left in the inbox.

On the other hand - when the subfolder is viewable the filter works fine.

This problem is reproduceable in mozilla 0.92, 0.93 and NS 6.1
(Assignee)

Comment 9

17 years ago
thorsten, I am not able to reproduce this problem with collapsed folders. 
Can you verify using latest builds.

Comment 10

17 years ago
Confirmed - the bug is FIXED.

I just tested the latest nightly-build (2001091403) and the bug can't be
reproduced any more.
(Assignee)

Comment 11

17 years ago
Marking fixed. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

17 years ago
vrfy fixed
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.