Closed Bug 858639 Opened 7 years ago Closed 7 years ago

Mochitest-browser-chrome fails since 20/03/2013

Categories

(SeaMonkey :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(3 files)

The mochitest-browser-chrome test crashes since 20/03/2013 on the SeaMonkey testboxen, see http://tbpl.drapostles.org/?tree=SeaMonkey&rev=8a50d60dd7a0, for reference:
"mochitest-browser-chrome exception
=== Output ===
'python' 'mochitest/runtests.py' '--appname=seamonkey/seamonkey.exe' '--utility-path=bin' '--extra-profile-file=bin/plugins' '--certificate-path=certs' '--autorun' '--close-when-done' '--console-level=INFO' '--symbols-path=symbols' '--browser-chrome'
[...]
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4caaa0bc587d&tochange=a73a2b5c423b
Ok, this is because of Bug 851516.
Depends on: 851516
Do you know why? That patch shouldn't have impacted SeaMonkey.
I guess we just need to port the patch from Bug 851516 :). SeaMonkey browser chrome tests use browser-test.js to run the test suite.
Oh, now that I look at the patch I see what you mean. Hm, not sure why it doesn't work anymore..
One last comment on this for now, this JS error looks related:
JavaScript error: chrome://mochikit/content/browser-test.js, line 112: NS_ERROR_FAILURE: Failure

Maybe the mentioned bug # is not related?!
Removing dependency, likely caused by another bug.
No longer depends on: 851516
This assertion appears when it tries to access Object.keys(window) in line 112, browser-test.js (window is [ChromeWindow]):
###!!! ASSERTION: This is not supposed to fail!: 'Error', file e:/builds/slave/c-cen-t-w32-dbg/build/mozilla/js/xpconnect/src/nsXPConnect.cpp, line 924
nsXPConnect::GetWrappedNativePrototype(JSContext *,JSObject *,nsIClassInfo *,nsIXPConnectJSObjectHolder * *) [js/xpconnect/src/nsXPConnect.cpp:1703]
GetXPCProto [dom/base/nsDOMClassInfo.cpp:4291]
nsWindowSH::GlobalResolve(nsGlobalWindow *,JSContext *,JSObject *,jsid,bool *) [dom/base/nsDOMClassInfo.cpp:4639]
nsWindowSH::NewResolve(nsIXPConnectWrappedNative *,JSContext *,JSObject *,jsid,unsigned int,JSObject * *,bool *) [dom/base/nsDOMClassInfo.cpp:5140]
XPC_WN_Helper_NewResolve [js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1038]
js::baseops::LookupProperty<1>(JSContext *,JS::Handle<JSObject *>,JS::Handle<jsid>,JS::MutableHandle<JSObject *>,JS::MutableHandle<js::Shape *>) [js/src/jsobj.cpp:3518]
LookupPropertyById [js/src/jsapi.cpp:3568]
JS_LookupPropertyById(JSContext *,JSObject *,jsid,JS::Value *) [js/src/jsapi.cpp:3618]
JS_LookupUCProperty(JSContext *,JSObject *,wchar_t const *,unsigned int,JS::Value *) [js/src/jsapi.cpp:3645]
ResolveGlobalName [dom/base/nsDOMClassInfo.cpp:3447]
EnumerateGlobalName [dom/base/nsScriptNameSpaceManager.cpp:837]
PL_DHashTableEnumerate [objdir/mozilla/xpcom/build/pldhash.cpp:714]
nsScriptNameSpaceManager::EnumerateGlobalNames(PLDHashOperator (*)(nsAString_internal const &,void *),void *) [dom/base/nsScriptNameSpaceManager.cpp:845]
nsWindowSH::Enumerate(nsIXPConnectWrappedNative *,JSContext *,JSObject *,bool *) [dom/base/nsDOMClassInfo.cpp:3476]
XPC_WN_JSOp_Enumerate(JSContext *,JS::Handle<JSObject *>,JSIterateOp,JS::MutableHandle<JS::Value>,JS::MutableHandle<jsid>) [js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1193]
Snapshot [js/src/jsiter.cpp:232]

Maybe Bug 851887 is related?
Attached patch PatchSplinter Review
Ian: It turned out Bug 604039 added a new .xpt file. We need to also add this. The missing .xpt file caused the assertion and failing browser chrome test. Since Bug 846540 we don't need to port configure.in AC_SUBST/AC_DEFINE changes from mozilla-central anymore.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #738085 - Flags: review?
Attachment #738085 - Flags: review? → review?(iann_bugzilla)
Comment on attachment 738085 [details] [diff] [review]
Patch

Merging this bug with Bug 862701
Attachment #738085 - Flags: review?(iann_bugzilla)
Depends on: 862701
Should all be fixed now by Bug 863672 and Bug 862701
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Looks like comm-aurora browser chrome mochitest is still broken, need to update package-manifest.in again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Is this bug (fully) "fixed" now?
Flags: needinfo?(bugzilla)
I can't really tell as mochitests are broken on comm-aurora.
Flags: needinfo?(bugzilla)
But then on comm-beta mochitest-browser-chrome seems to run (with a few errors). I guess I can call this fixed for now.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.