All users were logged out of Bugzilla on October 13th, 2018

error tab (and body) not cleared

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jchermak, Unassigned)

Tracking

16 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 733956 [details]
Screen Shot 2013-04-05 at 11.00.49 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

I attempted to go to a (company internal) website when the network connection was down. I had asked to open a new tab for the website I was going to.


Actual results:

I got the (attached screenshot).  The site (in fact, all sites) was inaccessible.  I resolved the network connectivity problem and clicked the "try again".  The URL had been damaged (possibly unrelated), so I corrected it to development.ariba.com and again clicked "try again".  Apparently there was no change.  I WAS WRONG -- the website had responded (in an adjacent display) and just not cleared the error tab.


Expected results:

The URL I was after was a PPT (PowerPoint) slide. This normally results in a "New Tab" tab being created with no content and PowerPoint being started with the content of the slideshow. WHEN THIS INITIALLY FAILS (as above) AND THEN SUCCEEDS, the tab and body displayed for the URL are not reset in FireFox, leaving the user thinking the problem is still present.  Even after correcting the problem, the attached screenshot was displayed as if the problem still persisted.
Please update to Firefox20 and try to reproduce the error again, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen [:Matti] from comment #1)
> Please update to Firefox20 and try to reproduce the error again, thanks.

Confirmed with Firefox 20.0.

URL requested was http://development/ASM_Suite/CommonPLM/SP_Branching.ppt
This was an internal website (development.ariba.com).
The error is a DNS error (server not found).
What are the STR ?

a) load a domain where the DNS answers with NIXDOMAIN (unknown domain)
b) the retry button doesn't seem to work if the the domain is back ?
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 4

6 years ago
(In reply to Matthias Versen [:Matti] from comment #3)
> The error is a DNS error (server not found).
> What are the STR ?
> 
> a) load a domain where the DNS answers with NIXDOMAIN (unknown domain)
> b) the retry button doesn't seem to work if the the domain is back ?

Need something within a domain (like "development" under "ariba.com".  When DNS does not answer, Firefox tries "www.development.com" and then puts up error page. When connection restored, Firefox still hung up on new domain (www.development.com) instead of retrying subdomain (development.ariba.com).

Comment 5

6 years ago
That's the expected behavior.  When you navigate to a file that Firefox downloads instead of displaying in a tab, the current tab, whatever it contains, remains unchanged, while Firefox downloads and then possibly launches the file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.