Add Firefox Favicon to FHR page

RESOLVED FIXED in Firefox 23

Status

Firefox Health Report
Client: Desktop
P4
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lco, Assigned: mconnor)

Tracking

Trunk
Firefox 23
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 734028 [details]
no-favicon

There's currently no favicon present.
A new favicon could be better. CCing Stephen Horlander.
Assignee: nobody → sneethling
We cannot set this via the FHR page as it is an embedded iframe. It will have to be added to the wrapper that also holds the CSS healthreport.css that is being change re: the flexbox issues. 

We can most likely just use the one that is used by mozilla.org:
<link href="//mozorg.cdn.mozilla.net/media/img/favicon.ico" rel="shortcut icon" />

CC'ing mconnor

Updated

5 years ago
Component: General → about:healthreport
Product: Webtools → Firefox Health Report
(Assignee)

Comment 3

5 years ago
Do we have a built-in icon for these?  I'm not sure if we have favicons on other about pages (about:support doesn't have one either)
Assignee: sneethling → mconnor
Severity: normal → enhancement
Component: about:healthreport → Client: Desktop
(Assignee)

Updated

5 years ago
Duplicate of this bug: 859316
(In reply to Mike Connor [:mconnor] from comment #3)
> I'm not sure if we have favicons on
> other about pages (about:support doesn't have one either)

Not for all but ideally all in-content pages should have one (especially new pages).
about:home definitely has, although it uses the Firefox icon. The solution is simple, have the parent page for the health report include the following in it's head:

<link href="//mozorg.cdn.mozilla.net/media/img/favicon.ico" rel="shortcut icon" />

We already have changes that needs to go into the next release so, we can surely slip this one in there. @see https://bugzilla.mozilla.org/show_bug.cgi?id=858305
(Assignee)

Comment 7

5 years ago
Trivial to fix, so I'll toss in a patch, but a P4.
Priority: -- → P4
(Assignee)

Comment 8

5 years ago
Created attachment 744136 [details] [diff] [review]
copy/paste from about:home
Attachment #744136 - Flags: review?(mnoorenberghe+bmo)
Status: NEW → ASSIGNED
Attachment #744136 - Flags: review?(mnoorenberghe+bmo) → review+
(Assignee)

Updated

5 years ago
Summary: [FHR] Add Firefox Favicon to FHR page → Add Firefox Favicon to FHR page
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/services/services-central/rev/9180229e191a
Whiteboard: [fixed in services]
https://hg.mozilla.org/mozilla-central/rev/9180229e191a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in services]
Target Milestone: --- → Firefox 23
You need to log in before you can comment on or make changes to this bug.