Lobby Buzzfeed for support of Popcorn embeds

RESOLVED WORKSFORME

Status

Webmaker
General
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Jacob, Assigned: Jacob)

Tracking

Details

(Assignee)

Description

5 years ago
Buzzfeed has a great publishing system to make your own feeds that can go viral if they get amplified by others in the community.

I played around with it today, trying to make a post for my Pizza Time video
http://popcorn.webmadecontent.org/wrs

The problem is, they don't accept iframe embeds from popcorn.webmadecontent.org. If they did, we'd be in serious business.

Currently they accept URLs and embed codes from YouTube, Vimeo, Soundcloud, Rdio, Spotify, Facebook, Hulu, Google Video, LiveLeak, MetaCafe, DailyMotion, or MySpace Video.

It would be a matter of convincing someone who works there to add Popcorn to that list. Would be totally worth it if we had any leads, and I think they'd be pleased with the results.
(Assignee)

Comment 1

5 years ago
An
(Assignee)

Comment 2

5 years ago
(excuse the accidental typo in above comment) An update on this - Andy from Buzzfeed gave us some help and I successfully made a my own buzzfeed page that uses a Popcorn embed as a test:

http://www.buzzfeed.com/reluctanthero/pizza-time-9leq

Basically we can't embed Popcorn iframes using the video tab, but we can embed Popcorn iframes using the puzzle piece tab. 

Unfortunately this isn't obvious and people will try to embed it as a video (rather than a puzzle piece), so the next step will be to try and get Andy or someone else at Buzzfeed to accept iframes in the thumbnail tab instead of the puzzle piece tab.

I notified him of this, and am awaiting a response. I can ping him again to see if he'd be open to changing this, I'm sure he's super busy so I might wait a bit. But this would be an important step in getting Buzzfeed users to make their own Buzzfeed pages with Popcorn
This is great.  One thing we're working on based on the BuzzFeed use case is adding a preload=none feature to the iframe.  For places where you want to put a bunch of iframes on a page, this would mean they don't all start loading right away.

Scott's been working on a few related patches for this, CC'ing him.  Scott, make sure you communicate this out to Jacob when it's all in.

Comment 4

5 years ago
Just checking in on the status of this bug. Is it resolved?

Updated

5 years ago
Assignee: nobody → jacob

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 years ago
(In reply to Erica Sackin from comment #4)
> Just checking in on the status of this bug. Is it resolved?

Well that depends. The embeds work, but our goal is to have Popcorn embeds be supported under the video tab rather than the much less obvious puzzle piece tab. The reason being that most users will paste it in the video tab and get an error message, then assume that it's not possible to embed at all (which is what happened to me). The answer is that it is indeed possible, but only in the more obscure puzzle piece tab.

If you think it's worth sending Andy another email nudge since he hasn't replied from two weeks ago, then I will do that, just trying to be mindful of nagging them :)

Comment 6

5 years ago
I'm marking this as resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Component: Marketing → General
Product: Webmaker → Webmaker
You need to log in before you can comment on or make changes to this bug.