Last Comment Bug 858916 - Switch-to-tab does not work on always private browsing mode
: Switch-to-tab does not work on always private browsing mode
Status: VERIFIED FIXED
[mentor=jdm][lang=js]
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: 20 Branch
: x86_64 Windows 7
-- normal (vote)
: Firefox 23
Assigned To: Avinash [:hardfire]
:
: :Ehsan Akhgari
Mentors:
Depends on:
Blocks: 816527
  Show dependency treegraph
 
Reported: 2013-04-06 05:11 PDT by tatsuya.sugi
Modified: 2013-05-20 03:16 PDT (History)
6 users (show)
blair: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments
patch for bug (3.50 KB, patch)
2013-04-20 20:44 PDT, Avinash [:hardfire]
no flags Details | Diff | Splinter Review
fixed indentation (3.37 KB, patch)
2013-04-21 19:35 PDT, Avinash [:hardfire]
blair: review+
josh: feedback+
Details | Diff | Splinter Review

Description User image tatsuya.sugi 2013-04-06 05:11:24 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

- Check "Always use private browsing mode".
- Restart FireFox.
- Open any URL.
- Open other tab and input the same URL.



Actual results:

- "Switch-to-tab" does not work, that is, duplicate the same URL.
Comment 1 User image (mostly gone) XtC4UaLL [:xtc4uall] 2013-04-06 19:53:58 PDT
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130406 Firefox/23.0 ID:20130406030922 CSet: 768af8d8fad4

Found no dupe.
Comment 2 User image Josh Matthews [:jdm] 2013-04-06 20:09:07 PDT
This bug can be fixed by looking at the patch in bug 816527 (which originally disabled this functionality for private windows) and adding checks for PrivateBrowsingUtils.permanentPrivateBrowsing in places that make sense.
Comment 3 User image Rahul Gandhi 2013-04-07 11:55:50 PDT
I wants to work on this bug. I have prerequisite knowledge of  c,c++,javascript, Html and Css.
So please assign this to me.
Comment 4 User image Josh Matthews [:jdm] 2013-04-07 14:46:15 PDT
Great! Please ask if anything is unclear.
Comment 5 User image Rahul Gandhi 2013-04-08 13:58:05 PDT
I am new to development . so can you please help me and explain this bug.
Comment 6 User image Josh Matthews [:jdm] 2013-04-08 14:19:31 PDT
Have you looked at the patch in bug 816527? That's the code that will need to be changed by adding the extra checks for permanent private browsing mode.
Comment 7 User image Rahul Gandhi 2013-04-08 14:37:27 PDT
I have seen the patch but what kind of extra checks for permanent private browsing mode we have to add?
Comment 8 User image Josh Matthews [:jdm] 2013-04-08 14:43:43 PDT
It looks like you'll want to add an extra condition in every check that was added in that patch.
Comment 9 User image Josh Matthews [:jdm] 2013-04-15 07:28:27 PDT
Let's throw this back in the pool until you've finished the other work you're doing.
Comment 10 User image Avinash [:hardfire] 2013-04-20 20:44:42 PDT
Created attachment 740044 [details] [diff] [review]
patch for bug

Added the checks at the required places. I couldn't figure out how to write the tests, some help would be appreciated.
Comment 11 User image Soumya Deb [:Debloper] 2013-04-21 13:43:38 PDT
Hey Avinash, I see there are a couple of indentation nits to fix on a first glance.
Comment 12 User image Avinash [:hardfire] 2013-04-21 19:35:07 PDT
Created attachment 740148 [details] [diff] [review]
fixed indentation

fixed indentation.
Comment 13 User image Josh Matthews [:jdm] 2013-04-22 06:15:22 PDT
Comment on attachment 740148 [details] [diff] [review]
fixed indentation

Review of attachment 740148 [details] [diff] [review]:
-----------------------------------------------------------------

This looks like what I was expecting. Over to gavin, who knows the code better than me.
Comment 14 User image Blair McBride [:Unfocused] (UNAVAILABLE) 2013-04-22 22:54:48 PDT
Comment on attachment 740148 [details] [diff] [review]
fixed indentation

Review of attachment 740148 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - thanks, Avinash!

AFAIK, we don't have a way to test UI changes for permanent private browsing mode - so you don't need to worry about that.
Comment 15 User image Blair McBride [:Unfocused] (UNAVAILABLE) 2013-04-22 23:04:22 PDT
Landed on the fx-team branch, which will get merged into mozilla-central within a day or two:
https://hg.mozilla.org/integration/fx-team/rev/070edc4c07a6
Comment 16 User image Tim Taubert [:ttaubert] 2013-04-23 10:04:03 PDT
https://hg.mozilla.org/mozilla-central/rev/070edc4c07a6
Comment 17 User image Maria Grazia Alastra [:mga] 2013-05-20 03:16:00 PDT
Verified as fixed on Windows 7, 64 bits, on Aurora 23.0 and latest Nightly 24.0:

- User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130519 Firefox/23.0, Build ID: 20130519004019

- User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130519 Firefox/24.0, Build ID: 20130519031035

Note You need to log in before you can comment on or make changes to this bug.