Can't send mail through smtp server that requires authorisation

VERIFIED DUPLICATE of bug 85304

Status

MailNews Core
Networking: SMTP
--
critical
VERIFIED DUPLICATE of bug 85304
17 years ago
9 years ago

People

(Reporter: Andy Ruddock, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1) Gecko/20010607
BuildID:    After 20010607

My mail server requires authorisation, the username is my full e-mail address.
Up to, and including, 20010607 this is fine (use % instead of @ in username).
After 20010607 mail doesn't get sent, have a small 'progress' window and the
progress bar at the bottom of the mail window just keep going.
Netstat reports a connection to the server.

Reproducible: Always
Steps to Reproduce:
1. Have SMTP server that requires authorisation.
2. Have username as full e-mail address (including '@') - not sure if this is a
red herring.
3. Try to send mail.

Actual Results:  Small 'progress' window opens with progress bar, progress bar
on bottom of composer window starts. Necessary to quit, losing the message that
was being sent if it hadn't previously been saved.


Expected Results:  Sent mail.

Could this be related to bug 72610?

Comment 1

17 years ago
Is your SSL set to "When Available" in the SMTP server page?  If it is and
changing it to "Never" fixes things then this is a dup of bug 83989. Reading bug
84731 is probably more illuminating, but it will tell you to dup bug 83989. 
This should be fixed in the next nightly.
(Assignee)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 85304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.