Async window raising is evil

VERIFIED DUPLICATE of bug 77675

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 77675
17 years ago
9 years ago

People

(Reporter: Morten Welinder, Assigned: Blake Ross)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; rv:0.9.1+) Gecko/20010610
BuildID:    2001061022

It seems that mozilla likes to raise its windows at
certain times.  That's the domain of the window manager,
not the application.

Specifically, I like to have two or more windows open.
When I have read a page, I might click a link and while
mozilla is loading that page, I bring another page
(or even another application) forward in order to read
that.

Five seconds later, mozilla decides to raise the
first page.  Highly annoying.


Reproducible: Always
Steps to Reproduce:
(See above)



Actual Results:  Unwanted windows raised.


Expected Results:  Leave window raise decisions to the window manager.

Comment 1

17 years ago
I agree, this behavior is highly annoying.

I'm pretty sure this is a dup, though.

Comment 2

17 years ago
I'm pretty sure this is it.  terra@diku.dk, please reopen if you disagree.

*** This bug has been marked as a duplicate of 77675 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
*** Bug 299399 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.