Closed Bug 85901 Opened 19 years ago Closed 19 years ago

Mozilla crashes at NSGetModule, libnecko

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 85822

People

(Reporter: jens-uwe, Assigned: neeti)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5 i686; en-US; rv:0.9.1+) Gecko/20010613
BuildID:    2001061321

Mozilla reprocible crashes at this adress. It works fine with NS6.1PR1, so I
guess it is a recent regression. It also seem to work on windows.

Reproducible: Always
Steps to Reproduce:
1.go to 
http://www.cnn.com/2001/TECH/science/06/13/humans.overkill.reut/index.html
2.see mozilla crashing
3.

Actual Results:  Mozilla crashes

Expected Results:  should not crash

below you can find the informations from the debugger

Document
http://www.cnn.com/virtual/editions/europe/2000/roof/change.pop/frameset.exclude.html
loaded successfully
[Switching to Thread 9754 (initial thread)]

Program received signal SIGSEGV, Segmentation fault.
0x41f87fb5 in ?? ()
(gdb) bt
#0  0x41f87fb5 in ?? ()
#1  0x40802091 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnecko.so
#2  0x40806a1a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnecko.so
#3  0x40e4f47b in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libimglib2.so
#4  0x40e500d9 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libimglib2.so
#5  0x40e4ebb3 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libimglib2.so
#6  0x40807b68 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnecko.so
#7  0x407d4460 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnecko.so
#8  0x407d3d56 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnecko.so
#9  0x400ca2d1 in PL_HandleEvent () from /home/jur/ftp/test/mozilla/libxpcom.so
#10 0x400ca1c9 in PL_ProcessPendingEvents () from
/home/jur/ftp/test/mozilla/libxpcom.so
#11 0x400cb32b in nsEventQueueImpl::ProcessPendingEvents () from
/home/jur/ftp/test/mozilla/libxpcom.so
#12 0x406cecd9 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#13 0x406cea16 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#14 0x40365340 in g_io_unix_dispatch (source_data=0x40fbc678,
current_time=0xbffff094, user_data=0x40922a28) at giounix.c:135
#15 0x40366bd6 in g_main_dispatch (dispatch_time=0xbffff094) at gmain.c:656
#16 0x40367203 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#17 0x403673cc in g_main_run () at gmain.c:884
#18 0x4028200c in gtk_main () at gtkmain.c:807
#19 0x406cf25a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#20 0x406b0cdc in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnsappshell.so
#21 0x804f04b in NS_CreateNativeAppSupport ()
#22 0x804f98c in main ()
#23 0x40465a5e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93
The last day or builds have been crashing on many site for me.

I have a talkback report for a crash on http://www.aftonbladet.se that someone
on #mozillazine could be related to this bug. The incident ID is: TB31717064Q.

I also easily managed to crash on the cnn page mentioned in this bug report. The
 talkback ID for that crash is: TB31717064Q.

The latest build I have tried is 2001061406 on Linux.
I cannot reproduce crashes for either of the urls mentioned on linux build 
pulled on 6/14.

The talkback stack trace for url http://www.aftonbladet.se shows is the same as 
bug 85806

Incident ID 31717064 
 Stack Signature
               libpthread.so.0 + 0x7a30 (0x401cfa30) 331fab5e 
 Bug ID
 Trigger Time 
               2001-06-14 08:21:18 
 User Comments 
               This page crashes as soon as I enter it. 
 Build ID
               2001061406 
 Product ID
               MozillaTrunk 
 Platform ID
               LinuxIntel 
 Stack Trace

libpthread.so.0 + 0x7a30 (0x401cfa30) 
libnspr4.so + 0x1b617 (0x401b5617) 
nsSocketTransport::SetReuseConnection() 
nsHttpConnection::OnTransactionComplete() 
nsHttpTransaction::Cancel() 
nsHttpChannel::Cancel() 
imgRequest::Cancel() 
imgRequest::RemoveProxy() 
imgRequestProxy::Cancel() 
nsImageFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsLineBox::DeleteLineList() 
nsBlockFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsTableFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsTableOuterFrame::Destroy() 
nsLineBox::DeleteLineList() 
nsBlockFrame::Destroy() 
nsLineBox::DeleteLineList() 
nsBlockFrame::Destroy() 
nsFrameList::DestroyFrame() 
CanvasFrame::RemoveFrame() 
FrameManager::RemoveFrame() 
nsCSSFrameConstructor::ReconstructDocElementHierarchy() 
StyleSetImpl::ReconstructDocElementHierarchy() 
PresShell::ReconstructFrames() 
PresShell::StyleSheetAdded() 
nsDocument::InsertStyleSheetAt() 
CSSLoaderImpl::InsertSheetInDoc() 
CSSLoaderImpl::LoadStyleLink() 
nsStyleLinkElement::UpdateStyleSheet() 
HTMLContentSink::ProcessLINKTag() 
HTMLContentSink::AddLeaf() 
CNavDTD::AddLeaf() 
CNavDTD::AddHeadLeaf() 
CNavDTD::HandleStartToken() 
CNavDTD::HandleToken() 
CNavDTD::BuildModel() 
nsParser::BuildModel() 
nsParser::ResumeParse() 
nsParser::ContinueParsing() 
HTMLContentSink::ScriptEvaluated() 
nsScriptLoader::FireScriptEvaluated() 
nsScriptLoader::ProcessRequest() 
nsScriptLoader::OnStreamComplete() 
nsStreamLoader::OnStopRequest() 
nsStreamListenerTee::OnStopRequest() 
nsHttpChannel::OnStopRequest() 
nsOnStopRequestEvent::HandleEvent() 
nsARequestObserverEvent::HandlePLEvent() 
PL_HandleEvent() 
PL_ProcessPendingEvents() 
nsEventQueueImpl::ProcessPendingEvents() 
event_processor_callback() 
our_gdk_io_invoke() 
libglib-1.2.so.0 + 0xec60 (0x4034cc60) 
libglib-1.2.so.0 + 0x10328 (0x4034e328) 
libglib-1.2.so.0 + 0x10933 (0x4034e933) 
libglib-1.2.so.0 + 0x10acc (0x4034eacc) 
libgtk-1.2.so.0 + 0x8d667 (0x4026f667) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x1d38b (0x4048a38b) 
2001061408 still crashes for me on the cnn-page mentioned. 
I have the Suse6.4, which is rather old but worked perfectly well so far. I am
using the 2.4.5 kernel, just in case this helps. If you need more info, just ask :-)
Dupe of 85822 (confirmed by darin)

*** This bug has been marked as a duplicate of 85822 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.