Unable to enter panorama workspace

RESOLVED WORKSFORME

Status

Firefox Graveyard
Panorama
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Callek, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
So today, after an aurora update to 22, I can't seem to switch into my panorama view.

I am getting:

Timestamp: 4/7/2013 1:55:23 AM
Error: TypeError: candidate is undefined
Source File: chrome://browser/content/tabbrowser.xml
Line: 4229

This is leaving many of my tabs/work-items unnaccessible atm.

I'm unsure if my existing use triggered this state or if it was like this from the start (I don't switch my panorama workspaces too often, but I do rely on them for organization)

I have tried both button, and ctrl+~

Even doing "right click on tab"->Move to group does not work (it shows only "New Group" though I should have at least 5 other named groups in this window, and tab neither moves to group or creates a new group when I do that)

Withholding intentional restart pending a few days for someone to request possible useful state. (up to and including C++ realtime debugging)
Still works for me. Maybe related to bug 858643?

Comment 2

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #1)
> Still works for me. Maybe related to bug 858643?

What info can we pull from Callek to help debug? Getting this info is blocking us from asking Callek to find a regression window or possibly disable the root cause add-on.

Also adding qawanted to see if they can reproduce.
Flags: needinfo?(ttaubert)
Flags: needinfo?(ehsan)
Keywords: qawanted

Comment 3

5 years ago
Not sure if I know anything about this...
Flags: needinfo?(ehsan)
Callek and I just did some remote debugging over IRC and it seems like the Panorama iframe has been created and loaded. For some reason 'tabview.js' was only partially loaded and/or executed. Some objects were accessible but some were simply not. Panorama's UI object was definitely never initialized and we had about 21 initFrameCallbacks waiting for the 'tabviewframeinitialized' event to be fired.

It might have been just a platform hiccup although we have no explanation what exactly might have happened. Justin will reboot his machine soon and we'll see if the problem persists but there's not much more to investigate now as it seems like Panorama *should* have loaded just fine.
Flags: needinfo?(ttaubert)
Keywords: qawanted

Comment 5

5 years ago
Callek - please renominate if this reproduces for you.
status-firefox22: ? → ---
tracking-firefox22: ? → ---
(Reporter)

Comment 6

5 years ago
After restart my whole computer + update to latest aurora, I no longer see this issue.

While me and ttaubert did investigate, no action item or cause-for-bug was identified, and since I cannot reproduce at this time --> Reso/WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.