broken handling of parentheses near inlines with unicode-bidi: isolate

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Amir Aharoni, Assigned: smontagu)

Tracking

({regression, rtl})

10 Branch
x86_64
Linux
regression, rtl
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox22 wontfix, firefox23 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 734374 [details]
demonstration of the problem

If there are closing parentheses after the closing tag of <span dir="auto">, they are shown on the wrong side of the word. See the attached HMTL file.

Comment 1

5 years ago
Regression range:
m-c
good=2011-10-19
bad=2011-10-20
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9fa62f76f1cf&tochange=311fdb9b38b7

Suspected bug:
Jonathan Kew — bug 694986 - trailing bracket misplaced in LTR language names when language-picker UI is displayed RTL. r=mfinkle
Blocks: 694986
Keywords: regression, rtl
Version: 20 Branch → 10 Branch
Bug 694986 touched -only- mobile JS code in mobile/chrome/content/localePicker.js, which was specific to the XUL fennec UI, so it's never been part of desktop Firefox, and isn't even present on mobile any longer.

(See https://hg.mozilla.org/mozilla-central/rev/387f388bca1f.)

So I don't think that can have caused the issue here.
(Assignee)

Comment 3

5 years ago
No, this is certainly caused by an error in bug 613149

Comment 4

5 years ago
You're right.
Blocks: 613149
No longer blocks: 694986
(Assignee)

Comment 5

5 years ago
Created attachment 734631 [details] [diff] [review]
Patch

This was a very silly mistake :(
Assignee: nobody → smontagu
Attachment #734631 - Flags: review?(roc)
(Assignee)

Comment 6

5 years ago
The issue isn't with dir=auto as such, but with any inline element with unicode-bidi: -moz-isolate.
Summary: broken handling of parentheses near dir=auto → broken handling of parentheses near inlines with unicode-bidi: isolate
https://hg.mozilla.org/mozilla-central/rev/86a405c5f7af
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
(Assignee)

Comment 9

5 years ago
Comment on attachment 734631 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 613149, and exposed in more contexts by bug 548206
User impact if declined: regressions in reordering of bidirectional text -- in particular it will appear as if the new bidi features of isolation and autodirection make reordering less accurate instead of more accurate as intended
Testing completed (on m-c, etc.): baked on m-c since 2013-04-08
Risk to taking this patch (and alternatives if risky): Minimal.
String or IDL/UUID changes made by this patch: None
Attachment #734631 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #734631 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/759b1354f8cd
status-firefox22: --- → fixed
status-firefox23: --- → fixed
Target Milestone: mozilla23 → ---

Updated

5 years ago
Depends on: 870794
status-firefox22: fixed → wontfix
You need to log in before you can comment on or make changes to this bug.