PNG images do not display correctly at first

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Aaron Sherman, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Some (all?) PNG images seem to load with garbage obscuring them at first under
Linux/0.9.1 (Netscape 6.1 or Mozilla), but only under Linux (I do not see this
at home under Windows 98).

If I re-load the page or scroll, the garbage does not go away, but if I obscure
the window (e.g. move it off the screen and then back) it corrects the artifacts
and displays correctly.

Comment 1

17 years ago
Seems to be linux only - your example image works under Mac OS 9 2001060712

Comment 2

17 years ago
wfm with Linux 2001061308. Maybe it's been fixed on the trunk.
wfm with win2k build 20010614.. (CVS opt) 
must be Linux only ...

Comment 4

17 years ago
yeah.
png's don't display correctly..

btw, when we right click the image.
should there be a list of the resolution of the image?

i think this should be for jpeg and other image files..
just add a text thing under image properties with width and height.

Comment 5

17 years ago
wfm, linux 2001062706
Aaron Sherman:  do you use the plugger.so plug-in?  I had trouble with PNGs
displaying properly while using the plugger, but after removing plugger.so from
my plugins/ folder, they worked normally.  If you have the plugger, please try
removing it and maybe use a newer build.

Comment 7

17 years ago
WORKSFORME
this was fixed a while back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.