Default column settings in SENT folder keep getting lost, if Sent folder is selected when Thunderbird was shut down

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: Art Masson, Unassigned)

Tracking

20 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130401192816

Steps to reproduce:

In Thunderbird 20 Beta1...My column settings in my SENT folder keep getting lost.  If I go to reset back to default the columns are reset and the recipients are visible.  But these settings are getting randomly lost and I have to go back to "reset columns to default" repeatedly.


Actual results:

Default Columns (including recipient) are lost in my SAVE folder message reader UI view


Expected results:

Setting back to default settings should be retained, but the settings are lost and recipient is replaced by "from" when I exit Thunderbird and relaunch.
POP3(or Local Folders)? Or IMAP?
Is the "Sent" folder correctly pointed at Copies&Folders of an Identity?

Did you do "reset columns to default" with Sent folder open? (I think so)
If yes, did you terminate Tb normally?
After termition of Tb, was "senderCol":{"visible":false}, "recipientCol":{"visible":true}, saved in .msf file of the Sent folder?
(view .msf file by Text Editor and find all senderCol and recipientCol) 

FYI.
By intentional .msf file corruption, I could see such phenomenon only on [Gmail]/Sent Mail of Gmail IMAP which is not pointed by any Copies&Folders setting. I couldn't see on Sent folder of POP3 and IMAP which is properly pointed by Copies&Folders.
(Reporter)

Comment 2

5 years ago
This is a POP3 Mail account.
The Sent Folder is correctly pointed to my C:\mail folder and all my sent messages are visible in Thunderbird.

If do a "reset columns to default" (or if I select/add the recipient field) with the Sent folder open, it immediately correctly shows "recipients" and will continue to do so until I exit Thunderbird.  As soon as I come back into Thunderbird the SENT folder columns are back to the previous settings only showing FROM (looks just like my Inbox folder columns.

OK...now I need some help...where will I find the .msf file for the Sent folder?  All I see is a "sent.mozmsgs" folder with lots of messages and another folder called sent.sbd which is empty. 

If it helps I'm running Windows 7 SP 1, 64 bit OS
Stop hiding of files/directories, and show file extension always, via Windows Explorer/Tools/Folder Options/Display(or View).
(Reporter)

Comment 4

5 years ago
Contents of SENT.MSF File below (this file has a change date of 8/29/2008) !!!
File Path = C:\Users\Art\AppData\Roaming\Thunderbird\Profiles\fgjgwxl3.default\Mail\Local Folders
Full contents below....changes in setting columns are not changing the content or date of this file....
-------------------------------------------------
< <(a=c)> // (f=iso-8859-1)
  (80=ns:msg:db:row:scope:msgs:all)(81=subject)(82=sender)(83=message-id)
  (84=references)(85=recipients)(86=date)(87=size)(88=flags)(89=priority)
  (8A=label)(8B=statusOfset)(8C=numLines)(8D=ccList)(8E=msgThreadId)
  (8F=threadId)(90=threadFlags)(91=threadNewestMsgDate)(92=children)
  (93=unreadChildren)(94=threadSubject)(95=numRefs)(96=msgCharSet)
  (97=ns:msg:db:table:kind:msgs)(98=ns:msg:db:table:kind:thread)
  (99=ns:msg:db:table:kind:allthreads)
  (9A=ns:msg:db:row:scope:threads:all)(9B=threadParent)(9C=threadRoot)
  (9D=msgOffset)(9E=offlineMsgSize)
  (9F=ns:msg:db:row:scope:dbfolderinfo:all)
  (A0=ns:msg:db:table:kind:dbfolderinfo)(A1=numMsgs)(A2=numNewMsgs)
  (A3=folderSize)(A4=expungedBytes)(A5=folderDate)(A6=highWaterKey)
  (A7=mailboxName)(A8=UIDValidity)(A9=totPendingMsgs)
  (AA=unreadPendingMsgs)(AB=expiredMark)(AC=version)
  (AD=fixedBadRefThreading)(AE=folderName)(AF=charSet)>
{1:^80 {(k^97:c)(s=9)} }
{FFFFFFFD:^9A {(k^99:c)(s=9)} }

<(80=1)(81=200)>
{1:^9F {(k^A0:c)(s=9u)} 
  [1(^AC=1)(^AD=1)(^88^81)]}

@$${1{@
@$$}1}@
(In reply to Art Masson from comment #4)
> Contents of SENT.MSF File below (this file has a change date of 8/29/2008)
> !!!
> File Path =
> C:\Users\Art\AppData\Roaming\Thunderbird\Profiles\fgjgwxl3.
> default\Mail\Local Folders
> Full contents below....changes in setting columns are not changing the
> content or date of this file....

Is the file actually used as Sent message folder by Tb?
(i) Account Settings/Server Settings/Local Directory:
    => Accout's mail directory
(ii) Identity's Copy&Folders setting => pointer to sent folder.
     mail.identity.idX.fcc_folder => message folder for sent mail copy
     <FolderName> and <FolderName>.msf is set of files for mail folder.
Can you copy mail manually to the Sent message folder? If mail copy is OK is file size of Sent(no suffix) increased? Is mail data appended to  Sent(no suffix) file? After termiation of Tb, is Sent.msf updated?
Following is Sent.msf data, which was just created by Tb 17.0.5.
If updated by Tb, I think at least string of <mdb:mork:z v="1.4"/> is written in .msf...
> // <!-- <mdb:mork:z v="1.4"/> -->
> < <(a=c)> // (f=iso-8859-1)
>   (8A=label)(8B=statusOfset)(8C=numLines)(8D=ccList)(8E=bccList)
>   (8F=msgThreadId)(90=threadId)(91=threadFlags)(92=threadNewestMsgDate)
>   (93=children)(94=unreadChildren)(95=threadSubject)(96=msgCharSet)
>   (97=ns:msg:db:table:kind:msgs)(98=ns:msg:db:table:kind:thread)
>   (99=ns:msg:db:table:kind:allthreads)
>   (9A=ns:msg:db:row:scope:threads:all)(9B=threadParent)(9C=threadRoot)
>   (9D=msgOffset)(9E=offlineMsgSize)
>   (9F=ns:msg:db:row:scope:dbfolderinfo:all)
>   (A0=ns:msg:db:table:kind:dbfolderinfo)(A1=numMsgs)(A2=numNewMsgs)
>   (A3=folderSize)(A4=expungedBytes)(A5=folderDate)(A6=highWaterKey)
>   (A7=mailboxName)(A8=UIDValidity)(A9=totPendingMsgs)
>   (AA=unreadPendingMsgs)(AB=expiredMark)(AC=version)
>   (AD=fixedBadRefThreading)(80=ns:msg:db:row:scope:msgs:all)(81=subject)
>   (82=sender)(83=message-id)(84=references)(85=recipients)(86=date)
>   (87=size)(88=flags)(89=priority)>
> {1:^80 {(k^97:c)(s=9)} }
> {FFFFFFFD:^9A {(k^99:c)(s=9)} }
> 
> <(80=1)(81=Sent)(82=0)(83=51650fbe)>
> {1:^9F {(k^A0:c)(s=9u)} 
>   [1(^AC=1)(^AD=1)(^A7^81)(^A3=0)(^A5^83)]}
>(snip)
(In reply to Art Masson from comment #4)
> Contents of SENT.MSF File below (this file has a change date of 8/29/2008)

Is file name actually upper case "SENT.MSF" istead of normal/expected "Sent.msf"?
If so, problem of bug 752697 may be relevant.
(Reporter)

Comment 9

5 years ago
1.  My actual sent folder (where copies of my sent messages are stored) is 
    C:\mail\Sent.mozmsgs
2.  My sent messages are actively stored in this folder and visible in TB
3.  The contents of my profile.ini file is:
      [General]
      StartWithLastProfile=1

      [Profile0]
      Name=default
      IsRelative=1
      Path=Profiles/fgjgwxl3.default
4.  The name of the .msf file is "Sent.msf"  (no caps except for 1st character)
5.  Can you copy mail manually to the Sent message folder? YES 
6.  If mail copy is OK is file size of Sent(no suffix) increased? YES...and file is added.
7.  Is mail data appended to  Sent(no suffix) file? After termiation of Tb, is Sent.msf updated?  No...best I can tell Sent.msf file under local folders has not been updated since 2008.  Perhaps I'm looking at the wrong file however.
8.  msf files in folder C:\mail\smart folders ARE being updated with current dates as I move mail to Junk, Inbox and Trash (Junk.msf, Infox.msf, and Trash.msf)...HOWEVER there is NO Sent.msf file in this folder.
9.  Should I try downgrading my TB application to the last production release?  I don't think I had these problems until loading TB 20 Beta 1.
(Reporter)

Comment 10

5 years ago
Sorry error in the path name above
...the folder path name where msf files are being updated is:
C:\Users\Art\AppData\Roaming\Thunderbird\Profiles\fgjgwxl3.default\Mail\smart mailboxes
(Reporter)

Comment 11

5 years ago
If just noticed something:

If I am viewing my sent mail folder in TB and exit the program and then launch TB again, my view with "RECIPIENT" is lost and the columns revert to the inbox column headings without "recipient"

However, if I first return to view any other mail folder (INBOX for instance) and exit there, relaunch TB and then go the SENT folder, my settings are still there and I can see RECIPIENTS.  (of course if I then exit again and come back the RECIPIENTS column is gone again).
(In reply to Art Masson from comment #9)
> 1.  My actual sent folder (where copies of my sent messages are stored) is 
>     C:\mail\Sent.mozmsgs

How, Where, did you know that the C:\mail\Sent.mozmsgs is actual sent folder for Tb?
Search Google for "mozmsgs Thunderbird". You will perhaps know that files in the mozmsgs *DIRECTORY* is not created/used by Tb.
> http://kb.mozillazine.org/Files_and_folders_in_the_profile_-_Thunderbird
> *.wdseml Copies of messages (its actually a .eml file) created by Windows Search Integration 
> (requires Vista or Windows 7). They're stored in .mozmsg directories.

What is shown in Location: field of Folder Properties/General tab of the problematic your Sent folder?
(string in the Location: field is selectable. Do CTRL+A==Select All, and Copy&Paste to text editor)
This is filepath or pointer used by Tb for the message folder. 

What file is used by identities defined in prefs.js?
(1) Copy prefs.js in Tb's profile directory to C:\WORK\prefs.js.
Following is set in your profile.ini file, so, if file path of your profile.ini is c:\ ... \xxx\profiles.ini, prefs.js is c:\ ... \xxx\Profiles\fgjgwxl3.default\prefs.js
>      [Profile0]
>      Name=default
>      IsRelative=1
>      Path=Profiles/fgjgwxl3.default
(2) Edit C:\WORK\prefs.js by text editor, extract all following lines, where N is numeric digit,
> user_pref("mail.identity.idN.fcc", true) ;
> user_pref("mail.identity.idN.fcc_folder", " ... ");
> user_pref("mail.identity.idN.fcc_folder_picker_mode", " ...");
> user_pref("mail.identity.idN.fcc_reply_follows_parent", ...);
and extract all lines which contains string of "/Sent" (no quote).

Is folder/file relevant to message folder you call "Sent" seen in extracted lines?
"Message folder used as Sent folder of Tb to save sent mail copy" is message folder pointed by mail.identity.idN.fcc_folder entry which has mail.identity.idN.fcc=true.
"Message folder used as Sent folder of Tb to save sent mail copy" is never message folder or file named "Sent".

What is used by Tb's folder to save sent mail copy?
Is file named "Sent" pointed by other entry then mail.identity.idN.fcc_folder?
(In reply to Art Masson from comment #11)
> However, if I first return to view any other mail folder (INBOX for
> instance) and exit there, relaunch TB and then go the SENT folder, my
> settings are still there and I can see RECIPIENTS.  (of course if I then
> exit again and come back the RECIPIENTS column is gone again).

Did you check Sent.msf file content after each termination of Tb for senderCol:visible:true or false, recipientCol:visible:true or false?
(Reporter)

Comment 14

5 years ago
1.  There is no Sent.msf file in the path with my other .msf files which are updated with current date.
    Path = C:\Users\Art\AppData\Roaming\Thunderbird\Profiles\fgjgwxl3.default
    \Mail\smart mailboxes
2.  The location for my actual sent messages (from properties on the sent folder 
    in TB) is:    mailbox:///C:/Mail/Sent
(Reporter)

Comment 15

5 years ago
The problem with "losing" my sent folder column settings seems to only occur if I exit TB while viewing my sent folder.  If I exit TB while viewing any other folder the settings are retained.
(Reporter)

Comment 16

5 years ago
prefs.js file content follows:
--------------------------------------------------------------------
# Mozilla User Preferences

/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 */

user_pref("accessibility.typeaheadfind.flashBar", 0);
user_pref("app.update.disable_button.showUpdateHistory", false);
user_pref("app.update.lastUpdateTime.addon-background-update-timer", 1365656283);
user_pref("app.update.lastUpdateTime.background-update-timer", 1365738881);
user_pref("app.update.lastUpdateTime.blocklist-background-update-timer", 1365738242);
user_pref("app.update.lastUpdateTime.microsummary-generator-update-timer", 1311996833);
user_pref("app.update.lastUpdateTime.search-engine-update-timer", 1365656163);
user_pref("browser.cache.disk.capacity", 358400);
user_pref("browser.cache.disk.smart_size.first_run", false);
user_pref("browser.cache.disk.smart_size.use_old_max", false);
user_pref("browser.cache.disk.smart_size_cached_value", 358400);
user_pref("browser.download.lastDir", "O:\\1 - Photographs\\Animals\\Tundra");
user_pref("calendar.categories.names", "Anniversary,Birthday,Business,Calls,Clients,Competition,Customer,Favorites,Follow up,Gifts,Holidays,Ideas,Issues,Miscellaneous,Personal,Projects,Public Holiday,Status,Suppliers,Travel,Vacation");
user_pref("calendar.list.sortOrder", "7b05112a-b510-438e-af31-c9a980992de9");
user_pref("calendar.registry.7b05112a-b510-438e-af31-c9a980992de9.calendar-main-in-composite", true);
user_pref("calendar.registry.7b05112a-b510-438e-af31-c9a980992de9.name", "Home");
user_pref("calendar.registry.7b05112a-b510-438e-af31-c9a980992de9.old_calendar_id", 0);
user_pref("calendar.registry.7b05112a-b510-438e-af31-c9a980992de9.type", "storage");
user_pref("calendar.registry.7b05112a-b510-438e-af31-c9a980992de9.uri", "moz-storage-calendar://");
user_pref("calendar.timezone.local", "America/Chicago");
user_pref("dom.w3c_touch_events.expose", false);
user_pref("editor.history_title_0", "Re: Benefit one month out");
user_pref("editor.history_url_0", "file:///C:/Users/Art%20Masson/Desktop/Re%20%20Benefit%20one%20month%20out.html");
user_pref("editor.lastFileLocation.htmlmail", "C:\\Users\\Art Masson\\Desktop");
user_pref("editor.lastFileLocation.image", "C:\\Users\\Art Masson\\Desktop");
user_pref("extensions.blocklist.pingCountTotal", 330);
user_pref("extensions.blocklist.pingCountVersion", 25);
user_pref("extensions.bootstrappedAddons", "{}");
user_pref("extensions.databaseSchema", 14);
user_pref("extensions.enabledAddons", "tbtestpilot%40labs.mozilla.com:1.3.9,%7B3ed8cc52-86fc-4613-9026-c1ef969da4c3%7D:2.8.0.1,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:20.0");
user_pref("extensions.enabledItems", "FiltersImportExport@mozilla.org:1.3.7.6,{3ed8cc52-86fc-4613-9026-c1ef969da4c3}:2.6.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.1.11");
user_pref("extensions.installCache", "[{\"name\":\"app-global\",\"addons\":{\"{972ce4c6-7e08-4474-a285-3208198ce6fd}\":{\"descriptor\":\"C:\\\\Program Files (x86)\\\\Mozilla Thunderbird\\\\extensions\\\\{972ce4c6-7e08-4474-a285-3208198ce6fd}\",\"mtime\":1362845002537}}},{\"name\":\"app-profile\",\"addons\":{\"FiltersImportExport@mozilla.org\":{\"descriptor\":\"C:\\\\Users\\\\Art\\\\AppData\\\\Roaming\\\\Thunderbird\\\\Profiles\\\\fgjgwxl3.default\\\\extensions\\\\FiltersImportExport@mozilla.org\",\"mtime\":1359317061942},\"tbtestpilot@labs.mozilla.com\":{\"descriptor\":\"C:\\\\Users\\\\Art\\\\AppData\\\\Roaming\\\\Thunderbird\\\\Profiles\\\\fgjgwxl3.default\\\\extensions\\\\tbtestpilot@labs.mozilla.com.xpi\",\"mtime\":1335644444000},\"{3ed8cc52-86fc-4613-9026-c1ef969da4c3}\":{\"descriptor\":\"C:\\\\Users\\\\Art\\\\AppData\\\\Roaming\\\\Thunderbird\\\\Profiles\\\\fgjgwxl3.default\\\\extensions\\\\{3ed8cc52-86fc-4613-9026-c1ef969da4c3}.xpi\",\"mtime\":1354389146000}}}]");
user_pref("extensions.installedDistroAddon.tbtestpilot@labs.mozilla.com", true);
user_pref("extensions.lastAppVersion", "20.0");
user_pref("extensions.lastPlatformVersion", "20.0");
user_pref("extensions.newAddons", "FiltersImportExport@mozilla.org,{3ed8cc52-86fc-4613-9026-c1ef969da4c3}");
user_pref("extensions.pendingOperations", false);
user_pref("extensions.shownSelectionUI", true);
user_pref("extensions.testpilot.deploymentRandomizer.tbweeklife", 96);
user_pref("extensions.testpilot.startDate.tbweeklife", "Tue Mar 27 2012 20:03:51 GMT-0500 (Central Daylight Time)");
user_pref("extensions.testpilot.taskstatus.tbweeklife", 3);
user_pref("extensions.update.notifyUser", false);
user_pref("filterimportexport.last_version", "1.3.7.6");
user_pref("font.internaluseonly.changed", true);
user_pref("font.name.monospace.el", "Consolas");
user_pref("font.name.monospace.tr", "Consolas");
user_pref("font.name.monospace.x-baltic", "Consolas");
user_pref("font.name.monospace.x-central-euro", "Consolas");
user_pref("font.name.monospace.x-cyrillic", "Consolas");
user_pref("font.name.monospace.x-unicode", "Consolas");
user_pref("font.name.monospace.x-western", "Consolas");
user_pref("font.name.sans-serif.el", "Calibri");
user_pref("font.name.sans-serif.tr", "Calibri");
user_pref("font.name.sans-serif.x-baltic", "Calibri");
user_pref("font.name.sans-serif.x-central-euro", "Calibri");
user_pref("font.name.sans-serif.x-cyrillic", "Calibri");
user_pref("font.name.sans-serif.x-unicode", "Calibri");
user_pref("font.name.sans-serif.x-western", "Calibri");
user_pref("font.name.serif.el", "Cambria");
user_pref("font.name.serif.tr", "Cambria");
user_pref("font.name.serif.x-baltic", "Cambria");
user_pref("font.name.serif.x-central-euro", "Cambria");
user_pref("font.name.serif.x-cyrillic", "Cambria");
user_pref("font.name.serif.x-unicode", "Cambria");
user_pref("font.name.serif.x-western", "Cambria");
user_pref("font.size.fixed.el", 14);
user_pref("font.size.fixed.tr", 14);
user_pref("font.size.fixed.x-baltic", 14);
user_pref("font.size.fixed.x-central-euro", 14);
user_pref("font.size.fixed.x-cyrillic", 14);
user_pref("font.size.fixed.x-unicode", 14);
user_pref("font.size.fixed.x-western", 14);
user_pref("font.size.variable.el", 17);
user_pref("font.size.variable.tr", 17);
user_pref("font.size.variable.x-baltic", 17);
user_pref("font.size.variable.x-central-euro", 17);
user_pref("font.size.variable.x-cyrillic", 17);
user_pref("font.size.variable.x-unicode", 17);
user_pref("font.size.variable.x-western", 17);
user_pref("gloda.facetview.hidetimeline", false);
user_pref("idle.lastDailyNotification", 1365740249);
user_pref("intl.charsetmenu.mailview.cache", "UTF-7, windows-1252, us-ascii, UTF-8, ISO-8859-15");
user_pref("ldap_2.prefs_migrated", true);
user_pref("ldap_2.servers.default.filename", "default.mab");
user_pref("ldap_2.servers.default.replication.lastChangeNumber", 0);
user_pref("ldap_2.servers.default.uri", "moz-abldapdirectory://default.mab");
user_pref("ldap_2.servers.history.replication.lastChangeNumber", 0);
user_pref("ldap_2.servers.pab.replication.lastChangeNumber", 0);
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.identities", "id1");
user_pref("mail.account.account2.server", "server2");
user_pref("mail.account.account3.identities", "id2");
user_pref("mail.account.account3.server", "server3");
user_pref("mail.account.account4.server", "server4");
user_pref("mail.accountmanager.accounts", "account1,account2,account4");
user_pref("mail.accountmanager.defaultaccount", "account2");
user_pref("mail.accountmanager.localfoldersserver", "server1");
user_pref("mail.append_preconfig_smtpservers.version", 2);
user_pref("mail.attachment.store.version", 1);
user_pref("mail.citation_color", "#FF6666");
user_pref("mail.compose.attach.dir", "O:\\1 - Photographs\\Kids\\Mark Young");
user_pref("mail.displayname.version", 1603);
user_pref("mail.folder.views.version", 1);
user_pref("mail.font.windows.version", 2);
user_pref("mail.identity.id1.archive_folder", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net/Archives");
user_pref("mail.identity.id1.attach_signature", true);
user_pref("mail.identity.id1.attach_vcard", false);
user_pref("mail.identity.id1.doBcc", false);
user_pref("mail.identity.id1.doBccList", "");
user_pref("mail.identity.id1.draft_folder", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net/Drafts");
user_pref("mail.identity.id1.drafts_folder_picker_mode", "0");
user_pref("mail.identity.id1.encryptionpolicy", 0);
user_pref("mail.identity.id1.fcc_folder", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net/Sent");
user_pref("mail.identity.id1.fcc_folder_picker_mode", "0");
user_pref("mail.identity.id1.fullName", "Art Masson");
user_pref("mail.identity.id1.htmlSigFormat", false);
user_pref("mail.identity.id1.reply_on_top", 1);
user_pref("mail.identity.id1.reply_to", "art@masson.ws");
user_pref("mail.identity.id1.sig_file", "C:\\Users\\Art\\Desktop\\sig.png");
user_pref("mail.identity.id1.sig_file-rel", "[ProfD]../../../../../Desktop/sig.png");
user_pref("mail.identity.id1.sig_on_fwd", true);
user_pref("mail.identity.id1.sign_mail", false);
user_pref("mail.identity.id1.smtpServer", "smtp1");
user_pref("mail.identity.id1.stationery_folder", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net/Templates");
user_pref("mail.identity.id1.tmpl_folder_picker_mode", "0");
user_pref("mail.identity.id1.useremail", "massonal@ix.netcom.com");
user_pref("mail.identity.id1.valid", true);
user_pref("mail.last_msg_movecopy_target_uri", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net/1%20-%20Steel%20Beam");
user_pref("mail.newsrc_root", "C:\\Users\\Arthur Masson\\AppData\\Roaming\\Thunderbird\\Profiles\\9v6t1q8x.default\\News");
user_pref("mail.newsrc_root-rel", "[ProfD]News");
user_pref("mail.openMessageBehavior.version", 1);
user_pref("mail.preferences.advanced.selectedTabIndex", 3);
user_pref("mail.preferences.compose.selectedTabIndex", 0);
user_pref("mail.preferences.display.selectedTabIndex", 0);
user_pref("mail.preferences.privacy.selectedTabIndex", 1);
user_pref("mail.preferences.security.selectedTabIndex", 3);
user_pref("mail.purge.ask", false);
user_pref("mail.purge_threshold_migrated", true);
user_pref("mail.rights.version", 1);
user_pref("mail.root.nntp", "C:\\Users\\Arthur Masson\\AppData\\Roaming\\Thunderbird\\Profiles\\9v6t1q8x.default\\News");
user_pref("mail.root.nntp-rel", "[ProfD]News");
user_pref("mail.root.none", "C:\\Documents and Settings\\Arthur Masson\\Application Data\\Thunderbird\\Profiles\\9v6t1q8x.default\\Mail");
user_pref("mail.root.none-rel", "[ProfD]Mail");
user_pref("mail.root.pop3", "C:\\Documents and Settings\\Arthur Masson\\Application Data\\Thunderbird\\Profiles\\9v6t1q8x.default\\Mail");
user_pref("mail.root.pop3-rel", "[ProfD]Mail");
user_pref("mail.server.server1.ageLimit", 30);
user_pref("mail.server.server1.applyToFlaggedMessages", false);
user_pref("mail.server.server1.cleanupBodies", false);
user_pref("mail.server.server1.daysToKeepBodies", 30);
user_pref("mail.server.server1.daysToKeepHdrs", 30);
user_pref("mail.server.server1.directory", "C:\\Users\\Art Masson\\AppData\\Roaming\\Thunderbird\\Profiles\\mfvb29m0.default\\Mail");
user_pref("mail.server.server1.directory-rel", "[ProfD]Mail");
user_pref("mail.server.server1.downloadByDate", false);
user_pref("mail.server.server1.downloadUnreadOnly", false);
user_pref("mail.server.server1.hostname", "Local Folders");
user_pref("mail.server.server1.keepUnreadOnly", false);
user_pref("mail.server.server1.moveOnSpam", true);
user_pref("mail.server.server1.name", "Local Folders");
user_pref("mail.server.server1.numHdrsToKeep", 30);
user_pref("mail.server.server1.spamActionTargetAccount", "mailbox://nobody@Local%20Folders");
user_pref("mail.server.server1.spamActionTargetFolder", "mailbox://nobody@Local%20Folders/Junk");
user_pref("mail.server.server1.storeContractID", "@mozilla.org/msgstore/berkeleystore;1");
user_pref("mail.server.server1.type", "none");
user_pref("mail.server.server1.userName", "nobody");
user_pref("mail.server.server2.ageLimit", 1);
user_pref("mail.server.server2.applyToFlaggedMessages", false);
user_pref("mail.server.server2.cleanupBodies", false);
user_pref("mail.server.server2.daysToKeepBodies", 1);
user_pref("mail.server.server2.daysToKeepHdrs", 30);
user_pref("mail.server.server2.directory", "C:\\Mail");
user_pref("mail.server.server2.directory-rel", "[ProfD]../../../../../../../Mail");
user_pref("mail.server.server2.downloadByDate", false);
user_pref("mail.server.server2.downloadUnreadOnly", false);
user_pref("mail.server.server2.download_on_biff", true);
user_pref("mail.server.server2.hostname", "pop.earthlink.net");
user_pref("mail.server.server2.keepUnreadOnly", false);
user_pref("mail.server.server2.login_at_startup", true);
user_pref("mail.server.server2.moveOnSpam", true);
user_pref("mail.server.server2.name", "art@masson.ws");
user_pref("mail.server.server2.numHdrsToKeep", 30);
user_pref("mail.server.server2.purgeSpam", true);
user_pref("mail.server.server2.realhostname", "pop.earthlink.net");
user_pref("mail.server.server2.socketType", 0);
user_pref("mail.server.server2.spamActionTargetAccount", "mailbox://massonal%40ix.netcom.com@pop.earthlink.net");
user_pref("mail.server.server2.spamActionTargetFolder", "mailbox://nobody@Local%20Folders/Junk");
user_pref("mail.server.server2.storeContractID", "@mozilla.org/msgstore/berkeleystore;1");
user_pref("mail.server.server2.type", "pop3");
user_pref("mail.server.server2.userName", "massonal@ix.netcom.com");
user_pref("mail.server.server4.directory", "C:\\Users\\Art Masson\\AppData\\Roaming\\Thunderbird\\Profiles\\mfvb29m0.default\\Mail\\smart mailboxes");
user_pref("mail.server.server4.directory-rel", "[ProfD]Mail/smart mailboxes");
user_pref("mail.server.server4.hidden", true);
user_pref("mail.server.server4.hostname", "smart mailboxes");
user_pref("mail.server.server4.name", "Smart Folders");
user_pref("mail.server.server4.storeContractID", "@mozilla.org/msgstore/berkeleystore;1");
user_pref("mail.server.server4.type", "none");
user_pref("mail.server.server4.userName", "nobody");
user_pref("mail.shell.checkDefaultClient", false);
user_pref("mail.smtp.defaultserver", "smtp1");
user_pref("mail.smtpserver.smtp1.authMethod", 3);
user_pref("mail.smtpserver.smtp1.auth_method", 1);
user_pref("mail.smtpserver.smtp1.hostname", "smtpauth.earthlink.net");
user_pref("mail.smtpserver.smtp1.port", 587);
user_pref("mail.smtpserver.smtp1.trySecAuth", false);
user_pref("mail.smtpserver.smtp1.try_ssl", 2);
user_pref("mail.smtpserver.smtp1.useSecAuth", false);
user_pref("mail.smtpserver.smtp1.username", "massonal@ix.netcom.com");
user_pref("mail.smtpservers", "smtp1");
user_pref("mail.spam.logging.enabled", true);
user_pref("mail.spam.manualMark", true);
user_pref("mail.spam.version", 1);
user_pref("mail.startup.enabledMailCheckOnce", true);
user_pref("mail.taskbar.lastgroupid", "8216C80C92C4E828");
user_pref("mail.ui-rdf.version", 5);
user_pref("mail.winsearch.enable", true);
user_pref("mail.winsearch.firstRunDone", true);
user_pref("mail.winsearch.global_reindex_time", "1246642745");
user_pref("mail.winsearch.lastFolderIndexedUri", "");
user_pref("mailnews.database.global.datastore.id", "d26912e5-9506-4199-b463-81383198638");
user_pref("mailnews.display.html_sanitizer.allowed_tags.migrated", true);
user_pref("mailnews.downloadToTempFile", true);
user_pref("mailnews.quotingPrefs.version", 1);
user_pref("mailnews.start_page.enabled", false);
user_pref("mailnews.start_page_override.mstone", "20.0");
user_pref("mailnews.tags.$label1.color", "#FF0000");
user_pref("mailnews.tags.$label1.tag", "Important");
user_pref("mailnews.tags.$label2.color", "#FF9900");
user_pref("mailnews.tags.$label2.tag", "Work");
user_pref("mailnews.tags.$label3.color", "#009900");
user_pref("mailnews.tags.$label3.tag", "Personal");
user_pref("mailnews.tags.$label4.color", "#3333FF");
user_pref("mailnews.tags.$label4.tag", "To Do");
user_pref("mailnews.tags.$label5.color", "#993399");
user_pref("mailnews.tags.$label5.tag", "Later");
user_pref("mailnews.tags.version", 2);
user_pref("mailnews.ui.junk.firstuse", false);
user_pref("messenger.save.dir", "O:\\1 - Photographs\\Animals\\Tundra");
user_pref("network.cookie.prefsMigrated", true);
user_pref("places.database.lastMaintenance", 1365310569);
user_pref("places.history.expiration.transient_current_max_pages", 104858);
user_pref("places.history.expiration.transient_optimal_database_size", 167772160);
user_pref("plugins.update.notifyUser", true);
user_pref("pref.downloads.disable_button.edit_actions", false);
user_pref("pref.privacy.disable_button.view_passwords", false);
user_pref("print.print_printer", "Canon Inkjet i960");
user_pref("print.printer_Canon_Inkjet_i960.print_bgcolor", true);
user_pref("print.printer_Canon_Inkjet_i960.print_bgimages", true);
user_pref("print.printer_Canon_Inkjet_i960.print_command", "");
user_pref("print.printer_Canon_Inkjet_i960.print_downloadfonts", false);
user_pref("print.printer_Canon_Inkjet_i960.print_edge_bottom", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_edge_left", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_edge_right", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_edge_top", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_evenpages", true);
user_pref("print.printer_Canon_Inkjet_i960.print_footercenter", "");
user_pref("print.printer_Canon_Inkjet_i960.print_footerleft", "&PT");
user_pref("print.printer_Canon_Inkjet_i960.print_footerright", "&D");
user_pref("print.printer_Canon_Inkjet_i960.print_headercenter", "");
user_pref("print.printer_Canon_Inkjet_i960.print_headerleft", "&T");
user_pref("print.printer_Canon_Inkjet_i960.print_headerright", "&U");
user_pref("print.printer_Canon_Inkjet_i960.print_in_color", true);
user_pref("print.printer_Canon_Inkjet_i960.print_margin_bottom", "0.5");
user_pref("print.printer_Canon_Inkjet_i960.print_margin_left", "0.5");
user_pref("print.printer_Canon_Inkjet_i960.print_margin_right", "0.5");
user_pref("print.printer_Canon_Inkjet_i960.print_margin_top", "0.5");
user_pref("print.printer_Canon_Inkjet_i960.print_oddpages", true);
user_pref("print.printer_Canon_Inkjet_i960.print_orientation", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_pagedelay", 500);
user_pref("print.printer_Canon_Inkjet_i960.print_paper_data", 1);
user_pref("print.printer_Canon_Inkjet_i960.print_paper_height", " 11.00");
user_pref("print.printer_Canon_Inkjet_i960.print_paper_size", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_paper_size_type", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_paper_size_unit", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_paper_width", "  8.50");
user_pref("print.printer_Canon_Inkjet_i960.print_reversed", false);
user_pref("print.printer_Canon_Inkjet_i960.print_scaling", "  1.00");
user_pref("print.printer_Canon_Inkjet_i960.print_shrink_to_fit", true);
user_pref("print.printer_Canon_Inkjet_i960.print_to_file", false);
user_pref("print.printer_Canon_Inkjet_i960.print_to_filename", "");
user_pref("print.printer_Canon_Inkjet_i960.print_unwriteable_margin_bottom", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_unwriteable_margin_left", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_unwriteable_margin_right", 0);
user_pref("print.printer_Canon_Inkjet_i960.print_unwriteable_margin_top", 0);
user_pref("print_printer", "Canon Inkjet i960");
user_pref("printer_Canon_Inkjet_i960.print_bgcolor", false);
user_pref("printer_Canon_Inkjet_i960.print_bgimages", false);
user_pref("printer_Canon_Inkjet_i960.print_colorspace", "");
user_pref("printer_Canon_Inkjet_i960.print_command", "");
user_pref("printer_Canon_Inkjet_i960.print_downloadfonts", false);
user_pref("printer_Canon_Inkjet_i960.print_edge_bottom", 0);
user_pref("printer_Canon_Inkjet_i960.print_edge_left", 0);
user_pref("printer_Canon_Inkjet_i960.print_edge_right", 0);
user_pref("printer_Canon_Inkjet_i960.print_edge_top", 0);
user_pref("printer_Canon_Inkjet_i960.print_evenpages", true);
user_pref("printer_Canon_Inkjet_i960.print_footercenter", "");
user_pref("printer_Canon_Inkjet_i960.print_footerleft", "&PT");
user_pref("printer_Canon_Inkjet_i960.print_footerright", "&D");
user_pref("printer_Canon_Inkjet_i960.print_headercenter", "");
user_pref("printer_Canon_Inkjet_i960.print_headerleft", "&T");
user_pref("printer_Canon_Inkjet_i960.print_headerright", "&U");
user_pref("printer_Canon_Inkjet_i960.print_in_color", true);
user_pref("printer_Canon_Inkjet_i960.print_margin_bottom", "0.5");
user_pref("printer_Canon_Inkjet_i960.print_margin_left", "0.5");
user_pref("printer_Canon_Inkjet_i960.print_margin_right", "0.5");
user_pref("printer_Canon_Inkjet_i960.print_margin_top", "0.5");
user_pref("printer_Canon_Inkjet_i960.print_oddpages", true);
user_pref("printer_Canon_Inkjet_i960.print_orientation", 0);
user_pref("printer_Canon_Inkjet_i960.print_page_delay", 50);
user_pref("printer_Canon_Inkjet_i960.print_paper_data", 1);
user_pref("printer_Canon_Inkjet_i960.print_paper_height", " 11.00");
user_pref("printer_Canon_Inkjet_i960.print_paper_name", "");
user_pref("printer_Canon_Inkjet_i960.print_paper_size_type", 0);
user_pref("printer_Canon_Inkjet_i960.print_paper_size_unit", 0);
user_pref("printer_Canon_Inkjet_i960.print_paper_width", "  8.50");
user_pref("printer_Canon_Inkjet_i960.print_plex_name", "");
user_pref("printer_Canon_Inkjet_i960.print_resolution_name", "");
user_pref("printer_Canon_Inkjet_i960.print_reversed", false);
user_pref("printer_Canon_Inkjet_i960.print_scaling", "  1.00");
user_pref("printer_Canon_Inkjet_i960.print_shrink_to_fit", false);
user_pref("printer_Canon_Inkjet_i960.print_to_file", false);
user_pref("printer_Canon_Inkjet_i960.print_to_filename", "");
user_pref("printer_Canon_Inkjet_i960.print_unwriteable_margin_bottom", 0);
user_pref("printer_Canon_Inkjet_i960.print_unwriteable_margin_left", 0);
user_pref("printer_Canon_Inkjet_i960.print_unwriteable_margin_right", 0);
user_pref("printer_Canon_Inkjet_i960.print_unwriteable_margin_top", 0);
user_pref("security.OCSP.disable_button.managecrl", false);
user_pref("security.disable_button.openCertManager", false);
user_pref("security.disable_button.openDeviceManager", false);
user_pref("storage.vacuum.last.index", 1);
user_pref("storage.vacuum.last.places.sqlite", 1364532558);
user_pref("toolkit.telemetry.prompted", true);
user_pref("wallet.caveat", true);
user_pref("xpinstall.whitelist.add", "");
user_pref("xpinstall.whitelist.add.36", "");
(Reporter)

Comment 17

5 years ago
Is the problem that I am "missing" the Sent.msf file on the path with my other active msf files? If so, how do I create one with default settings?  Shouldn't TB create one if it is "missing" when I exit TB ?
Hi Art. 

Do you still see this problem when using version 45?
Component: Message Reader UI → Folder and Message Lists
Flags: needinfo?(art)
Summary: Default settings in SENT folder keep getting lost → Default column settings in SENT folder keep getting lost
Whiteboard: [closeme 2016-10-15]
(In reply to Art Masson from comment #17)
> Is the problem that I am "missing" the Sent.msf file on the path with my
> other active msf files? If so, how do I create one with default settings? 
> Shouldn't TB create one if it is "missing" when I exit TB ?

Art,
THanks for all the great details. One might speculate this could be caused by automatic compact, which had some fixes in recent years. But I don't recall see this being reported recently.  If you still see the issue or know why it was happening please comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(art)
Resolution: --- → INCOMPLETE
Summary: Default column settings in SENT folder keep getting lost → Default column settings in SENT folder keep getting lost, if Sent folder is selected when Thunderbird was shut down
Whiteboard: [closeme 2016-10-15]
Oh, I see Art emailed me a month ago "No..this problem went away a few versions ago...."
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.